aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts/libXft/Makefile
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2013-03-20 13:49:00 +0800
committermezz <mezz@FreeBSD.org>2013-03-20 13:49:00 +0800
commit2d9f53ed2d082115d93a77309cae82c80c73c92f (patch)
tree3816304320ff81ca88af8e812a3583ef42400cb4 /x11-fonts/libXft/Makefile
parenta1525b46250dc30abc307d964e9bd64b1fa558b6 (diff)
downloadfreebsd-ports-gnome-2d9f53ed2d082115d93a77309cae82c80c73c92f.tar.gz
freebsd-ports-gnome-2d9f53ed2d082115d93a77309cae82c80c73c92f.tar.zst
freebsd-ports-gnome-2d9f53ed2d082115d93a77309cae82c80c73c92f.zip
-Update to 2.3.1.
-Update the header. In this version has removed the xft-config, but I have brought it back to avoid require test in the pointyhat-exp/tinderbox to see if it will break old ports that needs xft-config. PR: ports/176801 Submitted by: Pierre Guinoiseau <pierre@guinoiseau.eu>
Diffstat (limited to 'x11-fonts/libXft/Makefile')
-rw-r--r--x11-fonts/libXft/Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/x11-fonts/libXft/Makefile b/x11-fonts/libXft/Makefile
index 696f58073d65..1e96411ec3c5 100644
--- a/x11-fonts/libXft/Makefile
+++ b/x11-fonts/libXft/Makefile
@@ -1,16 +1,12 @@
-# New ports collection makefile for: Xft
-# Date created: 06 October 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+#Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libXft
-PORTVERSION= 2.1.14
+PORTVERSION= 2.3.1
CATEGORIES= x11-fonts
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A client-sided font API for X applications
+COMMENT= Client-sided font API for X applications
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
@@ -19,7 +15,18 @@ RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
XORG_CAT= lib
USE_XORG= xproto:both xrender
-MAN1= xft-config.1
MAN3= Xft.3
+post-extract:
+ @${CP} ${FILESDIR}/xft-config.in \
+ ${WRKSRC}/xft-config.in
+
+post-patch:
+ @${REINPLACE_CMD} -e '/ac_config_files/s|xft\.pc|xft\.pc xft-config|' \
+ ${WRKSRC}/configure
+
+post-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/xft-config \
+ ${PREFIX}/bin/
+
.include <bsd.port.mk>