aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts/p5-Font-TTFMetrics/Makefile
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2007-03-19 04:26:35 +0800
committeraaron <aaron@FreeBSD.org>2007-03-19 04:26:35 +0800
commit91a19f71c6e4235d17ce0d913410164ea65dc3b0 (patch)
tree3ab816079404a3ebf89f50e981b28a1a7a9eaa1f /x11-fonts/p5-Font-TTFMetrics/Makefile
parent174c236bf552301a3407b91a3ad5a763d0ce2930 (diff)
downloadfreebsd-ports-gnome-91a19f71c6e4235d17ce0d913410164ea65dc3b0.tar.gz
freebsd-ports-gnome-91a19f71c6e4235d17ce0d913410164ea65dc3b0.tar.zst
freebsd-ports-gnome-91a19f71c6e4235d17ce0d913410164ea65dc3b0.zip
Adding port x11-fonts/p5-Font-TTFMetrics, a Perl module for parsing TTF files.
Diffstat (limited to 'x11-fonts/p5-Font-TTFMetrics/Makefile')
-rw-r--r--x11-fonts/p5-Font-TTFMetrics/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-fonts/p5-Font-TTFMetrics/Makefile b/x11-fonts/p5-Font-TTFMetrics/Makefile
new file mode 100644
index 000000000000..d2c94937301c
--- /dev/null
+++ b/x11-fonts/p5-Font-TTFMetrics/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Font-TTFMetrics
+# Date created: 18 Mar 2007
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Font-TTFMetrics
+PORTVERSION= 0.1
+CATEGORIES= x11-fonts perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Font
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= A parser for the TTF file
+
+MAN3= Font::TTFMetrics.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>