aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts/proggy_fonts
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-11-24 20:32:09 +0800
committeredwin <edwin@FreeBSD.org>2005-11-24 20:32:09 +0800
commit1fb1efd6c3cd63fcd10d21debed9361d59abf597 (patch)
tree2123ac8a5f23280729ae402a7c119efd215a0a84 /x11-fonts/proggy_fonts
parentc6217350efafb30a9811512eca5beaef8f45d7ff (diff)
downloadfreebsd-ports-gnome-1fb1efd6c3cd63fcd10d21debed9361d59abf597.tar.gz
freebsd-ports-gnome-1fb1efd6c3cd63fcd10d21debed9361d59abf597.tar.zst
freebsd-ports-gnome-1fb1efd6c3cd63fcd10d21debed9361d59abf597.zip
New port: x11-fonts/proggy_fonts a monospaced programming font
Proggy fonts are a set of monospaced programming fonts said to be perfect. PR: ports/84329 Submitted by: Li-Lun Wang (Leland Wang) <llwang@infor.org>
Diffstat (limited to 'x11-fonts/proggy_fonts')
-rw-r--r--x11-fonts/proggy_fonts/Makefile40
-rw-r--r--x11-fonts/proggy_fonts/distinfo18
-rw-r--r--x11-fonts/proggy_fonts/pkg-descr16
-rw-r--r--x11-fonts/proggy_fonts/pkg-plist12
4 files changed, 86 insertions, 0 deletions
diff --git a/x11-fonts/proggy_fonts/Makefile b/x11-fonts/proggy_fonts/Makefile
new file mode 100644
index 000000000000..c802fafe1a37
--- /dev/null
+++ b/x11-fonts/proggy_fonts/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: proggy_fonts
+# Date Created: 30 July 2005
+# Whom: Leland Wang <llwang@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= proggy_fonts
+PORTVERSION= 1.0
+CATEGORIES= x11-fonts
+MASTER_SITES= http://www.proggyfonts.com/download/
+DISTFILES= ProggyClean.pcf.gz ProggySquare.pcf.gz \
+ ProggySmall.pcf.gz ProggyTiny.pcf.gz \
+ ProggyCleanSZ.pcf.gz ProggySquareSZ.pcf.gz \
+ ProggyTinySZ.pcf.gz ProggyCleanSZBP.pcf.gz \
+ ProggyCleanCP.pcf.zip
+
+MAINTAINER= llwang@infor.org
+COMMENT= The perfect monospaced bitmap programming fonts
+
+RUN_DEPENDS= mkfontdir:${X_CLIENTS_PORT}
+
+USE_X_PREFIX= yes
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+XFONTDIR= ${PREFIX}/lib/X11/fonts/local
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKDIR}
+
+post-extract:
+ @(cd ${WRKDIR}; for i in *.zip; do ${UNZIP_CMD} $$i; done)
+
+do-install:
+ @${MKDIR} ${XFONTDIR}
+ @${INSTALL_DATA} ${WRKDIR}/*.pcf.gz ${XFONTDIR}
+ @(cd ${XFONTDIR}; mkfontdir)
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/proggy_fonts/distinfo b/x11-fonts/proggy_fonts/distinfo
new file mode 100644
index 000000000000..49b14c148235
--- /dev/null
+++ b/x11-fonts/proggy_fonts/distinfo
@@ -0,0 +1,18 @@
+MD5 (ProggyClean.pcf.gz) = 8b47c7957dd5b040b6e0a844589e3af9
+SIZE (ProggyClean.pcf.gz) = 4794
+MD5 (ProggySquare.pcf.gz) = 555e8657dffb4ae59e2ca8bb875a4b3e
+SIZE (ProggySquare.pcf.gz) = 4437
+MD5 (ProggySmall.pcf.gz) = 160c8af718da3cb1c9bee89cd8a57250
+SIZE (ProggySmall.pcf.gz) = 4256
+MD5 (ProggyTiny.pcf.gz) = 4e26d14fdeba03f245e0a865c0f6718e
+SIZE (ProggyTiny.pcf.gz) = 4300
+MD5 (ProggyCleanSZ.pcf.gz) = 7e188bebacbc6a9395a3c00796784a12
+SIZE (ProggyCleanSZ.pcf.gz) = 4798
+MD5 (ProggySquareSZ.pcf.gz) = 0500c08d68dd418df95af7b85c24049a
+SIZE (ProggySquareSZ.pcf.gz) = 4443
+MD5 (ProggyTinySZ.pcf.gz) = 475a1192098bc632da7355b947c87e1a
+SIZE (ProggyTinySZ.pcf.gz) = 4530
+MD5 (ProggyCleanSZBP.pcf.gz) = 8222f1ca7c2ca4755761c25ce5c76fb8
+SIZE (ProggyCleanSZBP.pcf.gz) = 4425
+MD5 (ProggyCleanCP.pcf.zip) = 7ccc9359ca1bca254a45744a16f38725
+SIZE (ProggyCleanCP.pcf.zip) = 8654
diff --git a/x11-fonts/proggy_fonts/pkg-descr b/x11-fonts/proggy_fonts/pkg-descr
new file mode 100644
index 000000000000..972fa4855ce8
--- /dev/null
+++ b/x11-fonts/proggy_fonts/pkg-descr
@@ -0,0 +1,16 @@
+The proggy programmer's fonts (Proggy Clean, Proggy Square, Proggy Small,
+and Proggy Tiny) are a set of fixed-width screen fonts that are designed
+for code listings. Each font only comes in one size that it looks good at.
+The fonts were optimized while coding in C or C++. For this reason,
+characters like the '*' were placed vertically centered, as '*' usually
+means dereference or multiply, but never 'to the power of' like in Fortran.
+The {}s are centered horizontally (as the author's coding style aligns
+braces vertically), the zero looks different from the capital oh, and there
+is never any confusion between ells, ones, and eyes. Additionally, the
+arithmetic operators (+ - * < >) are all axis aligned.
+
+Author: Tristan Grimmer
+WWW: http://www.proggyfonts.com/
+
+-- Leland Wang
+llwang@infor.org
diff --git a/x11-fonts/proggy_fonts/pkg-plist b/x11-fonts/proggy_fonts/pkg-plist
new file mode 100644
index 000000000000..718e40fd12c0
--- /dev/null
+++ b/x11-fonts/proggy_fonts/pkg-plist
@@ -0,0 +1,12 @@
+lib/X11/fonts/local/ProggyClean.pcf.gz
+lib/X11/fonts/local/ProggySquare.pcf.gz
+lib/X11/fonts/local/ProggySmall.pcf.gz
+lib/X11/fonts/local/ProggyTiny.pcf.gz
+lib/X11/fonts/local/ProggyCleanSZ.pcf.gz
+lib/X11/fonts/local/ProggySquareSZ.pcf.gz
+lib/X11/fonts/local/ProggyTinySZ.pcf.gz
+lib/X11/fonts/local/ProggyCleanSZBP.pcf.gz
+lib/X11/fonts/local/ProggyCleanCP.pcf.gz
+lib/X11/fonts/local/ProggyCleanSZCP.pcf.gz
+@exec (cd %D/lib/X11/fonts/local ; %D/bin/mkfontdir)
+@unexec (cd %D/lib/X11/fonts/local ; %D/bin/mkfontdir)