aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts/wqy
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-04-21 01:43:12 +0800
committermat <mat@FreeBSD.org>2015-04-21 01:43:12 +0800
commitc473982c20f72e187bc513e75d92c61592279b62 (patch)
treea226e53879990739ff48085f14fd0b28f0a0fd20 /x11-fonts/wqy
parent48404cec2fb66408318b6475e5fe6e16a564101f (diff)
downloadfreebsd-ports-gnome-c473982c20f72e187bc513e75d92c61592279b62.tar.gz
freebsd-ports-gnome-c473982c20f72e187bc513e75d92c61592279b62.tar.zst
freebsd-ports-gnome-c473982c20f72e187bc513e75d92c61592279b62.zip
Fix build with Perl 5.21.1+
Omitting % and @ on hash and array names is no longer permitted Really old Perl let you omit the @ on array names and the % on hash names in some spots. This has issued a deprecation warning since Perl 5.0, and is no longer permitted. With hat: perl@ Sponsored by: Absolight
Diffstat (limited to 'x11-fonts/wqy')
-rw-r--r--x11-fonts/wqy/Makefile1
-rw-r--r--x11-fonts/wqy/files/patch-wqy-unibit_bdfmerge.pl11
2 files changed, 12 insertions, 0 deletions
diff --git a/x11-fonts/wqy/Makefile b/x11-fonts/wqy/Makefile
index 0a8a3e4149cf..8986af5affa6 100644
--- a/x11-fonts/wqy/Makefile
+++ b/x11-fonts/wqy/Makefile
@@ -25,6 +25,7 @@ BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf
USE_XORG= x11
USES= fonts perl5
USE_PERL5= build
+NO_WRKSUBDIR= yes
FONTNAME= wqy
CONFDDIR= etc/fonts/conf.d
diff --git a/x11-fonts/wqy/files/patch-wqy-unibit_bdfmerge.pl b/x11-fonts/wqy/files/patch-wqy-unibit_bdfmerge.pl
new file mode 100644
index 000000000000..004879b4f84e
--- /dev/null
+++ b/x11-fonts/wqy/files/patch-wqy-unibit_bdfmerge.pl
@@ -0,0 +1,11 @@
+--- wqy-unibit/bdfmerge.pl.orig 2007-09-09 22:39:32 UTC
++++ wqy-unibit/bdfmerge.pl
+@@ -32,7 +32,7 @@ while(@ARGV>=1&& $ARGV[0]=~/^-{0,1}0[xX]
+ {
+ $startpos = hex($1);
+ $endpos=0;
+- $range=shift(ARGV);
++ $range=shift(@ARGV);
+ if($range=~/--0[xX]([0-9A-Fa-f]{0,6})/)
+ {
+ $endpos=hex($1);