aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts/xfed/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-04-01 22:54:57 +0800
committerasami <asami@FreeBSD.org>1995-04-01 22:54:57 +0800
commit35edcec8d330644ab59fea17ebfb3ba8397e9427 (patch)
tree7f0692d67567161c42e25916a920d2915cca30c9 /x11-fonts/xfed/Makefile
parent1ee19348fbb996c821cd7e252beb3805e9556ee0 (diff)
downloadfreebsd-ports-gnome-35edcec8d330644ab59fea17ebfb3ba8397e9427.tar.gz
freebsd-ports-gnome-35edcec8d330644ab59fea17ebfb3ba8397e9427.tar.zst
freebsd-ports-gnome-35edcec8d330644ab59fea17ebfb3ba8397e9427.zip
Pipe output of tar to "gzip --best" to ensure we get the exact same
tar.gz file every time.
Diffstat (limited to 'x11-fonts/xfed/Makefile')
-rw-r--r--x11-fonts/xfed/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/x11-fonts/xfed/Makefile b/x11-fonts/xfed/Makefile
index e8c97e967dbd..04af9f1ca326 100644
--- a/x11-fonts/xfed/Makefile
+++ b/x11-fonts/xfed/Makefile
@@ -3,7 +3,7 @@
# Date created: 7 December 1994
# Whom: asami
#
-# $Id: Makefile,v 1.5 1995/03/24 11:11:58 asami Exp $
+# $Id: Makefile,v 1.6 1995/04/01 12:51:21 jkh Exp $
#
USE_IMAKE= yes
@@ -33,7 +33,8 @@ fetch: pre-fetch
${NCFTP} ${NCFTPFLAGS} ${SOURCESITE}\{$$file\}); \
done; \
echo ">> Now creating a tarball ${DISTDIR}/${TARFILE}..."; \
- tar -C ${.CURDIR}/src -czf ${DISTDIR}/${TARFILE} xfed; \
+ tar -C ${.CURDIR}/src -cf - xfed | \
+ gzip --best > ${DISTDIR}/${TARFILE}; \
rm -rf ${.CURDIR}/src; \
fi
.endif