aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts/xfontselector
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
commitfd50192ea7567a034b59dfc96a1d112f8ccfa573 (patch)
tree6975c46330f04e77b17cb4d014c9d66ceb4f7a68 /x11-fonts/xfontselector
parent54d69c112debb52b84b6d174bd59479eec834fb7 (diff)
downloadfreebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.gz
freebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.zst
freebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.zip
${PERL} -> ${REINPLACE_CMD}
PR: 40784 Submitted by: corecode@corecode.ath.cx Reviewed by: flynn@energyhq.homeip.net
Diffstat (limited to 'x11-fonts/xfontselector')
-rw-r--r--x11-fonts/xfontselector/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/x11-fonts/xfontselector/Makefile b/x11-fonts/xfontselector/Makefile
index c652325acc5b..82aec633a52d 100644
--- a/x11-fonts/xfontselector/Makefile
+++ b/x11-fonts/xfontselector/Makefile
@@ -15,6 +15,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}-4
MAINTAINER= kde@freebsd.org
+USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_QT_VER= 2
MAKE_ENV= CXX="${CXX} ${QTCPPFLAGS} -I${X11BASE}/include" \
@@ -24,9 +25,9 @@ ALL_TARGET= # empty
MAN1= xfontselector.1
post-patch:
- @${PERL} -pi -e "s,^CXX,#CXX,g ; s,^CXXFLAGS,#CXXFLAGS,g ; \
+ @${REINPLACE_CMD} -e "s,^CXX,#CXX,g ; s,^CXXFLAGS,#CXXFLAGS,g ; \
s,^LIBS=,LIBS+=,g ; s,-lqt,-lqt2,g ; \
- s,\tmoc,\t${MOC},g" ${WRKSRC}/Makefile
+ s,moc ,${MOC} ,g" ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin