aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2013-01-25 19:36:43 +0800
committerrakuco <rakuco@FreeBSD.org>2013-01-25 19:36:43 +0800
commit88c928733bf255ec80ae27e04aebe0b5041acf97 (patch)
tree338fae817c706adf7425387bff1dc8810a57a8f6 /x11-fonts
parentf82feea9ae1e4bbba24083fee45acb3227ca140d (diff)
downloadfreebsd-ports-gnome-88c928733bf255ec80ae27e04aebe0b5041acf97.tar.gz
freebsd-ports-gnome-88c928733bf255ec80ae27e04aebe0b5041acf97.tar.zst
freebsd-ports-gnome-88c928733bf255ec80ae27e04aebe0b5041acf97.zip
Consola Mono is a monospaced font created for programming, text editors and
terminal-use. It is licensed under the SIL Open Font License v1.1.
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/consolamono-ttf/Makefile41
-rw-r--r--x11-fonts/consolamono-ttf/distinfo2
-rw-r--r--x11-fonts/consolamono-ttf/files/pkg-message.in8
-rw-r--r--x11-fonts/consolamono-ttf/pkg-descr8
-rw-r--r--x11-fonts/consolamono-ttf/pkg-plist6
6 files changed, 66 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index c8c1ff35f2d4..616824323fb0 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -17,6 +17,7 @@
SUBDIR += charis-compact
SUBDIR += code2000
SUBDIR += code2001
+ SUBDIR += consolamono-ttf
SUBDIR += croscorefonts-fonts-ttf
SUBDIR += cyberbit-ttfonts
SUBDIR += cyr-rfx
diff --git a/x11-fonts/consolamono-ttf/Makefile b/x11-fonts/consolamono-ttf/Makefile
new file mode 100644
index 000000000000..f4f8120e720f
--- /dev/null
+++ b/x11-fonts/consolamono-ttf/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= consolamono-ttf
+PORTVERSION= 20121116
+CATEGORIES= x11-fonts
+MASTER_SITES= http://openfontlibrary.org/assets/downloads/consolamono/7c6fa601cdc82be054fb2b8fd7e3c8cc/
+DISTNAME= consolamono
+
+MAINTAINER= rakuco@FreeBSD.org
+COMMENT= Monospace font created for programming, text editors and terminal-use
+
+LICENSE= OFL
+LICENSE_NAME= SIL OPEN FONT LICENSE Version 1.1
+LICENSE_FILE= ${WRKSRC}/SIL\ -\ Open\ Font\ License.txt
+LICENSE_PERMS= auto-accept
+
+BUILD_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
+ mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
+
+USE_ZIP= yes
+
+FONTDIR= lib/X11/fonts/ConsolaMono
+PKGMESSAGE= ${WRKDIR}/pkg-message
+PLIST_SUB= FONTDIR=${FONTDIR}
+SUB_FILES= pkg-message
+SUB_LIST= FONTDIR=${FONTDIR}
+WRKSRC= ${WRKDIR}/Consola\ Mono
+
+do-build:
+ @cd ${WRKSRC}/ && \
+ ${LOCALBASE}/bin/mkfontscale && \
+ ${LOCALBASE}/bin/mkfontdir
+
+do-install:
+ ${MKDIR} ${PREFIX}/${FONTDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} *.ttf fonts.* ${PREFIX}/${FONTDIR}/
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/consolamono-ttf/distinfo b/x11-fonts/consolamono-ttf/distinfo
new file mode 100644
index 000000000000..506cc9b5f170
--- /dev/null
+++ b/x11-fonts/consolamono-ttf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (consolamono.zip) = 7792d34cf5fc46a58fdc630828b854228e9e0b51fc914639f777456dac375086
+SIZE (consolamono.zip) = 1114416
diff --git a/x11-fonts/consolamono-ttf/files/pkg-message.in b/x11-fonts/consolamono-ttf/files/pkg-message.in
new file mode 100644
index 000000000000..798a45125c89
--- /dev/null
+++ b/x11-fonts/consolamono-ttf/files/pkg-message.in
@@ -0,0 +1,8 @@
+
+You can start using the fonts by following these instructions:
+
+Add the following line to the "Files" section of your X.org configuration
+file:
+
+ FontPath "%%PREFIX%%/%%FONTDIR%%/"
+
diff --git a/x11-fonts/consolamono-ttf/pkg-descr b/x11-fonts/consolamono-ttf/pkg-descr
new file mode 100644
index 000000000000..6af173f30415
--- /dev/null
+++ b/x11-fonts/consolamono-ttf/pkg-descr
@@ -0,0 +1,8 @@
+'Consola Mono' is the monospace font especially created for programming, text
+editors and for terminal-use.
+
+'Consola Mono' is a Unicode typeface font that supports all languages that use
+the Latin, Greek, Cyrillic script and its variants, and could be expanded to
+support other scripts.
+
+WWW: http://openfontlibrary.org/en/font/consolamono
diff --git a/x11-fonts/consolamono-ttf/pkg-plist b/x11-fonts/consolamono-ttf/pkg-plist
new file mode 100644
index 000000000000..5a45367f1457
--- /dev/null
+++ b/x11-fonts/consolamono-ttf/pkg-plist
@@ -0,0 +1,6 @@
+%%FONTDIR%%/ConsolaMono.ttf
+%%FONTDIR%%/ConsolaMono-Bold.ttf
+%%FONTDIR%%/fonts.dir
+%%FONTDIR%%/fonts.scale
+@unexec rm %D/%%FONTDIR%%/fonts.cache-1 2>/dev/null || true
+@dirrm %%FONTDIR%%