aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2014-04-25 23:25:16 +0800
committerkevlo <kevlo@FreeBSD.org>2014-04-25 23:25:16 +0800
commitb6c4f2134c6decf8c66008ae0686625fdf0ae6bf (patch)
tree8cddd5dca7cfc136ef5e94ba986360a900263382 /x11-fonts
parent3ac2631511b4a5e8c772d72b2e639df0e58ce6b2 (diff)
downloadfreebsd-ports-gnome-b6c4f2134c6decf8c66008ae0686625fdf0ae6bf.tar.gz
freebsd-ports-gnome-b6c4f2134c6decf8c66008ae0686625fdf0ae6bf.tar.zst
freebsd-ports-gnome-b6c4f2134c6decf8c66008ae0686625fdf0ae6bf.zip
Import comic-neue 1.1.
Comic Neue is a set of free fonts providing an alternative to Microsoft’s popular Comic Sans font.
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/comic-neue/Makefile32
-rw-r--r--x11-fonts/comic-neue/distinfo2
-rw-r--r--x11-fonts/comic-neue/files/pkg-message.in8
-rw-r--r--x11-fonts/comic-neue/pkg-descr4
-rw-r--r--x11-fonts/comic-neue/pkg-plist15
6 files changed, 62 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index cd2afa91e52d..ad6609fae408 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -23,6 +23,7 @@
SUBDIR += code2000
SUBDIR += code2001
SUBDIR += comfortaa-ttf
+ SUBDIR += comic-neue
SUBDIR += consolamono-ttf
SUBDIR += croscorefonts-fonts-ttf
SUBDIR += cyberbit-ttfonts
diff --git a/x11-fonts/comic-neue/Makefile b/x11-fonts/comic-neue/Makefile
new file mode 100644
index 000000000000..704d46f01da8
--- /dev/null
+++ b/x11-fonts/comic-neue/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= comic-neue
+PORTVERSION= 1.1
+CATEGORIES= x11-fonts
+MASTER_SITES= http://comicneue.com/
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= Free Comic Sans alternative
+
+LICENSE= CC0
+LICENSE_NAME= CC0 1.0 Universal
+LICENSE_TEXT= See http://creativecommons.org/publicdomain/zero/1.0/
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= zip
+NO_BUILD= yes
+
+PLIST_SUB= FONTSDIR="${FONTSDIR:S|${PREFIX}/||}"
+FONTSDIR= ${PREFIX}/lib/X11/fonts/${PORTNAME}
+SUB_FILES= pkg-message
+SUB_LIST= FONTSDIR=${FONTSDIR}
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.ttf ${STAGEDIR}${FONTSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/comic-neue/distinfo b/x11-fonts/comic-neue/distinfo
new file mode 100644
index 000000000000..5bf62e18375c
--- /dev/null
+++ b/x11-fonts/comic-neue/distinfo
@@ -0,0 +1,2 @@
+SHA256 (comic-neue-1.1.zip) = f9442fc42252db62ea788bd0247ae0e74571678d1dbd3e3edc229389050d6923
+SIZE (comic-neue-1.1.zip) = 760818
diff --git a/x11-fonts/comic-neue/files/pkg-message.in b/x11-fonts/comic-neue/files/pkg-message.in
new file mode 100644
index 000000000000..82f1671ede7a
--- /dev/null
+++ b/x11-fonts/comic-neue/files/pkg-message.in
@@ -0,0 +1,8 @@
+Make sure that the freetype module is loaded. If it is not, add the following
+line to the "Modules" section of your X Windows configuration file:
+
+ Load "freetype"
+
+Add the following line to the "Files" section of X Windows configuration file:
+
+ FontPath "%%FONTSDIR%%/"
diff --git a/x11-fonts/comic-neue/pkg-descr b/x11-fonts/comic-neue/pkg-descr
new file mode 100644
index 000000000000..972c1b47ae05
--- /dev/null
+++ b/x11-fonts/comic-neue/pkg-descr
@@ -0,0 +1,4 @@
+Comic Neue is a set of free fonts providing an alternative to
+Microsoft's popular Comic Sans font.
+
+WWW: http://comicneue.com/
diff --git a/x11-fonts/comic-neue/pkg-plist b/x11-fonts/comic-neue/pkg-plist
new file mode 100644
index 000000000000..f71fbec33bb4
--- /dev/null
+++ b/x11-fonts/comic-neue/pkg-plist
@@ -0,0 +1,15 @@
+%%FONTSDIR%%/ComicNeue-Angular-Bold-Oblique.ttf
+%%FONTSDIR%%/ComicNeue-Angular-Bold.ttf
+%%FONTSDIR%%/ComicNeue-Angular-Light-Oblique.ttf
+%%FONTSDIR%%/ComicNeue-Angular-Light.ttf
+%%FONTSDIR%%/ComicNeue-Angular-Regular-Oblique.ttf
+%%FONTSDIR%%/ComicNeue-Angular-Regular.ttf
+%%FONTSDIR%%/ComicNeue-Bold-Oblique.ttf
+%%FONTSDIR%%/ComicNeue-Bold.ttf
+%%FONTSDIR%%/ComicNeue-Light-Oblique.ttf
+%%FONTSDIR%%/ComicNeue-Light.ttf
+%%FONTSDIR%%/ComicNeue-Regular-Oblique.ttf
+%%FONTSDIR%%/ComicNeue-Regular.ttf
+@unexec /bin/rm %D/%%FONTSDIR%%/fonts.cache-1 2>/dev/null || /usr/bin/true
+@dirrm %%FONTSDIR%%
+@exec %%LOCALBASE%%/bin/fc-cache -f -v %D/%%FONTSDIR%% || /usr/bin/true