aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2005-07-12 00:47:36 +0800
committermi <mi@FreeBSD.org>2005-07-12 00:47:36 +0800
commit22fd45811d5b02c392bb5e8e4c67d6cc3a052a89 (patch)
tree9c659bfa933b4a71571c866e0896ecdd31ce3a1e /x11-fonts
parentb722c898553800ac6c2d90aebb820a37ff9cd808 (diff)
downloadfreebsd-ports-gnome-22fd45811d5b02c392bb5e8e4c67d6cc3a052a89.tar.gz
freebsd-ports-gnome-22fd45811d5b02c392bb5e8e4c67d6cc3a052a89.tar.zst
freebsd-ports-gnome-22fd45811d5b02c392bb5e8e4c67d6cc3a052a89.zip
Change the software's Makefile to run `mkfontdir' in the destination
directory after install instead of the ${WRKSRC} after build. This works around a bug in Xorg's mkfontdir, which lists both -- the bdf-sources and the pcf-binary fonts -- in the generated fonts.dir.
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/geminifonts/Makefile1
-rw-r--r--x11-fonts/geminifonts/files/patch-gz18
2 files changed, 18 insertions, 1 deletions
diff --git a/x11-fonts/geminifonts/Makefile b/x11-fonts/geminifonts/Makefile
index 6b00723ca67f..3f87749b6351 100644
--- a/x11-fonts/geminifonts/Makefile
+++ b/x11-fonts/geminifonts/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gemini
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= x11-fonts
MASTER_SITES= http://www.brama.com/compute/unix/
PKGNAMEPREFIX= koi8-u-
diff --git a/x11-fonts/geminifonts/files/patch-gz b/x11-fonts/geminifonts/files/patch-gz
index fff0a7159118..9ca25d421b66 100644
--- a/x11-fonts/geminifonts/files/patch-gz
+++ b/x11-fonts/geminifonts/files/patch-gz
@@ -1,5 +1,21 @@
--- Makefile Sun Dec 31 11:22:34 1995
-+++ Makefile Sun Jan 21 11:54:00 2001
++++ Makefile Mon Jul 11 12:37:08 2005
+@@ -53,5 +53,4 @@
+
+ all: $(SRC) $(ROMAN) $(SLANT) $(BOLD) $(BSLANT) $(FIXED)
+- mkfontdir .
+
+ src: $(SRC)
+@@ -63,6 +62,7 @@
+ install:
+ -mkdir $(DESTDIR)
+- for i in $(ROMAN) $(SLANT) $(BOLD) $(BSLANT) $(FIXED) fonts.dir fonts.alias;\
+- do install -c -m 444 $$i $(DESTDIR)/$$i; done
++ ${BSD_INSTALL_DATA} $(ROMAN) $(SLANT) $(BOLD) $(BSLANT) $(FIXED) \
++ fonts.alias $(DESTDIR)/
++ mkfontdir $(DESTDIR)
+
+ package:
@@ -75 +75 @@
- bdftopcf -t $< | compress > $@
+ bdftopcf -t $< | gzip -9 > $@