aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-01-22 00:19:47 +0800
committermarcus <marcus@FreeBSD.org>2003-01-22 00:19:47 +0800
commitca9599ef175a67f533406e9d3ba01d930fb8a6e5 (patch)
treed9ea39c5338ce3306880ff65b52b2ae72c6b4b33 /x11-fonts
parent465a5949c3a20c6af8c5dd344e2eec65d2d69b04 (diff)
downloadfreebsd-ports-gnome-ca9599ef175a67f533406e9d3ba01d930fb8a6e5.tar.gz
freebsd-ports-gnome-ca9599ef175a67f533406e9d3ba01d930fb8a6e5.tar.zst
freebsd-ports-gnome-ca9599ef175a67f533406e9d3ba01d930fb8a6e5.zip
Make sure fc-cache is run after installation for both the port and
package. PR: 47283
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/fontconfig/Makefile6
-rw-r--r--x11-fonts/fontconfig/pkg-install12
2 files changed, 18 insertions, 0 deletions
diff --git a/x11-fonts/fontconfig/Makefile b/x11-fonts/fontconfig/Makefile
index edcef2a7e8d3..6ddb7d338c86 100644
--- a/x11-fonts/fontconfig/Makefile
+++ b/x11-fonts/fontconfig/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fontconfig
PORTVERSION= 2.1
+PORTREVISION= 1
CATEGORIES= x11-fonts
MASTER_SITES= http://www.fontconfig.org/fontconfig/release/
DISTNAME= fcpackage.${PORTVERSION:S/./_/}
@@ -32,4 +33,9 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/fontconfig
pre-patch:
@${REINPLACE_CMD} -e 's|[(]LIBDIR[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
+post-install:
+.if !defined(PACKAGE_BUILDING)
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
+
.include <bsd.port.mk>
diff --git a/x11-fonts/fontconfig/pkg-install b/x11-fonts/fontconfig/pkg-install
new file mode 100644
index 000000000000..a6228fb8397e
--- /dev/null
+++ b/x11-fonts/fontconfig/pkg-install
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+if [ -n "${PACKAGE_BUILDING}" ]; then
+ exit 0
+fi
+
+PATH=/bin:/usr/bin:/sbin:/usr/sbin:/usr/X11R6/bin:${PATH}
+export PATH
+
+if [ "$2" = "POST-INSTALL" ]; then
+ fc-cache >/dev/null 2>&1
+fi