aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-11-02 06:21:13 +0800
committermiwi <miwi@FreeBSD.org>2008-11-02 06:21:13 +0800
commitf63063141ffde8ea8586f2f9d3d5a6a41475f44a (patch)
tree4c04ef64b8e0ee1ae8a7933405b2e959f7c2c7a3 /x11-fonts
parentbecfc7a8b76c8a4448813f6f5584d181ad554b9f (diff)
downloadfreebsd-ports-gnome-f63063141ffde8ea8586f2f9d3d5a6a41475f44a.tar.gz
freebsd-ports-gnome-f63063141ffde8ea8586f2f9d3d5a6a41475f44a.tar.zst
freebsd-ports-gnome-f63063141ffde8ea8586f2f9d3d5a6a41475f44a.zip
MonteCarlo is a bitmap font suitable for code editors. All the characters
have the same width, which is ideal for alignment. It is loosely derived from the look of the Monaco screen font that was available on the old MacOS systems. Some changes have been made to make it easier to differentiate certain symbols. WWW: http://bok.net/MonteCarlo/ PR: ports/128249 Submitted by: Dennis Herrmann <adox at mcx2.org>
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/montecarlo_fonts/Makefile34
-rw-r--r--x11-fonts/montecarlo_fonts/distinfo3
-rw-r--r--x11-fonts/montecarlo_fonts/pkg-descr7
4 files changed, 45 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index b1f4d5f58026..87c28de7717a 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -102,6 +102,7 @@
SUBDIR += mkfontdir
SUBDIR += mkfontscale
SUBDIR += mkitalic
+ SUBDIR += montecarlo_fonts
SUBDIR += mozilla-fonts
SUBDIR += nexfontsel
SUBDIR += nucleus
diff --git a/x11-fonts/montecarlo_fonts/Makefile b/x11-fonts/montecarlo_fonts/Makefile
new file mode 100644
index 000000000000..8f16445e1af4
--- /dev/null
+++ b/x11-fonts/montecarlo_fonts/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: montecarlo_fonts
+# Date Created: 20 Okt 2008
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= montecarlo_fonts
+PORTVERSION= 1.0
+CATEGORIES= x11-fonts
+MASTER_SITES= http://bok.net/MonteCarlo/downloads/
+DISTNAME= MonteCarlo-PCF
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= adox@mcx2.org
+COMMENT= A monospace font
+
+RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+
+USE_XORG= x11
+NO_BUILD= yes
+FONTDIR= ${PREFIX}/lib/X11/fonts/montecarlo
+
+PLIST_FILES= lib/X11/fonts/montecarlo/fonts.dir \
+ lib/X11/fonts/montecarlo//MonteCarloBold.pcf \
+ lib/X11/fonts/montecarlo//MonteCarloMedium.pcf
+PLIST_DIRS= lib/X11/fonts/montecarlo
+
+do-install:
+ @${MKDIR} ${FONTDIR}
+ @${INSTALL_DATA} ${WRKSRC}/*.pcf ${FONTDIR}
+ @(cd ${FONTDIR}; mkfontdir)
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/montecarlo_fonts/distinfo b/x11-fonts/montecarlo_fonts/distinfo
new file mode 100644
index 000000000000..72e335e6075c
--- /dev/null
+++ b/x11-fonts/montecarlo_fonts/distinfo
@@ -0,0 +1,3 @@
+MD5 (MonteCarlo-PCF.tgz) = 503ecb321266fdd2b2baa0a052d8543c
+SHA256 (MonteCarlo-PCF.tgz) = dc0380aad8dc72f4a98d2ae7dc110311f61f484eda748e16a942ccbb4486063a
+SIZE (MonteCarlo-PCF.tgz) = 5749
diff --git a/x11-fonts/montecarlo_fonts/pkg-descr b/x11-fonts/montecarlo_fonts/pkg-descr
new file mode 100644
index 000000000000..fea1be7d2d64
--- /dev/null
+++ b/x11-fonts/montecarlo_fonts/pkg-descr
@@ -0,0 +1,7 @@
+MonteCarlo is a bitmap font suitable for code editors. All the characters
+have the same width, which is ideal for alignment. It is loosely derived
+from the look of the Monaco screen font that was available on the old MacOS
+systems. Some changes have been made to make it easier to differentiate
+certain symbols.
+
+WWW: http://bok.net/MonteCarlo/