aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2005-03-07 06:38:41 +0800
committerthierry <thierry@FreeBSD.org>2005-03-07 06:38:41 +0800
commita664a159628b9465e3641360d59b7eefeb59905c (patch)
tree33f4879902b59a3cafa2984235964fc6971de0d6 /x11-fonts
parentfe8bccc68f732342f31f9ef43b03e66b7c10517f (diff)
downloadfreebsd-ports-gnome-a664a159628b9465e3641360d59b7eefeb59905c.tar.gz
freebsd-ports-gnome-a664a159628b9465e3641360d59b7eefeb59905c.tar.zst
freebsd-ports-gnome-a664a159628b9465e3641360d59b7eefeb59905c.zip
Add mathfonts 4.1, mathematica fonts for MathML-enabled Mozilla.
These fonts are required to display MathML pages with Mozilla or Firefox.
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/mathfonts/Makefile68
-rw-r--r--x11-fonts/mathfonts/distinfo2
-rw-r--r--x11-fonts/mathfonts/files/pkg-message.in16
-rw-r--r--x11-fonts/mathfonts/pkg-descr6
-rw-r--r--x11-fonts/mathfonts/pkg-plist27
6 files changed, 120 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index 0b04d709dabc..294ac8f6f9fa 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -37,6 +37,7 @@
SUBDIR += libXft
SUBDIR += linux-fontconfig
SUBDIR += linux-urw-fonts
+ SUBDIR += mathfonts
SUBDIR += mkbold
SUBDIR += mkbold-mkitalic
SUBDIR += mkitalic
diff --git a/x11-fonts/mathfonts/Makefile b/x11-fonts/mathfonts/Makefile
new file mode 100644
index 000000000000..f89ac222e521
--- /dev/null
+++ b/x11-fonts/mathfonts/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: mathfonts
+# Date created: 6 March 2005
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mathfonts
+PORTVERSION= 4.1 # Don't upgrade this port if not supported by MathML-enabled Mozilla
+# # Please check http://www.mozilla.org/projects/mathml/fonts/
+CATEGORIES= x11-fonts
+MASTER_SITES= http://support.wolfram.com/mathematica/systems/windows/general/
+DISTNAME= MathFonts_TrueType
+EXTRACT_SUFX= .exe
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Mathematica fonts for MathML-enabled Mozilla
+
+BUILD_DEPENDS= ttmkfdir:${PORTSDIR}/x11-fonts/ttmkfdir
+
+RESTRICTED= "no distribution of the fonts allowed"
+NO_CDROM= ${RESTRICTED}
+
+.if !defined(WITHOUT_FULLMATHML)
+BUILD_DEPENDS+= ${LOCALBASE}/Acrobat5/Resource/Font/Symbol:${PORTSDIR}/print/acroread
+RUN_DEPENDS+= ${FONTSBASE}/texcm-ttf/cmr10.ttf:${PORTSDIR}/x11-fonts/texcm-ttf \
+ ${LOCALBASE}/Acrobat5/Resource/Font/Symbol:${PORTSDIR}/print/acroread
+PLIST_SUB= ACROREAD=""
+.else
+PLIST_SUB= ACROREAD="@comment "
+.endif
+
+USE_X_PREFIX= yes
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+
+SUB_FILES= pkg-message
+SUB_LIST= FONTSDIR="${FONTSDIR}"
+PLIST_SUB+= FONTSDIR="${FONTSDIR:S|${PREFIX}/||}"
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+FONTNAME= ${PORTNAME}
+FONTSBASE= ${X11BASE}/lib/X11/fonts
+FONTSDIR= ${PREFIX}/lib/X11/fonts/${FONTNAME}
+TTMKFDIR_CMD= ${X11BASE}/bin/ttmkfdir
+
+do-build:
+ ${TTMKFDIR_CMD} -c -f ${FONTNAME} -d ${WRKSRC} | ${CAT} -n | \
+ ${SED} -e 's|^ 1|100000|' | ${SORT} -r | \
+ ${CUT} -c 8- > ${WRKSRC}/fonts.scale
+ ${CP} ${WRKSRC}/fonts.scale ${WRKSRC}/fonts.dir
+
+do-install:
+ ${MKDIR} ${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.ttf ${WRKSRC}/fonts.scale ${WRKSRC}/fonts.dir \
+ ${FONTSDIR}
+.if !defined(WITHOUT_FULLMATHML)
+ ${LN} -fs ${LOCALBASE}/Acrobat5/Resource/Font/Symbol ${FONTSDIR}
+.endif
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/mathfonts/distinfo b/x11-fonts/mathfonts/distinfo
new file mode 100644
index 000000000000..3ed448bfbee1
--- /dev/null
+++ b/x11-fonts/mathfonts/distinfo
@@ -0,0 +1,2 @@
+MD5 (mathfonts-4.1/MathFonts_TrueType.exe) = 6c952203198216c53aa968d4d12b0c61
+SIZE (mathfonts-4.1/MathFonts_TrueType.exe) = 702976
diff --git a/x11-fonts/mathfonts/files/pkg-message.in b/x11-fonts/mathfonts/files/pkg-message.in
new file mode 100644
index 000000000000..4938eab365a7
--- /dev/null
+++ b/x11-fonts/mathfonts/files/pkg-message.in
@@ -0,0 +1,16 @@
+You can start using the fonts by following these instructions:
+
+Make sure that the freetype module is loaded. If it is not, add the following
+line to the "Modules" section of your X Windows configuration file:
+
+ Load "freetype"
+
+Add the following line to the "Files" section of X Windows configuration file:
+
+ FontPath "%%FONTSDIR%%/"
+
+Note: your X Windows configuration file is typically /etc/X11/XF86Config
+if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
+
+To test your installation, check the following URL:
+<http://swissnet.ai.mit.edu/projects/intelligent-book/mathml/mathml-example.xml>
diff --git a/x11-fonts/mathfonts/pkg-descr b/x11-fonts/mathfonts/pkg-descr
new file mode 100644
index 000000000000..f4093f8d5019
--- /dev/null
+++ b/x11-fonts/mathfonts/pkg-descr
@@ -0,0 +1,6 @@
+Mathematica 4.1 Fonts, to be used for example with a Xft enabled version
+of Mozilla or Firefox, in order to display MathML webpages.
+
+With this port, you should also install the port x11-fonts/texcm-ttf.
+
+WWW: http://support.wolfram.com/mathematica/systems/windows/general/latestfonts.html
diff --git a/x11-fonts/mathfonts/pkg-plist b/x11-fonts/mathfonts/pkg-plist
new file mode 100644
index 000000000000..618f4e511419
--- /dev/null
+++ b/x11-fonts/mathfonts/pkg-plist
@@ -0,0 +1,27 @@
+@comment $FreeBSD$
+%%FONTSDIR%%/fonts.dir
+%%FONTSDIR%%/fonts.scale
+%%FONTSDIR%%/math1___.ttf
+%%FONTSDIR%%/math1b__.ttf
+%%FONTSDIR%%/math1m__.ttf
+%%FONTSDIR%%/math1mb_.ttf
+%%FONTSDIR%%/math2___.ttf
+%%FONTSDIR%%/math2b__.ttf
+%%FONTSDIR%%/math2m__.ttf
+%%FONTSDIR%%/math2mb_.ttf
+%%FONTSDIR%%/math3___.ttf
+%%FONTSDIR%%/math3b__.ttf
+%%FONTSDIR%%/math3m__.ttf
+%%FONTSDIR%%/math3mb_.ttf
+%%FONTSDIR%%/math4___.ttf
+%%FONTSDIR%%/math4b__.ttf
+%%FONTSDIR%%/math4m__.ttf
+%%FONTSDIR%%/math4mb_.ttf
+%%FONTSDIR%%/math5___.ttf
+%%FONTSDIR%%/math5b__.ttf
+%%FONTSDIR%%/math5m__.ttf
+%%FONTSDIR%%/math5mb_.ttf
+%%ACROREAD%%@exec ln -fs %%LOCALBASE%%/Acrobat5/Resource/Font/Symbol %D/%%FONTSDIR%%
+%%ACROREAD%%@unexec rm %D/%%FONTSDIR%%/Symbol
+@unexec rm %D/%%FONTSDIR%%/fonts.cache-1 2>/dev/null || true
+@dirrm %%FONTSDIR%%