aboutsummaryrefslogtreecommitdiffstats
path: root/x11-servers/x2x
diff options
context:
space:
mode:
authorgrog <grog@FreeBSD.org>2000-09-03 16:06:08 +0800
committergrog <grog@FreeBSD.org>2000-09-03 16:06:08 +0800
commitbfb528b2294ec1948cb9e381ba88f44ad3f388b0 (patch)
treefed583b7a1d712e9dc850615294ed83ee10de797 /x11-servers/x2x
parentd39e786550bdb361276ee81f3fcba960ad072ca1 (diff)
downloadfreebsd-ports-gnome-bfb528b2294ec1948cb9e381ba88f44ad3f388b0.tar.gz
freebsd-ports-gnome-bfb528b2294ec1948cb9e381ba88f44ad3f388b0.tar.zst
freebsd-ports-gnome-bfb528b2294ec1948cb9e381ba88f44ad3f388b0.zip
Initial import of x2x.
Obtained from: David Chaiken <chaiken@pa.dec.com> x2x allows the keyboard and mouse on one ("from") X display to be used to control another ("to") X display. Since x2x uses the XTEST extension, the "to" X display must support XTEST. In the default interface, x2x puts a window on the "from" display. This window is labeled with the name of the "to" display. Keystrokes typed into this window go to the window on the "to" display that has the input focus. Clicking on the x2x window causes the mouse on the "from" display to control the cursor on the "to" display. Perform- ing a subsequent multiple button click on the "to" display returns control to the "from" display. If the -east or -west options are specified on the command line, x2x starts up with a different interface. When the mouse moves to the (east or west) side of the default screen on the "from" display, the cursor slides over to the "to" display. When the mouse returns to to side of the "to" display that it entered, it slides back onto the "from" display.
Diffstat (limited to 'x11-servers/x2x')
-rw-r--r--x11-servers/x2x/Makefile25
-rw-r--r--x11-servers/x2x/distinfo1
-rw-r--r--x11-servers/x2x/files/patch-aa10
-rw-r--r--x11-servers/x2x/pkg-comment1
-rw-r--r--x11-servers/x2x/pkg-descr24
-rw-r--r--x11-servers/x2x/pkg-plist3
6 files changed, 64 insertions, 0 deletions
diff --git a/x11-servers/x2x/Makefile b/x11-servers/x2x/Makefile
new file mode 100644
index 000000000000..1b6350a68cfb
--- /dev/null
+++ b/x11-servers/x2x/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: x2x
+# Date created: 3 September 2000
+# Whom: grog
+#
+# $FreeBSD$
+#
+
+PORTNAME= x2x
+PORTVERSION= 1.27
+CATEGORIES= x11
+MASTER_SITES= http://gatekeeper.dec.com/pub/DEC/SRC/x2x/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= grog@FreeBSD.org
+
+USE_IMAKE= yes
+USE_GMAKE= yes
+MAKE_ENV+= MAKE=${GMAKE}
+MANCOMPRESSED= yes
+MAN1= x2x.1
+
+do-install:
+ cd ${WRKSRC}; make install; make install.man
+
+.include <bsd.port.mk>
diff --git a/x11-servers/x2x/distinfo b/x11-servers/x2x/distinfo
new file mode 100644
index 000000000000..feb4a72c0621
--- /dev/null
+++ b/x11-servers/x2x/distinfo
@@ -0,0 +1 @@
+MD5 (x2x-1.27.tar.gz) = 3d1bc863f3209ec37caf7f57bde7e8f0
diff --git a/x11-servers/x2x/files/patch-aa b/x11-servers/x2x/files/patch-aa
new file mode 100644
index 000000000000..ceab5355f6f8
--- /dev/null
+++ b/x11-servers/x2x/files/patch-aa
@@ -0,0 +1,10 @@
+--- Imakefile~ Thu Aug 21 01:44:52 1997
++++ Imakefile Sun Sep 3 16:44:47 2000
+@@ -10,3 +10,7 @@
+ CDEBUGFLAGS = -O
+
+ ComplexProgramTarget(x2x)
++# Added by Greg Lehey <grog@FreeBSD.org> for FreeBSD port
++x2x.man: x2x.1
++ rm -f x2x.man
++ ln x2x.1 x2x.man
diff --git a/x11-servers/x2x/pkg-comment b/x11-servers/x2x/pkg-comment
new file mode 100644
index 000000000000..92fc8960478c
--- /dev/null
+++ b/x11-servers/x2x/pkg-comment
@@ -0,0 +1 @@
+A program to link multiple X servers together \ No newline at end of file
diff --git a/x11-servers/x2x/pkg-descr b/x11-servers/x2x/pkg-descr
new file mode 100644
index 000000000000..b421aa4832b4
--- /dev/null
+++ b/x11-servers/x2x/pkg-descr
@@ -0,0 +1,24 @@
+x2x allows the keyboard and mouse on one ("from") X display to be used
+to control another ("to") X display. Since x2x uses the XTEST
+extension, the "to" X display must support XTEST.
+
+In the default interface, x2x puts a window on the "from" display.
+This window is labeled with the name of the "to" display. Keystrokes
+typed into this window go to the window on the "to" display that has
+the input focus. Clicking on the x2x window causes the mouse on the
+"from" display to control the cursor on the "to" display. Perform-
+ing a subsequent multiple button click on the "to" display returns
+control to the "from" display.
+
+If the -east or -west options are specified on the command line, x2x
+starts up with a different interface. When the mouse moves to the
+(east or west) side of the default screen on the "from" display, the
+cursor slides over to the "to" display. When the mouse returns to to
+side of the "to" display that it entered, it slides back onto the
+"from" display.
+
+Unless the -nosel option is specified, x2x relays X selections from
+one display to the other.
+
+Greg Lehey
+grog@FreeBSD.org
diff --git a/x11-servers/x2x/pkg-plist b/x11-servers/x2x/pkg-plist
new file mode 100644
index 000000000000..8e785c9168fe
--- /dev/null
+++ b/x11-servers/x2x/pkg-plist
@@ -0,0 +1,3 @@
+@cwd /usr/X11R6
+bin/x2x
+lib/X11/doc/html/x2x.1.html