aboutsummaryrefslogtreecommitdiffstats
path: root/x11-servers/xephyr/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-08-17 00:15:19 +0800
committeradamw <adamw@FreeBSD.org>2014-08-17 00:15:19 +0800
commit26d5ecdffb4dfdde918f2b31335f8ce637567914 (patch)
tree75c21562e06237b0c50b44ac6a71b0ac894bde7c /x11-servers/xephyr/Makefile
parent8c1b4ca40642de199e203520012ec59995bf9426 (diff)
downloadfreebsd-ports-gnome-26d5ecdffb4dfdde918f2b31335f8ce637567914.tar.gz
freebsd-ports-gnome-26d5ecdffb4dfdde918f2b31335f8ce637567914.tar.zst
freebsd-ports-gnome-26d5ecdffb4dfdde918f2b31335f8ce637567914.zip
Because this is a slave port, it cannot load bsd.port.pre.mk before defining
the do-install target. This means that the test for .if defined(WITH_NEW_XORG) will always be false unless it's actually set in make.conf. WITH_NEW_XORG is automatically set for OSVERSION > 100704, but the port can't access that. Apply a really inelegant kludge that simply tries to install the manpage from both possible places. One will fail, and one will succeed.
Diffstat (limited to 'x11-servers/xephyr/Makefile')
-rw-r--r--x11-servers/xephyr/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/x11-servers/xephyr/Makefile b/x11-servers/xephyr/Makefile
index 6b33cf0bb6d8..c5cc7d916ee9 100644
--- a/x11-servers/xephyr/Makefile
+++ b/x11-servers/xephyr/Makefile
@@ -23,10 +23,10 @@ PLIST_FILES= bin/Xephyr man/man1/Xephyr.1.gz
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hw/kdrive/ephyr/Xephyr ${STAGEDIR}${PREFIX}/bin/
-.if defined(WITH_NEW_XORG)
- ${INSTALL_MAN} ${WRKSRC}/hw/kdrive/ephyr/man/Xephyr.1 ${STAGEDIR}${PREFIX}/man/man1/
-.else
- ${INSTALL_MAN} ${WRKSRC}/hw/kdrive/ephyr/Xephyr.1 ${STAGEDIR}${PREFIX}/man/man1/
-.endif
+#.if defined(WITH_NEW_XORG)
+ -${INSTALL_MAN} ${WRKSRC}/hw/kdrive/ephyr/man/Xephyr.1 ${STAGEDIR}${PREFIX}/man/man1/
+#.else
+ -${INSTALL_MAN} ${WRKSRC}/hw/kdrive/ephyr/Xephyr.1 ${STAGEDIR}${PREFIX}/man/man1/
+#.endif
.include "${MASTERDIR}/Makefile"