aboutsummaryrefslogtreecommitdiffstats
path: root/x11-servers
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2017-11-29 15:21:04 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:01:44 +0800
commit7fb3fa0eba6d491b358b5d27040f783727a374a7 (patch)
tree2069abdd3095ddc039e814e8af27c367c58bcd37 /x11-servers
parent918b591b49ad7c609cdb4b76eac5167bf528cbe9 (diff)
downloadfreebsd-ports-gnome-7fb3fa0eba6d491b358b5d27040f783727a374a7.tar.gz
freebsd-ports-gnome-7fb3fa0eba6d491b358b5d27040f783727a374a7.tar.zst
freebsd-ports-gnome-7fb3fa0eba6d491b358b5d27040f783727a374a7.zip
x11-servers/xorg-server: Fix dashed/dotted line rendering with GLAMOR.
When drawing dashed lines with GLAMOR, they were drawn partially or as a regular (solid) line, depending on the OpenGL backend. It behaved so because screen pixmap was bound as the dash and sampling its alpha, which is usually just 1.0 (no dashing at all). Upstream bug: https://bugs.freedesktop.org/show_bug.cgi?id=99708 Fixed by: Eric Anholt (it's a pity that anholt@ no longer works on FreeBSD) Silence from: x11@
Diffstat (limited to 'x11-servers')
-rw-r--r--x11-servers/xorg-server/Makefile2
-rw-r--r--x11-servers/xorg-server/files/patch-glamor_glamor__dash.c27
2 files changed, 28 insertions, 1 deletions
diff --git a/x11-servers/xorg-server/Makefile b/x11-servers/xorg-server/Makefile
index 7d712814fee1..7b275af548a7 100644
--- a/x11-servers/xorg-server/Makefile
+++ b/x11-servers/xorg-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= xorg-server
PORTVERSION?= 1.18.4
-PORTREVISION?= 5
+PORTREVISION?= 6
PORTEPOCH?= 1
CATEGORIES= x11-servers
MASTER_SITES= XORG/individual/xserver
diff --git a/x11-servers/xorg-server/files/patch-glamor_glamor__dash.c b/x11-servers/xorg-server/files/patch-glamor_glamor__dash.c
new file mode 100644
index 000000000000..3255e4bd706c
--- /dev/null
+++ b/x11-servers/xorg-server/files/patch-glamor_glamor__dash.c
@@ -0,0 +1,27 @@
+From: Eric Anholt <eric@anholt.net>
+Date: Wed Mar 15 17:51:46 2017 -0700
+Subject: [PATCH]glamor: Fix dashed line rendering.
+Patch-mainline: fe0b297420fc1de8a7fab28457d0864b3182e967
+References: boo#1021803
+Signed-off-by: Max Staudt <mstaudt@suse.de>
+
+We were binding the screen pixmap as the dash and sampling its alpha,
+which is usually just 1.0 (no dashing at all).
+
+Please cherry-pick this to active stable branches.
+
+Signed-off-by: Eric Anholt <eric@anholt.net>
+Reviewed-by: Keith Packard <keithp@keithp.com>
+Reviewed-by: Michel Dänzer <michel.daenzer@amd.com>
+
+--- glamor/glamor_dash.c.orig 2016-07-18 19:08:16 UTC
++++ glamor/glamor_dash.c
+@@ -146,7 +146,7 @@ glamor_dash_setup(DrawablePtr drawable, GCPtr gc)
+ goto bail;
+
+ dash_pixmap = glamor_get_dash_pixmap(gc);
+- dash_priv = glamor_get_pixmap_private(pixmap);
++ dash_priv = glamor_get_pixmap_private(dash_pixmap);
+
+ if (!GLAMOR_PIXMAP_PRIV_HAS_FBO(dash_priv))
+ goto bail;