aboutsummaryrefslogtreecommitdiffstats
path: root/x11-servers
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2014-12-24 04:40:58 +0800
committerak <ak@FreeBSD.org>2014-12-24 04:40:58 +0800
commit3c30267ae8bea9b4824f0c6e2eae81403f97fe15 (patch)
treef113c2da9cfbabcc2853233a1ed3aec6d711f03e /x11-servers
parent73383cc8d9a63d168737ebf145049aa1c2789b1e (diff)
downloadfreebsd-ports-gnome-3c30267ae8bea9b4824f0c6e2eae81403f97fe15.tar.gz
freebsd-ports-gnome-3c30267ae8bea9b4824f0c6e2eae81403f97fe15.tar.zst
freebsd-ports-gnome-3c30267ae8bea9b4824f0c6e2eae81403f97fe15.zip
- Fix AutoAddDevices option when config/devd backend is used
Reported by: Jonathan Chen <jonc@chen.org.nz>, lightside@gmx.com, many others Approved by: x11 (dumbbell, kwm)
Diffstat (limited to 'x11-servers')
-rw-r--r--x11-servers/xorg-server/Makefile4
-rw-r--r--x11-servers/xorg-server/files/patch-hw_xfree86_common_xf86Xinput.c9
2 files changed, 11 insertions, 2 deletions
diff --git a/x11-servers/xorg-server/Makefile b/x11-servers/xorg-server/Makefile
index f54cd438881c..2725363c9a8f 100644
--- a/x11-servers/xorg-server/Makefile
+++ b/x11-servers/xorg-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= xorg-server
PORTVERSION= 1.14.7
-PORTREVISION?= 0
+PORTREVISION?= 1
PORTEPOCH?= 1
CATEGORIES= x11-servers
MASTER_SITES= XORG
@@ -25,7 +25,7 @@ SLAVE_PORT?= no
OPTIONS_SUB= yes
OPTIONS_DEFINE= SUID
OPTIONS_RADIO= CONF
-OPTIONS_RADIO_CONF= HAL DEVD
+OPTIONS_RADIO_CONF= HAL DEVD
SUID_DESC= Install the Xorg server with setuid bit set
HAL_DESC= Compile with HAL config support
DEVD_DESC= Use devd for autoconfiguration of input devices
diff --git a/x11-servers/xorg-server/files/patch-hw_xfree86_common_xf86Xinput.c b/x11-servers/xorg-server/files/patch-hw_xfree86_common_xf86Xinput.c
new file mode 100644
index 000000000000..0260fb86b780
--- /dev/null
+++ b/x11-servers/xorg-server/files/patch-hw_xfree86_common_xf86Xinput.c
@@ -0,0 +1,9 @@
+Index: hw/xfree86/common/xf86Xinput.c
+@@ -942,6 +942,7 @@
+ if (strcmp(key, "_source") == 0 &&
+ (strcmp(value, "server/hal") == 0 ||
+ strcmp(value, "server/udev") == 0 ||
++ strcmp(value, "server/devd") == 0 ||
+ strcmp(value, "server/wscons") == 0)) {
+ is_auto = 1;
+ if (!xf86Info.autoAddDevices) {