aboutsummaryrefslogtreecommitdiffstats
path: root/x11-themes/clearlooks/Makefile
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-04-14 07:43:23 +0800
committerahze <ahze@FreeBSD.org>2005-04-14 07:43:23 +0800
commitd07743e63e8e6a581bc0522242fb1e8902ca5653 (patch)
treeae1bb8c8ab3358734548a365096f81b34d57730c /x11-themes/clearlooks/Makefile
parenteb91361714b6527c110f6f569bed0583cda41661 (diff)
downloadfreebsd-ports-gnome-d07743e63e8e6a581bc0522242fb1e8902ca5653.tar.gz
freebsd-ports-gnome-d07743e63e8e6a581bc0522242fb1e8902ca5653.tar.zst
freebsd-ports-gnome-d07743e63e8e6a581bc0522242fb1e8902ca5653.zip
- Argghhh, fix one last conflicting file with gtk-engines [1]
Pointed out by: mezz
Diffstat (limited to 'x11-themes/clearlooks/Makefile')
-rw-r--r--x11-themes/clearlooks/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/x11-themes/clearlooks/Makefile b/x11-themes/clearlooks/Makefile
index 1ba9a76d0dd9..22ffea32b375 100644
--- a/x11-themes/clearlooks/Makefile
+++ b/x11-themes/clearlooks/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= clearlooks
PORTVERSION= 0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-themes
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= clearlooks
@@ -20,6 +20,7 @@ USE_BZIP2= yes
USE_LIBTOOL_VER=15
USE_GNOME= gtk20
USE_X_PREFIX= yes
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LDFLAGS="-L${X11BASE}/lib"
@@ -64,4 +65,10 @@ pre-everything::
fi
.endif
+.if ${PORTNAME} != "clearlooks"
+post-patch:
+ @${REINPLACE_CMD} -e 's|gtkrc||' \
+ ${WRKSRC}/themes/Clearlooks/gtk-2.0/Makefile.in
+.endif
+
.include <bsd.port.post.mk>