aboutsummaryrefslogtreecommitdiffstats
path: root/x11-themes/gnome-splashscreen-manager
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2007-02-23 09:11:20 +0800
committerahze <ahze@FreeBSD.org>2007-02-23 09:11:20 +0800
commit4292a647a9cee6f339ed9067fd241e8f551105fe (patch)
tree434019df4692b612bd61d0e06310a03e4ef286a7 /x11-themes/gnome-splashscreen-manager
parent9058e6987fde46d78b93ff699081bcd469b477bb (diff)
downloadfreebsd-ports-gnome-4292a647a9cee6f339ed9067fd241e8f551105fe.tar.gz
freebsd-ports-gnome-4292a647a9cee6f339ed9067fd241e8f551105fe.tar.zst
freebsd-ports-gnome-4292a647a9cee6f339ed9067fd241e8f551105fe.zip
Fix crash if no splash is set
Obtained from: Ubuntu
Diffstat (limited to 'x11-themes/gnome-splashscreen-manager')
-rw-r--r--x11-themes/gnome-splashscreen-manager/Makefile2
-rw-r--r--x11-themes/gnome-splashscreen-manager/files/patch-lib_gnome-splachscreen-manager_ui_main_window.rb11
2 files changed, 12 insertions, 1 deletions
diff --git a/x11-themes/gnome-splashscreen-manager/Makefile b/x11-themes/gnome-splashscreen-manager/Makefile
index 54507e356935..d9effd64062c 100644
--- a/x11-themes/gnome-splashscreen-manager/Makefile
+++ b/x11-themes/gnome-splashscreen-manager/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnome-splashscreen-manager
PORTVERSION= 0.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-themes
MASTER_SITES= http://www.miketech.net/gnome-art/download/
DISTNAME= gnome-art-${PORTVERSION}
diff --git a/x11-themes/gnome-splashscreen-manager/files/patch-lib_gnome-splachscreen-manager_ui_main_window.rb b/x11-themes/gnome-splashscreen-manager/files/patch-lib_gnome-splachscreen-manager_ui_main_window.rb
new file mode 100644
index 000000000000..7716eac4e5f0
--- /dev/null
+++ b/x11-themes/gnome-splashscreen-manager/files/patch-lib_gnome-splachscreen-manager_ui_main_window.rb
@@ -0,0 +1,11 @@
+--- lib/gnome-splashscreen-manager/ui/main_window.rb.orig Thu Feb 22 20:01:13 2007
++++ lib/gnome-splashscreen-manager/ui/main_window.rb Thu Feb 22 20:01:34 2007
+@@ -422,7 +422,7 @@
+
+ #Add old splash screen
+ def add_old_splash_screen
+- if (@old_splash_screen == "")
++ if (@old_splash_screen == "" || @old_splash_screen == nil)
+ return
+ end
+