aboutsummaryrefslogtreecommitdiffstats
path: root/x11-themes/kde4-windeco-crystal/Makefile
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-06-13 05:00:42 +0800
committeroliver <oliver@FreeBSD.org>2005-06-13 05:00:42 +0800
commitbdf17e8a8e155c53c30318e3e4c67bbcfc480d18 (patch)
treecce893a0e0870ea1f3f3e751145bac51cdbd5ddd /x11-themes/kde4-windeco-crystal/Makefile
parentb37c6d3328b0430fd096470126a072b70f0ff89a (diff)
downloadfreebsd-ports-gnome-bdf17e8a8e155c53c30318e3e4c67bbcfc480d18.tar.gz
freebsd-ports-gnome-bdf17e8a8e155c53c30318e3e4c67bbcfc480d18.tar.zst
freebsd-ports-gnome-bdf17e8a8e155c53c30318e3e4c67bbcfc480d18.zip
Add kde-windeco-crystal 0.9.2, transparent KDE window decoration.
PR: 80598 Submitted by: Shane <decept0@gmail.com>
Diffstat (limited to 'x11-themes/kde4-windeco-crystal/Makefile')
-rw-r--r--x11-themes/kde4-windeco-crystal/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-themes/kde4-windeco-crystal/Makefile b/x11-themes/kde4-windeco-crystal/Makefile
new file mode 100644
index 000000000000..46982186f926
--- /dev/null
+++ b/x11-themes/kde4-windeco-crystal/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: crystal
+# Date created: March 15th, 2005
+# Whom: decept
+#
+# $FreeBSD$
+#
+
+PORTNAME= crystal
+PORTVERSION= 0.9.2
+CATEGORIES= x11-themes
+MASTER_SITES= http://www.kde-look.org/content/files/
+DISTNAME= 13969-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= decept0@gmail.com
+COMMENT= Transparent KDE window decoration
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_KDEBASE_VER=3
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lkdeui|-lkdeui ${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|-lkdeui|-lkdeui ${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/client/Makefile.in
+
+.include <bsd.port.mk>