aboutsummaryrefslogtreecommitdiffstats
path: root/x11-themes/qnxstyle
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-05-22 06:23:08 +0800
committerlofi <lofi@FreeBSD.org>2004-05-22 06:23:08 +0800
commitd1252614215048e822b94df6cd1e90a8767f993e (patch)
tree22bd2f5189af01a1fe3bdbd91ee107fd761f6d72 /x11-themes/qnxstyle
parent695e0248a64772c504f0bbe819b884fc235f7ebc (diff)
downloadfreebsd-ports-gnome-d1252614215048e822b94df6cd1e90a8767f993e.tar.gz
freebsd-ports-gnome-d1252614215048e822b94df6cd1e90a8767f993e.tar.zst
freebsd-ports-gnome-d1252614215048e822b94df6cd1e90a8767f993e.zip
Remove inclusion of "${PORTSDIR}/x11/kde3/Makefile.kde", fix PTHREAD_LIBS
safeness, fix compilation where needed. Committers: Please do NOT include Makefile.kde or commit new ports which do so. It's for use with the core KDE ports maintained by kde@freebsd.org ONLY.
Diffstat (limited to 'x11-themes/qnxstyle')
-rw-r--r--x11-themes/qnxstyle/Makefile9
-rw-r--r--x11-themes/qnxstyle/files/patch-src_Makefile.in11
2 files changed, 17 insertions, 3 deletions
diff --git a/x11-themes/qnxstyle/Makefile b/x11-themes/qnxstyle/Makefile
index ab0f1e58e7dc..4511f2062ab2 100644
--- a/x11-themes/qnxstyle/Makefile
+++ b/x11-themes/qnxstyle/Makefile
@@ -22,11 +22,14 @@ USE_KDELIBS_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
PLIST_FILES= lib/kde3/plugins/styles/qnx.so \
lib/kde3/plugins/styles/qnx.la \
share/apps/kstyle/themes/qnx.themerc
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/x11-themes/qnxstyle/files/patch-src_Makefile.in b/x11-themes/qnxstyle/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..e4e6bc88a88b
--- /dev/null
+++ b/x11-themes/qnxstyle/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Sat May 22 00:01:43 2004
++++ src/Makefile.in Sat May 22 00:02:13 2004
+@@ -228,7 +228,7 @@
+ noinst_HEADERS = qnx.h
+ kde_style_LTLIBRARIES = qnx.la
+ qnx_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -lkdefx -module
+-qnx_la_LIBADD =
++qnx_la_LIBADD = $(LIBPTHREAD)
+ qnx_la_SOURCES = qnx.cpp
+ #>- qnx_la_METASOURCES = AUTO
+