aboutsummaryrefslogtreecommitdiffstats
path: root/x11-themes
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-10-19 22:50:26 +0800
committertijl <tijl@FreeBSD.org>2016-10-19 22:50:26 +0800
commit7b80293f580b2c2cf97b82acd6bcb0d9a48cdb46 (patch)
tree3e3556f1e26a35be0250e7f749680b9fc30e9c6b /x11-themes
parent101296dbd3ff02a5ab22526d0cfcd944432ddfe0 (diff)
downloadfreebsd-ports-gnome-7b80293f580b2c2cf97b82acd6bcb0d9a48cdb46.tar.gz
freebsd-ports-gnome-7b80293f580b2c2cf97b82acd6bcb0d9a48cdb46.tar.zst
freebsd-ports-gnome-7b80293f580b2c2cf97b82acd6bcb0d9a48cdb46.zip
Add Linux CentOS 7 infrastructure ports.
Mk/Uses/linux.mk changes: - Add support for architecture neutral (noarch) distfiles. - Add support for 64-bit only ports: set IGNORE on i386 and don't install 32-bit compat libraries on amd64. Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> Differential Revision: https://reviews.freebsd.org/D7886
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/Makefile1
-rw-r--r--x11-themes/linux-c7-hicolor-icon-theme/Makefile27
-rw-r--r--x11-themes/linux-c7-hicolor-icon-theme/pkg-descr6
3 files changed, 34 insertions, 0 deletions
diff --git a/x11-themes/Makefile b/x11-themes/Makefile
index 427f9d0d4c2e..8df443641c04 100644
--- a/x11-themes/Makefile
+++ b/x11-themes/Makefile
@@ -125,6 +125,7 @@
SUBDIR += kde4-windeco-dekorator
SUBDIR += kdeartwork4
SUBDIR += linux-c6-hicolor-icon-theme
+ SUBDIR += linux-c7-hicolor-icon-theme
SUBDIR += linux-f10-hicolor-icon-theme
SUBDIR += linux-f10-qtcurve-gtk2
SUBDIR += linux-hicolor-icon-theme
diff --git a/x11-themes/linux-c7-hicolor-icon-theme/Makefile b/x11-themes/linux-c7-hicolor-icon-theme/Makefile
new file mode 100644
index 000000000000..6157db94480d
--- /dev/null
+++ b/x11-themes/linux-c7-hicolor-icon-theme/Makefile
@@ -0,0 +1,27 @@
+# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
+# $FreeBSD$
+
+PORTNAME= hicolor-icon-theme
+PORTVERSION= 0.5
+CATEGORIES= x11-themes linux
+MASTER_SITES= # empty
+DISTFILES= # empty
+PKGNAMEPREFIX= linux-c7-
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= High-color icon theme shell from the FreeDesktop project
+
+CONFLICTS= linux-f10-${PORTNAME}-[0-9]* linux-c6-${PORTNAME}-[0-9]*
+
+RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:misc/hicolor-icon-theme
+
+NO_BUILD= yes
+USES= linux:c7
+USE_LINUX_PREFIX= yes
+PLIST_FILES= usr/share/icons/hicolor
+
+do-install:
+ ${INSTALL} -d ${STAGEDIR}${PREFIX}/usr/share/icons
+ ${LN} -fs ${LOCALBASE}/share/icons/hicolor ${STAGEDIR}${PREFIX}/usr/share/icons
+
+.include <bsd.port.mk>
diff --git a/x11-themes/linux-c7-hicolor-icon-theme/pkg-descr b/x11-themes/linux-c7-hicolor-icon-theme/pkg-descr
new file mode 100644
index 000000000000..08eae69dd45a
--- /dev/null
+++ b/x11-themes/linux-c7-hicolor-icon-theme/pkg-descr
@@ -0,0 +1,6 @@
+The freedesktop.org project provides a shared high-color desktop
+icon theme shell for use under both KDE and GNOME desktops. This
+is a glue port providing a symlink so that Linux apps find their
+way around.
+
+WWW: http://www.freedesktop.org/Standards/icon-theme-spec