aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/bakery/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-22 20:40:16 +0800
committerbapt <bapt@FreeBSD.org>2014-04-22 20:40:16 +0800
commit15d388ac760eaaa9f19a0ab6992d7b68fcce70ca (patch)
treede2ee604f53035ef4a23bb747e77c321a31f566a /x11-toolkits/bakery/Makefile
parentb842158f91d871a29cf66d3fab84abd005ecbaff (diff)
downloadfreebsd-ports-gnome-15d388ac760eaaa9f19a0ab6992d7b68fcce70ca.tar.gz
freebsd-ports-gnome-15d388ac760eaaa9f19a0ab6992d7b68fcce70ca.tar.zst
freebsd-ports-gnome-15d388ac760eaaa9f19a0ab6992d7b68fcce70ca.zip
Support stage
Strip binaries USES=libtool
Diffstat (limited to 'x11-toolkits/bakery/Makefile')
-rw-r--r--x11-toolkits/bakery/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/x11-toolkits/bakery/Makefile b/x11-toolkits/bakery/Makefile
index f6eaefcdbb01..c7bad2fe28fb 100644
--- a/x11-toolkits/bakery/Makefile
+++ b/x11-toolkits/bakery/Makefile
@@ -4,29 +4,28 @@
PORTNAME= bakery
PORTVERSION= 2.6.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= A C++ Application Framework for use with Gtkmm
-LIB_DEPENDS= gconfmm-2.6:${PORTSDIR}/devel/gconfmm26 \
- glademm-2.4:${PORTSDIR}/devel/libglademm24 \
- gnomevfsmm-2.6:${PORTSDIR}/devel/gnome-vfsmm \
- xml\\+\\+-2.6:${PORTSDIR}/textproc/libxml++26
+LIB_DEPENDS= libgconfmm-2.6.so:${PORTSDIR}/devel/gconfmm26 \
+ libglademm-2.4.so:${PORTSDIR}/devel/libglademm24 \
+ libgnomevfsmm-2.6.so:${PORTSDIR}/devel/gnome-vfsmm \
+ libxml++-2.6.so:${PORTSDIR}/textproc/libxml++26
-USE_GNOME= gnomehack gnomeprefix intlhack ltverhack
-USE_BZIP2= yes
-USES= gettext gmake pkgconfig
-USE_AUTOTOOLS= libtool
+USE_GNOME= gnomeprefix intlhack
+USES= gettext gmake libtool pathfix pkgconfig tar:bzip2
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
PLIST_SUB= VERSION="2.6" API_VERSION="2.6"
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s/examples//' \
${WRKSRC}/Makefile.in