aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/bakery/Makefile
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2004-08-18 15:06:39 +0800
committerbland <bland@FreeBSD.org>2004-08-18 15:06:39 +0800
commite061a7b6bf9a1aa183da5648a8c4c2237c6b5a7e (patch)
tree64fe8f27236fbd8b467edecbef0917727ffaaf72 /x11-toolkits/bakery/Makefile
parentd656889d50b308a41c6efd1e482a88c890d3f1cc (diff)
downloadfreebsd-ports-gnome-e061a7b6bf9a1aa183da5648a8c4c2237c6b5a7e.tar.gz
freebsd-ports-gnome-e061a7b6bf9a1aa183da5648a8c4c2237c6b5a7e.tar.zst
freebsd-ports-gnome-e061a7b6bf9a1aa183da5648a8c4c2237c6b5a7e.zip
- Fix build with gcc 3.4 [1]
- Unplug examples from build since they are not installed anyway. - Use lthack. Reported by: pointyhat via kris
Diffstat (limited to 'x11-toolkits/bakery/Makefile')
-rw-r--r--x11-toolkits/bakery/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/x11-toolkits/bakery/Makefile b/x11-toolkits/bakery/Makefile
index 400bb408a0bc..d97478a4a0ea 100644
--- a/x11-toolkits/bakery/Makefile
+++ b/x11-toolkits/bakery/Makefile
@@ -23,10 +23,14 @@ LIB_DEPENDS= gtkmm-2.0.6:${PORTSDIR}/x11-toolkits/gtk--2 \
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intltool gnometarget
+USE_GNOME= gnomeprefix gnomehack lthack intltool gnometarget
USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s/examples//' \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>