aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/fltk/Makefile
diff options
context:
space:
mode:
authorbillf <billf@FreeBSD.org>1999-03-08 07:52:56 +0800
committerbillf <billf@FreeBSD.org>1999-03-08 07:52:56 +0800
commit99e9b6db3e8b760c72244c57d72576f4092c005e (patch)
treedb8742111b70d377f566ba3bc61d84ebc8cd11ac /x11-toolkits/fltk/Makefile
parent8dfe75f4ee1c159f28b2d6b855bc8d8c559cbbe4 (diff)
downloadfreebsd-ports-gnome-99e9b6db3e8b760c72244c57d72576f4092c005e.tar.gz
freebsd-ports-gnome-99e9b6db3e8b760c72244c57d72576f4092c005e.tar.zst
freebsd-ports-gnome-99e9b6db3e8b760c72244c57d72576f4092c005e.zip
The Fast Light ToolKit ("FLTK", pronounces "fulltick") is a LGPL'd C++
graphical user interface for X. http://fltk.easysw.com PR: ports/10036 and ports/10053 Submitted by: Dima Sivachenko <dima@Chg.RU>
Diffstat (limited to 'x11-toolkits/fltk/Makefile')
-rw-r--r--x11-toolkits/fltk/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
new file mode 100644
index 000000000000..9ba961bd93dc
--- /dev/null
+++ b/x11-toolkits/fltk/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: fltk
+# Version required: 19990127
+# Date created: 11 February 1999
+# Whom: Dima Sivachenko <dima@Chg.RU>
+#
+# $Id: $
+#
+
+DISTNAME= fltk-19990127
+PKGNAME= fltk-1999.01.27
+CATEGORIES= x11-toolkit
+MASTER_SITES= ftp://ftp.easysw.com/pub/fltk/ \
+ ftp://ftp.northamerica.net/pub/ESP/fltk/ \
+ ftp://ftp.funet.fi/mirrors/ftp.easysw.com/pub/fltk/ \
+ ftp://ftp.kddlabs.co.jp/pub/lang/fltk/ \
+ ftp://ftp.c-com.net/pub/LinuxBerg/files/x11/dev/
+
+MAINTAINER= dima@chg.ru
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --enable-shared
+USE_X_PREFIX= yes
+
+post-install:
+
+ @ ${INSTALL_DATA} ${WRKSRC}/lib/libfltk.so.1 ${PREFIX}/lib
+ @ ${LDCONFIG} -m
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/fltk
+ @ ${INSTALL_DATA} ${WRKSRC}/documentation/* ${PREFIX}/share/doc/fltk
+.endif
+
+.include <bsd.port.mk>