aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/fltk
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2011-10-24 21:12:23 +0800
committergahr <gahr@FreeBSD.org>2011-10-24 21:12:23 +0800
commit1996478d90723bd7b5c0364112039df310550d69 (patch)
tree2b6a5550594cad8fdfec2d01d3d2100f0068a801 /x11-toolkits/fltk
parent9d7fcd134237fe551cd5f239b4fb55c28f3e822b (diff)
downloadfreebsd-ports-gnome-1996478d90723bd7b5c0364112039df310550d69.tar.gz
freebsd-ports-gnome-1996478d90723bd7b5c0364112039df310550d69.tar.zst
freebsd-ports-gnome-1996478d90723bd7b5c0364112039df310550d69.zip
- Update to 1.3.0
Diffstat (limited to 'x11-toolkits/fltk')
-rw-r--r--x11-toolkits/fltk/Makefile6
-rw-r--r--x11-toolkits/fltk/distinfo4
-rw-r--r--x11-toolkits/fltk/files/patch-configure11
-rw-r--r--x11-toolkits/fltk/files/patch-documentation_Makefile31
-rw-r--r--x11-toolkits/fltk/files/patch-src_Makefile44
-rw-r--r--x11-toolkits/fltk/files/patch-src_filename_list.cxx20
-rw-r--r--x11-toolkits/fltk/pkg-plist148
7 files changed, 74 insertions, 190 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index e72c29eb675c..46396a901392 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= fltk
-PORTVERSION= 1.1.10
-PORTREVISION= 1
+PORTVERSION= 1.3.0
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_EASYSW}
MASTER_SITE_SUBDIR= fltk/${PORTVERSION}
@@ -19,7 +18,6 @@ COMMENT= Cross-platform C++ graphical user interface toolkit
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg
-USE_BZIP2= yes
USE_LDCONFIG= yes
USE_XORG= xft
USE_GL= gl glu
@@ -28,7 +26,7 @@ CONFIGURE_ARGS+=--enable-threads \
--enable-shared \
--enable-xft
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${WRKSRC}/src -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/x11-toolkits/fltk/distinfo b/x11-toolkits/fltk/distinfo
index 858e6a9f4ceb..23ea5454a456 100644
--- a/x11-toolkits/fltk/distinfo
+++ b/x11-toolkits/fltk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fltk-1.1.10-source.tar.bz2) = 37ada22bf2586b8dd30d84209b8b58bdcb864627e5d02ae3f2c323a29261b19a
-SIZE (fltk-1.1.10-source.tar.bz2) = 2214382
+SHA256 (fltk-1.3.0-source.tar.gz) = 990676808294cea4cca3de833ad5a5de08073c11b665356d4ecf35d22535b21c
+SIZE (fltk-1.3.0-source.tar.gz) = 4111004
diff --git a/x11-toolkits/fltk/files/patch-configure b/x11-toolkits/fltk/files/patch-configure
new file mode 100644
index 000000000000..c7f85cee6354
--- /dev/null
+++ b/x11-toolkits/fltk/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2011-08-31 09:14:41.000000000 +0200
++++ configure 2011-08-31 09:14:54.000000000 +0200
+@@ -11566,7 +11566,7 @@
+ LIBS="$LIBS -lX11 $X_EXTRA_LIBS"
+ CFLAGS="$CFLAGS $X_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $X_CFLAGS"
+- LDFLAGS="$X_LIBS $LDFLAGS"
++ LDFLAGS="$LDFLAGS $X_LIBS"
+ DSOFLAGS="$X_LIBS $DSOFLAGS"
+ cat >>confdefs.h <<\_ACEOF
+ #define USE_X11 1
diff --git a/x11-toolkits/fltk/files/patch-documentation_Makefile b/x11-toolkits/fltk/files/patch-documentation_Makefile
index 29a6f9070b56..74682884c0a1 100644
--- a/x11-toolkits/fltk/files/patch-documentation_Makefile
+++ b/x11-toolkits/fltk/files/patch-documentation_Makefile
@@ -1,24 +1,25 @@
---- documentation/Makefile.orig 2007-02-06 19:35:28.000000000 +0000
-+++ documentation/Makefile 2010-04-29 08:51:10.000000000 +0000
-@@ -230,18 +230,15 @@
-
+--- documentation/Makefile.orig 2011-08-27 01:33:42.000000000 +0000
++++ documentation/Makefile 2011-08-27 01:39:59.000000000 +0000
+@@ -80,6 +80,7 @@
depend:
--install: $(MANPAGES)
+ install: $(MANPAGES)
+docinstall:
- echo "Installing documentation files in $(DESTDIR)$(docdir)..."
+ echo "Installing documentation files in $(DESTDIR)$(docdir) ..."
-$(INSTALL_DIR) $(DESTDIR)$(docdir)
- for file in $(HTMLFILES) $(IMAGEFILES) index.html; do \
- $(INSTALL_DATA) $$file $(DESTDIR)$(docdir); \
- done
+ if test -f html/index.html ; then \
+@@ -91,12 +92,9 @@
+ echo "Installing fltk.pdf in $(DESTDIR)$(docdir) ..."; \
+ $(INSTALL_DATA) fltk.pdf $(DESTDIR)$(docdir); \
+ fi
+
+install: $(MANPAGES)
- echo "Installing man pages in $(DESTDIR)$(mandir)..."
+ echo "Installing man pages in $(DESTDIR)$(mandir) ..."
- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat1
-- $(INSTALL_MAN) fluid.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
-- $(INSTALL_MAN) fltk-config.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fluid.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fltk-config.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat3
-- $(INSTALL_MAN) fltk.$(CAT3EXT) $(DESTDIR)$(mandir)/cat3
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fltk.$(CAT3EXT) $(DESTDIR)$(mandir)/cat3
-$(INSTALL_DIR) $(DESTDIR)$(mandir)/man1
- $(INSTALL_MAN) fluid.man $(DESTDIR)$(mandir)/man1/fluid.1
- $(INSTALL_MAN) fltk-config.man $(DESTDIR)$(mandir)/man1/fltk-config.1
+ $(INSTALL_MAN) $(SRC_DOCDIR)/fluid.man $(DESTDIR)$(mandir)/man1/fluid.1
+ $(INSTALL_MAN) $(SRC_DOCDIR)/fltk-config.man $(DESTDIR)$(mandir)/man1/fltk-config.1
diff --git a/x11-toolkits/fltk/files/patch-src_Makefile b/x11-toolkits/fltk/files/patch-src_Makefile
index 79c9dd3ca7f8..a546de50137a 100644
--- a/x11-toolkits/fltk/files/patch-src_Makefile
+++ b/x11-toolkits/fltk/files/patch-src_Makefile
@@ -1,34 +1,34 @@
---- src/Makefile.orig 2010-03-09 15:43:18.000000000 +0100
-+++ src/Makefile 2010-03-09 15:45:30.000000000 +0100
-@@ -508,6 +508,7 @@
+--- src/Makefile.orig 2011-08-27 01:18:14.000000000 +0000
++++ src/Makefile 2011-08-27 01:31:39.000000000 +0000
+@@ -576,6 +576,7 @@
$(RM) $(DESTDIR)$(libdir)/libfltk.so*;\
- $(INSTALL_LIB) libfltk.so.1.1 $(DESTDIR)$(libdir); \
- $(LN) libfltk.so.1.1 $(DESTDIR)$(libdir)/libfltk.so;\
-+ $(LN) libfltk.so.1.1 $(DESTDIR)$(libdir)/libfltk.so.1;\
+ $(INSTALL_LIB) libfltk.so.1.3 $(DESTDIR)$(libdir); \
+ $(LN) libfltk.so.1.3 $(DESTDIR)$(libdir)/libfltk.so;\
++ $(LN) libfltk.so.1.3 $(DESTDIR)$(libdir)/libfltk.so.1;\
fi
- if test x$(DSONAME) = xlibfltk.sl.1.1; then\
+ if test x$(DSONAME) = xlibfltk.sl.1.3; then\
$(RM) $(DESTDIR)$(libdir)/libfltk.sl*;\
-@@ -539,6 +540,7 @@
+@@ -607,6 +608,7 @@
$(RM) $(DESTDIR)$(libdir)/libfltk_forms.so*;\
- $(INSTALL_LIB) libfltk_forms.so.1.1 $(DESTDIR)$(libdir); \
- $(LN) libfltk_forms.so.1.1 $(DESTDIR)$(libdir)/libfltk_forms.so;\
-+ $(LN) libfltk_forms.so.1.1 $(DESTDIR)$(libdir)/libfltk_forms.so.1;\
+ $(INSTALL_LIB) libfltk_forms.so.1.3 $(DESTDIR)$(libdir); \
+ $(LN) libfltk_forms.so.1.3 $(DESTDIR)$(libdir)/libfltk_forms.so;\
++ $(LN) libfltk_forms.so.1.3 $(DESTDIR)$(libdir)/libfltk_forms.so.1;\
fi
- if test x$(FLDSONAME) = xlibfltk_forms.sl.1.1; then\
+ if test x$(FLDSONAME) = xlibfltk_forms.sl.1.3; then\
$(RM) $(DESTDIR)$(libdir)/libfltk_forms.sl*;\
-@@ -570,6 +572,7 @@
+@@ -638,6 +640,7 @@
$(RM) $(DESTDIR)$(libdir)/libfltk_gl.so*;\
- $(INSTALL_LIB) libfltk_gl.so.1.1 $(DESTDIR)$(libdir); \
- $(LN) libfltk_gl.so.1.1 $(DESTDIR)$(libdir)/libfltk_gl.so;\
-+ $(LN) libfltk_gl.so.1.1 $(DESTDIR)$(libdir)/libfltk_gl.so.1;\
+ $(INSTALL_LIB) libfltk_gl.so.1.3 $(DESTDIR)$(libdir); \
+ $(LN) libfltk_gl.so.1.3 $(DESTDIR)$(libdir)/libfltk_gl.so;\
++ $(LN) libfltk_gl.so.1.3 $(DESTDIR)$(libdir)/libfltk_gl.so.1;\
fi
- if test x$(GLDSONAME) = xlibfltk_gl.sl.1.1; then\
+ if test x$(GLDSONAME) = xlibfltk_gl.sl.1.3; then\
$(RM) $(DESTDIR)$(libdir)/libfltk_gl.sl*;\
-@@ -601,6 +604,7 @@
+@@ -669,6 +672,7 @@
$(RM) $(DESTDIR)$(libdir)/libfltk_images.so*;\
- $(INSTALL_LIB) libfltk_images.so.1.1 $(DESTDIR)$(libdir); \
- $(LN) libfltk_images.so.1.1 $(DESTDIR)$(libdir)/libfltk_images.so;\
-+ $(LN) libfltk_images.so.1.1 $(DESTDIR)$(libdir)/libfltk_images.so.1;\
+ $(INSTALL_LIB) libfltk_images.so.1.3 $(DESTDIR)$(libdir); \
+ $(LN) libfltk_images.so.1.3 $(DESTDIR)$(libdir)/libfltk_images.so;\
++ $(LN) libfltk_images.so.1.3 $(DESTDIR)$(libdir)/libfltk_images.so.1;\
fi
- if test x$(IMGDSONAME) = xlibfltk_images.sl.1.1; then\
+ if test x$(IMGDSONAME) = xlibfltk_images.sl.1.3; then\
$(RM) $(DESTDIR)$(libdir)/libfltk_images.sl*;\
diff --git a/x11-toolkits/fltk/files/patch-src_filename_list.cxx b/x11-toolkits/fltk/files/patch-src_filename_list.cxx
deleted file mode 100644
index da716bc95db1..000000000000
--- a/x11-toolkits/fltk/files/patch-src_filename_list.cxx
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/filename_list.cxx.orig 2010-03-09 08:52:26.000000000 +0100
-+++ src/filename_list.cxx 2010-03-09 08:54:53.000000000 +0100
-@@ -30,7 +30,7 @@
- #include <FL/filename.H>
- #include "flstring.h"
- #include <stdlib.h>
--
-+#include <sys/param.h>
-
- extern "C" {
- #ifndef HAVE_SCANDIR
-@@ -54,7 +54,7 @@
- Fl_File_Sort_F *sort) {
- #ifndef HAVE_SCANDIR
- int n = scandir(d, list, 0, sort);
--#elif defined(HAVE_SCANDIR_POSIX)
-+#elif defined(HAVE_SCANDIR_POSIX) || (defined(__FreeBSD__) && (__FreeBSD_version >= 900006 || (__FreeBSD_version >= 800501 && __FreeBSD_version < 900000) || (__FreeBSD_version >= 730000 && __FreeBSD_version < 800000)))
- // POSIX (2008) defines the comparison function like this:
- int n = scandir(d, list, 0, (int(*)(const dirent **, const dirent **))sort);
- #elif defined(__osf__)
diff --git a/x11-toolkits/fltk/pkg-plist b/x11-toolkits/fltk/pkg-plist
index e73d7ab4ff70..88266fa9dd9f 100644
--- a/x11-toolkits/fltk/pkg-plist
+++ b/x11-toolkits/fltk/pkg-plist
@@ -1,267 +1,161 @@
bin/fltk-config
bin/fluid
include/FL/Enumerations.H
-include/FL/Enumerations.h
include/FL/Fl.H
-include/FL/Fl.h
include/FL/Fl_Adjuster.H
-include/FL/Fl_Adjuster.h
include/FL/Fl_BMP_Image.H
-include/FL/Fl_BMP_Image.h
include/FL/Fl_Bitmap.H
-include/FL/Fl_Bitmap.h
include/FL/Fl_Box.H
-include/FL/Fl_Box.h
include/FL/Fl_Browser.H
-include/FL/Fl_Browser.h
include/FL/Fl_Browser_.H
-include/FL/Fl_Browser_.h
include/FL/Fl_Button.H
-include/FL/Fl_Button.h
+include/FL/Fl_Cairo.H
+include/FL/Fl_Cairo_Window.H
include/FL/Fl_Chart.H
-include/FL/Fl_Chart.h
include/FL/Fl_Check_Browser.H
-include/FL/Fl_Check_Browser.h
include/FL/Fl_Check_Button.H
-include/FL/Fl_Check_Button.h
include/FL/Fl_Choice.H
-include/FL/Fl_Choice.h
include/FL/Fl_Clock.H
-include/FL/Fl_Clock.h
include/FL/Fl_Color_Chooser.H
-include/FL/Fl_Color_Chooser.h
include/FL/Fl_Counter.H
-include/FL/Fl_Counter.h
+include/FL/Fl_Device.H
include/FL/Fl_Dial.H
-include/FL/Fl_Dial.h
include/FL/Fl_Double_Window.H
-include/FL/Fl_Double_Window.h
include/FL/Fl_Export.H
-include/FL/Fl_Export.h
include/FL/Fl_File_Browser.H
-include/FL/Fl_File_Browser.h
include/FL/Fl_File_Chooser.H
-include/FL/Fl_File_Chooser.h
include/FL/Fl_File_Icon.H
-include/FL/Fl_File_Icon.h
include/FL/Fl_File_Input.H
-include/FL/Fl_File_Input.h
include/FL/Fl_Fill_Dial.H
-include/FL/Fl_Fill_Dial.h
include/FL/Fl_Fill_Slider.H
-include/FL/Fl_Fill_Slider.h
include/FL/Fl_Float_Input.H
-include/FL/Fl_Float_Input.h
include/FL/Fl_FormsBitmap.H
-include/FL/Fl_FormsBitmap.h
include/FL/Fl_FormsPixmap.H
-include/FL/Fl_FormsPixmap.h
include/FL/Fl_Free.H
-include/FL/Fl_Free.h
include/FL/Fl_GIF_Image.H
-include/FL/Fl_GIF_Image.h
include/FL/Fl_Gl_Window.H
-include/FL/Fl_Gl_Window.h
include/FL/Fl_Group.H
-include/FL/Fl_Group.h
include/FL/Fl_Help_Dialog.H
-include/FL/Fl_Help_Dialog.h
include/FL/Fl_Help_View.H
-include/FL/Fl_Help_View.h
include/FL/Fl_Hold_Browser.H
-include/FL/Fl_Hold_Browser.h
include/FL/Fl_Hor_Fill_Slider.H
-include/FL/Fl_Hor_Fill_Slider.h
include/FL/Fl_Hor_Nice_Slider.H
-include/FL/Fl_Hor_Nice_Slider.h
include/FL/Fl_Hor_Slider.H
-include/FL/Fl_Hor_Slider.h
include/FL/Fl_Hor_Value_Slider.H
-include/FL/Fl_Hor_Value_Slider.h
include/FL/Fl_Image.H
-include/FL/Fl_Image.h
include/FL/Fl_Input.H
-include/FL/Fl_Input.h
include/FL/Fl_Input_.H
-include/FL/Fl_Input_.h
include/FL/Fl_Input_Choice.H
-include/FL/Fl_Input_Choice.h
include/FL/Fl_Int_Input.H
-include/FL/Fl_Int_Input.h
include/FL/Fl_JPEG_Image.H
-include/FL/Fl_JPEG_Image.h
include/FL/Fl_Light_Button.H
-include/FL/Fl_Light_Button.h
include/FL/Fl_Line_Dial.H
-include/FL/Fl_Line_Dial.h
include/FL/Fl_Menu.H
-include/FL/Fl_Menu.h
include/FL/Fl_Menu_.H
-include/FL/Fl_Menu_.h
include/FL/Fl_Menu_Bar.H
-include/FL/Fl_Menu_Bar.h
include/FL/Fl_Menu_Button.H
-include/FL/Fl_Menu_Button.h
include/FL/Fl_Menu_Item.H
-include/FL/Fl_Menu_Item.h
include/FL/Fl_Menu_Window.H
-include/FL/Fl_Menu_Window.h
include/FL/Fl_Multi_Browser.H
-include/FL/Fl_Multi_Browser.h
include/FL/Fl_Multi_Label.H
-include/FL/Fl_Multi_Label.h
include/FL/Fl_Multiline_Input.H
-include/FL/Fl_Multiline_Input.h
include/FL/Fl_Multiline_Output.H
-include/FL/Fl_Multiline_Output.h
+include/FL/Fl_Native_File_Chooser.H
include/FL/Fl_Nice_Slider.H
-include/FL/Fl_Nice_Slider.h
include/FL/Fl_Object.H
-include/FL/Fl_Object.h
include/FL/Fl_Output.H
-include/FL/Fl_Output.h
include/FL/Fl_Overlay_Window.H
-include/FL/Fl_Overlay_Window.h
include/FL/Fl_PNG_Image.H
-include/FL/Fl_PNG_Image.h
include/FL/Fl_PNM_Image.H
-include/FL/Fl_PNM_Image.h
include/FL/Fl_Pack.H
-include/FL/Fl_Pack.h
+include/FL/Fl_Paged_Device.H
include/FL/Fl_Pixmap.H
-include/FL/Fl_Pixmap.h
+include/FL/Fl_Plugin.H
include/FL/Fl_Positioner.H
-include/FL/Fl_Positioner.h
+include/FL/Fl_PostScript.H
include/FL/Fl_Preferences.H
-include/FL/Fl_Preferences.h
+include/FL/Fl_Printer.H
include/FL/Fl_Progress.H
-include/FL/Fl_Progress.h
include/FL/Fl_RGB_Image.H
-include/FL/Fl_RGB_Image.h
include/FL/Fl_Radio_Button.H
-include/FL/Fl_Radio_Button.h
include/FL/Fl_Radio_Light_Button.H
-include/FL/Fl_Radio_Light_Button.h
include/FL/Fl_Radio_Round_Button.H
-include/FL/Fl_Radio_Round_Button.h
include/FL/Fl_Repeat_Button.H
-include/FL/Fl_Repeat_Button.h
include/FL/Fl_Return_Button.H
-include/FL/Fl_Return_Button.h
include/FL/Fl_Roller.H
-include/FL/Fl_Roller.h
include/FL/Fl_Round_Button.H
-include/FL/Fl_Round_Button.h
include/FL/Fl_Round_Clock.H
-include/FL/Fl_Round_Clock.h
include/FL/Fl_Scroll.H
-include/FL/Fl_Scroll.h
include/FL/Fl_Scrollbar.H
-include/FL/Fl_Scrollbar.h
include/FL/Fl_Secret_Input.H
-include/FL/Fl_Secret_Input.h
include/FL/Fl_Select_Browser.H
-include/FL/Fl_Select_Browser.h
include/FL/Fl_Shared_Image.H
-include/FL/Fl_Shared_Image.h
include/FL/Fl_Simple_Counter.H
-include/FL/Fl_Simple_Counter.h
include/FL/Fl_Single_Window.H
-include/FL/Fl_Single_Window.h
include/FL/Fl_Slider.H
-include/FL/Fl_Slider.h
include/FL/Fl_Spinner.H
-include/FL/Fl_Spinner.h
include/FL/Fl_Sys_Menu_Bar.H
-include/FL/Fl_Sys_Menu_Bar.h
+include/FL/Fl_Table.H
+include/FL/Fl_Table_Row.H
include/FL/Fl_Tabs.H
-include/FL/Fl_Tabs.h
include/FL/Fl_Text_Buffer.H
-include/FL/Fl_Text_Buffer.h
include/FL/Fl_Text_Display.H
-include/FL/Fl_Text_Display.h
include/FL/Fl_Text_Editor.H
-include/FL/Fl_Text_Editor.h
include/FL/Fl_Tile.H
-include/FL/Fl_Tile.h
include/FL/Fl_Tiled_Image.H
-include/FL/Fl_Tiled_Image.h
include/FL/Fl_Timer.H
-include/FL/Fl_Timer.h
include/FL/Fl_Toggle_Button.H
-include/FL/Fl_Toggle_Button.h
include/FL/Fl_Toggle_Light_Button.H
-include/FL/Fl_Toggle_Light_Button.h
include/FL/Fl_Toggle_Round_Button.H
-include/FL/Fl_Toggle_Round_Button.h
include/FL/Fl_Tooltip.H
-include/FL/Fl_Tooltip.h
+include/FL/Fl_Tree.H
+include/FL/Fl_Tree_Item.H
+include/FL/Fl_Tree_Item_Array.H
+include/FL/Fl_Tree_Prefs.H
include/FL/Fl_Valuator.H
-include/FL/Fl_Valuator.h
include/FL/Fl_Value_Input.H
-include/FL/Fl_Value_Input.h
include/FL/Fl_Value_Output.H
-include/FL/Fl_Value_Output.h
include/FL/Fl_Value_Slider.H
-include/FL/Fl_Value_Slider.h
include/FL/Fl_Widget.H
-include/FL/Fl_Widget.h
include/FL/Fl_Window.H
-include/FL/Fl_Window.h
include/FL/Fl_Wizard.H
-include/FL/Fl_Wizard.h
include/FL/Fl_XBM_Image.H
-include/FL/Fl_XBM_Image.h
include/FL/Fl_XPM_Image.H
-include/FL/Fl_XPM_Image.h
+include/FL/Xutf8.h
include/FL/dirent.h
include/FL/filename.H
-include/FL/filename.h
include/FL/fl_ask.H
-include/FL/fl_ask.h
include/FL/fl_draw.H
-include/FL/fl_draw.h
-include/FL/fl_file_chooser.H
-include/FL/fl_file_chooser.h
include/FL/fl_message.H
-include/FL/fl_message.h
include/FL/fl_show_colormap.H
-include/FL/fl_show_colormap.h
include/FL/fl_show_input.H
-include/FL/fl_show_input.h
+include/FL/fl_types.h
+include/FL/fl_utf8.h
include/FL/forms.H
-include/FL/forms.h
include/FL/gl.h
include/FL/gl2opengl.h
include/FL/gl_draw.H
-include/FL/gl_draw.h
include/FL/glu.h
include/FL/glut.H
-include/FL/glut.h
include/FL/mac.H
-include/FL/mac.h
-include/FL/mac.r
include/FL/math.h
include/FL/names.h
include/FL/win32.H
-include/FL/win32.h
include/FL/x.H
-include/FL/x.h
-include/Fl
lib/libfltk.a
lib/libfltk.so
lib/libfltk.so.1
-lib/libfltk.so.1.1
+lib/libfltk.so.1.3
lib/libfltk_forms.a
lib/libfltk_forms.so
lib/libfltk_forms.so.1
-lib/libfltk_forms.so.1.1
+lib/libfltk_forms.so.1.3
lib/libfltk_gl.a
lib/libfltk_gl.so
lib/libfltk_gl.so.1
-lib/libfltk_gl.so.1.1
+lib/libfltk_gl.so.1.3
lib/libfltk_images.a
lib/libfltk_images.so
lib/libfltk_images.so.1
-lib/libfltk_images.so.1.1
+lib/libfltk_images.so.1.3
@dirrm include/FL