aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/flvw/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-09-04 02:41:37 +0800
committerknu <knu@FreeBSD.org>2001-09-04 02:41:37 +0800
commit20cefa9585bca169bef97b5b0a721b5051d2d47c (patch)
tree4768c4e0cb4777a5fe110cb7ba41fdbd10da0a7a /x11-toolkits/flvw/Makefile
parentbddfeef7f600d326dc9080591875cce5fd8b9bd5 (diff)
downloadfreebsd-ports-gnome-20cefa9585bca169bef97b5b0a721b5051d2d47c.tar.gz
freebsd-ports-gnome-20cefa9585bca169bef97b5b0a721b5051d2d47c.tar.zst
freebsd-ports-gnome-20cefa9585bca169bef97b5b0a721b5051d2d47c.zip
Add flvw. The FLVW (Fast Light Virtual Widgets) require the use of
the FLTK (Fast Light ToolKit) library. They are designed to handle large amounts of data. As such they are definitely not the smallset of FLTK widgets, but they are designed to use memory conservatively. PR: ports/29860 Submitted by: Cyrille Lefevre <clefevre@citeweb.net>
Diffstat (limited to 'x11-toolkits/flvw/Makefile')
-rw-r--r--x11-toolkits/flvw/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-toolkits/flvw/Makefile b/x11-toolkits/flvw/Makefile
new file mode 100644
index 000000000000..52e1d84cc8e6
--- /dev/null
+++ b/x11-toolkits/flvw/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: flvw
+# Date created: 17 August 2001
+# Whom: Cyrille Lefevre <clefevre@citeweb.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flvw
+PORTVERSION= 20000224
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= clefevre@citeweb.net
+
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/1.0
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAKE_ARGS= DIRS=src
+
+DOC_FILES= documentation/html/*.html
+DOC_SUBDIR= share/doc/${PKGBASE}
+INC_FILES= Flv_CStyle.H Flv_Data_Source.H Flv_List.H Flv_Style.H \
+ Flv_Table.H Flve_Check_Button.H Flve_Combo.H Flve_Input.H
+INC_SUBDIR= include/FL
+
+INSTALLS_SHLIB= yes
+
+post-install: symlink-inc install-doc
+
+symlink-inc:
+.for file in ${INC_FILES}
+ @${LN} -fs ${file} ${PREFIX}/${INC_SUBDIR}/${file:R}.${file:E:L}
+.endfor
+
+install-doc:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/${DOC_SUBDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/${DOC_SUBDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>