aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/fox10/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-05-01 00:39:03 +0800
committerknu <knu@FreeBSD.org>2001-05-01 00:39:03 +0800
commitf330e4500c9cd19cd8a2f6befb0bdb02b3c28d60 (patch)
treef477422e128263622710f199d0dc451412dd6494 /x11-toolkits/fox10/Makefile
parentda96ec51c5bef0db052c3fa909f1e714409e8d15 (diff)
downloadfreebsd-ports-gnome-f330e4500c9cd19cd8a2f6befb0bdb02b3c28d60.tar.gz
freebsd-ports-gnome-f330e4500c9cd19cd8a2f6befb0bdb02b3c28d60.tar.zst
freebsd-ports-gnome-f330e4500c9cd19cd8a2f6befb0bdb02b3c28d60.zip
Note the default optimization flags used by the vendor in a comment.
Comment out redundant lines rather than deleting them. (Just my taste)
Diffstat (limited to 'x11-toolkits/fox10/Makefile')
-rw-r--r--x11-toolkits/fox10/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/x11-toolkits/fox10/Makefile b/x11-toolkits/fox10/Makefile
index f91b89a6ed96..3354a4916f21 100644
--- a/x11-toolkits/fox10/Makefile
+++ b/x11-toolkits/fox10/Makefile
@@ -32,6 +32,7 @@ PATCHVERSION= ${PORTVERSION}
USE_MESA= yes
INSTALLS_SHLIB= yes
+CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}"
CONFIGURE_ARGS+=--with-opengl=mesa --with-x
.if defined(NO_SHM)
CONFIGURE_ARGS+=--with-shm=no
@@ -53,6 +54,9 @@ MAKE_ENV+= LT_CURRENT="${SHLIB_MAJ}" LT_REVISION="${SHLIB_MIN}"
PLIST_SUB+= LIBVER="${SHLIB_MAJ}"
MAN1= reswrap.1
+# Uncomment this to turn the default optimization flags on.
+CXXFLAGS= -O2 -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations
+
.if defined(WITH_XUNICODE)
post-extract:
cd ${WRKSRC} && ${LN} -s ${X11BASE}/include/xunicode