aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gal/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-10-06 10:42:20 +0800
committerade <ade@FreeBSD.org>2000-10-06 10:42:20 +0800
commite05ea80d34384a7e380c3436e91384053c1a8acc (patch)
tree1f1fbb9e3fd336a75243f98b2ebde4d20f17583d /x11-toolkits/gal/Makefile
parentd19907826889cc1ea9b002d349d08f3f16d98ec4 (diff)
downloadfreebsd-ports-gnome-e05ea80d34384a7e380c3436e91384053c1a8acc.tar.gz
freebsd-ports-gnome-e05ea80d34384a7e380c3436e91384053c1a8acc.tar.zst
freebsd-ports-gnome-e05ea80d34384a7e380c3436e91384053c1a8acc.zip
GAL is a collection of widgets and utility routines that were taken
from GNOME Evolution and Gnumeric - upcoming releases of these two pieces of software, and others, will require this library.
Diffstat (limited to 'x11-toolkits/gal/Makefile')
-rw-r--r--x11-toolkits/gal/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-toolkits/gal/Makefile b/x11-toolkits/gal/Makefile
new file mode 100644
index 000000000000..b124ece0f0ca
--- /dev/null
+++ b/x11-toolkits/gal/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: gal
+# Date created: 5th October 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gal
+PORTVERSION= 0.1
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/gal
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= gnomeprint.12:${PORTSDIR}/print/gnomeprint \
+ glade.4:${PORTSDIR}/devel/libglade \
+ unicode.0:${PORTSDIR}/devel/libunicode \
+ gnomevfs.0:${PORTSDIR}/devel/gnomevfs
+
+USE_X_PREFIX= yes
+USE_PERL5= yes
+USE_GMAKE= yes
+USE_GNOME= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-static
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>