aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/girara
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2018-01-14 06:15:33 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:23:42 +0800
commit5cc652c732697ee579f0dbcd8dea576cdcd11c28 (patch)
tree54fab65b23d9460be467463ccdc97610a9d581bf /x11-toolkits/girara
parenta63fd61741636d5aad99ec374eeb1cdb40575b0c (diff)
downloadfreebsd-ports-gnome-5cc652c732697ee579f0dbcd8dea576cdcd11c28.tar.gz
freebsd-ports-gnome-5cc652c732697ee579f0dbcd8dea576cdcd11c28.tar.zst
freebsd-ports-gnome-5cc652c732697ee579f0dbcd8dea576cdcd11c28.zip
- Add NOTIFY option, enabled by default
- Add JSONC option, disabled by default These options allow controlling two optional dependencies of girara, which where being silently linked if present on the system when compiling. PR: 224876 Submitted by: pawel@ MFH: 2018Q1
Diffstat (limited to 'x11-toolkits/girara')
-rw-r--r--x11-toolkits/girara/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/x11-toolkits/girara/Makefile b/x11-toolkits/girara/Makefile
index 8f5f73b7dace..854a8a69bf64 100644
--- a/x11-toolkits/girara/Makefile
+++ b/x11-toolkits/girara/Makefile
@@ -3,6 +3,7 @@
PORTNAME= girara
PORTVERSION= 0.2.8
+PORTREVISION= 1
CATEGORIES= x11-toolkits graphics
MASTER_SITES= https://pwmt.org/projects/girara/download/ \
http://www.madpilot.net/~mad/pwmt.org/
@@ -19,10 +20,19 @@ LIBDIR= ${PREFIX}/lib
MAKE_ENV+= SFLAGS=${STRIP} \
VERBOSE=1
-OPTIONS_DEFINE= NLS
+OPTIONS_DEFINE= JSONC NLS NOTIFY
+OPTIONS_DEFAULT= NOTIFY
+JSONC_DESC= Support json configuration dump
-OPTIONS_SUB= yes
-NLS_USES= gettext
+OPTIONS_SUB= yes
+
+JSONC_LIB_DEPENDS= libjson-c.so:devel/json-c
+JSONC_MAKE_ENV_OFF= WITH_JSON=0
+
+NLS_USES= gettext
+
+NOTIFY_LIB_DEPENDS= libnotify.so:devel/libnotify
+NOTIFY_MAKE_ENV_OFF= WITH_LIBNOTIFY=0
post-patch: .SILENT
${REINPLACE_CMD} -e 's|^\(CFLAGS +=\) -std=c11|\1|' \