aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtk-engines/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>1998-12-28 23:54:54 +0800
committervanilla <vanilla@FreeBSD.org>1998-12-28 23:54:54 +0800
commit01b591ca120fd1196df0f302ed4251b91b899bc6 (patch)
treed2cb4d4b4b7a951228f06eadaf69b5692a08b7e5 /x11-toolkits/gtk-engines/Makefile
parent091cf4f00b1e08847796aa869203ca63ca260098 (diff)
downloadfreebsd-ports-gnome-01b591ca120fd1196df0f302ed4251b91b899bc6.tar.gz
freebsd-ports-gnome-01b591ca120fd1196df0f302ed4251b91b899bc6.tar.zst
freebsd-ports-gnome-01b591ca120fd1196df0f302ed4251b91b899bc6.zip
Gtk themes engine.
Diffstat (limited to 'x11-toolkits/gtk-engines/Makefile')
-rw-r--r--x11-toolkits/gtk-engines/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-toolkits/gtk-engines/Makefile b/x11-toolkits/gtk-engines/Makefile
new file mode 100644
index 000000000000..a02a0e2b6231
--- /dev/null
+++ b/x11-toolkits/gtk-engines/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gtk-engines
+# Version required: 0.1
+# Date Created: 23 Dec 1998
+# Whom: Vanilla I. Shu <vanilla@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= gtk-engines-0.1
+CATEGORIES= x11-toolkits
+MASTER_SITES= ftp://ftp.jimpick.com/pub/mirrors/gnome/sources/ \
+ ftp://ftp.gnome.org/pub/GNOME/sources/
+
+MAINTAINER= vanilla@FreeBSD.ORG
+
+LIB_DEPENDS= gtk11d.1:${PORTSDIR}/x11-toolkits/gtk11-devel \
+ gdk_imlib.1:${PORTSDIR}/graphics/imlib
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk11d-config" \
+ GLIB_CONFIG="${LOCALBASE}/bin/glib11d-config"
+
+post-install:
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>