aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtk12/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>1998-12-12 12:43:30 +0800
committervanilla <vanilla@FreeBSD.org>1998-12-12 12:43:30 +0800
commit948c2c629fa06e239fd18134cb7f5db6a5bb2363 (patch)
treedc157eeec82d9ec1fc16cd544d8c333604467aec /x11-toolkits/gtk12/Makefile
parent616534f262f5d6290848b26993216d328f5a10f8 (diff)
downloadfreebsd-ports-gnome-948c2c629fa06e239fd18134cb7f5db6a5bb2363.tar.gz
freebsd-ports-gnome-948c2c629fa06e239fd18134cb7f5db6a5bb2363.tar.zst
freebsd-ports-gnome-948c2c629fa06e239fd18134cb7f5db6a5bb2363.zip
Upgrade to 1.1.7,
I change library name to libgtk11d, and gtk-config to gtk11d-config.
Diffstat (limited to 'x11-toolkits/gtk12/Makefile')
-rw-r--r--x11-toolkits/gtk12/Makefile27
1 files changed, 9 insertions, 18 deletions
diff --git a/x11-toolkits/gtk12/Makefile b/x11-toolkits/gtk12/Makefile
index b34e46b1e3e3..14026a6f9315 100644
--- a/x11-toolkits/gtk12/Makefile
+++ b/x11-toolkits/gtk12/Makefile
@@ -1,13 +1,13 @@
-# New ports collection makefile for: gtk
-# Version required: 1.1.2
+# New ports collection makefile for: gtk11-devel
+# Version required: 1.1.7
# Date Created: 28 Sep 1997
# Whom: Vanilla I. Shu <vanilla@MinJe.com.TW>
#
-# $Id: Makefile,v 1.31 1998/12/10 13:18:16 vanilla Exp $
+# $Id: Makefile,v 1.32 1998/12/10 14:30:28 asami Exp $
#
-DISTNAME= gtk+-1.1.2
-PKGNAME= gtk-1.1.2
+DISTNAME= gtk+-1.1.7
+PKGNAME= gtk-1.1.7
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.gimp.org/pub/gtk/v1.1/ \
ftp://ftp.cs.umn.edu/pub/gimp/gtk/v1.1/ \
@@ -15,24 +15,15 @@ MASTER_SITES= ftp://ftp.gimp.org/pub/gtk/v1.1/ \
MAINTAINER= vanilla@FreeBSD.ORG
-LIB_DEPENDS= glib11.0:${PORTSDIR}/devel/glib
-
-BROKEN= upgrade
+LIB_DEPENDS= glib11d.1:${PORTSDIR}/devel/glib11-devel
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= INSTALL='$${INSTALL} -c'
-CONFIGURE_ARGS= --includedir=${PREFIX}/include/gtk11
-
-MAN1= gtk-config.1
-
-pre-install:
- @if [ ! -f ${PREFIX}/info/dir ]; then \
- ${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
- fi
+CONFIGURE_ENV= INSTALL='$${INSTALL} -c' \
+ GLIB_CONFIG="${LOCALBASE}/bin/glib11d-config"
+CONFIGURE_ARGS= --includedir=${PREFIX}/include/gtk11d
post-install:
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
- ${CAT} ${PKGDIR}/MESSAGE
.include <bsd.port.mk>