aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtk20
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-04-13 02:07:20 +0800
committerahze <ahze@FreeBSD.org>2005-04-13 02:07:20 +0800
commit49d47757d788d51063a0adb954eebde790c102c9 (patch)
tree6d83ea74fe69750fcbf047de1ca381b76ef06dcc /x11-toolkits/gtk20
parentf62a08cea712359f77f92bcc7080f3b47fe5df66 (diff)
downloadfreebsd-ports-gnome-49d47757d788d51063a0adb954eebde790c102c9.tar.gz
freebsd-ports-gnome-49d47757d788d51063a0adb954eebde790c102c9.tar.zst
freebsd-ports-gnome-49d47757d788d51063a0adb954eebde790c102c9.zip
- Add WITH_DEBUG knob that has the following turnables [no|minimum|yes]
Default is minimum per gtk.
Diffstat (limited to 'x11-toolkits/gtk20')
-rw-r--r--x11-toolkits/gtk20/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index d5429e0b74b2..bbbefef34720 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -51,6 +51,18 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
GTK_VERSION= 2.4.0
PLIST_SUB= GTK_VERSION="${GTK_VERSION}"
+.if defined(WITH_DEBUG)
+.if ${WITH_DEBUG:L} == "no"
+CONFIGURE_ARGS+= --enable-debug=no
+.else
+.if ${WITH_DEBUG:L} == "yes"
+CONFIGURE_ARGS+= --enable-debug=yes
+.else
+CONFIGURE_ARGS+= --enable-debug=minimum
+.endif
+.endif
+.endif
+
pre-everything::
.if !defined(WITH_DROPSHADOW)
@${ECHO_MSG}
@@ -61,6 +73,14 @@ pre-everything::
@${ECHO_MSG} "stop using the patch; we will not further debug it."
@${ECHO_MSG}
.endif
+.if !defined(WITH_DEBUG)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Enable or disable debugging with the following knob"
+ @${ECHO_MSG} "WITH_DEBUG=[no|minimum|yes]"
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Default is minimum"
+ @${ECHO_MSG}
+.endif
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${GREP} -l lgmodule | \