aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtk20
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-02-17 00:36:43 +0800
committermarcus <marcus@FreeBSD.org>2008-02-17 00:36:43 +0800
commit1301805759e7e83fea05730e9ce8f45f3a5e8650 (patch)
tree15a9884cf448545760d2c37bcecfdef27cb5bea5 /x11-toolkits/gtk20
parent6bbb9d3b9e91573dd96d65b91fd94f06ad01014e (diff)
downloadfreebsd-ports-gnome-1301805759e7e83fea05730e9ce8f45f3a5e8650.tar.gz
freebsd-ports-gnome-1301805759e7e83fea05730e9ce8f45f3a5e8650.tar.zst
freebsd-ports-gnome-1301805759e7e83fea05730e9ce8f45f3a5e8650.zip
Restore the behavior of unlinking invalid icon cache files to prevent
leftovers. reported by: pointyhat via pav
Diffstat (limited to 'x11-toolkits/gtk20')
-rw-r--r--x11-toolkits/gtk20/Makefile2
-rw-r--r--x11-toolkits/gtk20/files/patch-gtk_updateiconcache.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index 3aad5f239997..bcec8b63415f 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gtk
PORTVERSION= 2.12.8
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/,} \
ftp://ftp.gtk.org/pub/gtk/%SUBDIR%/ \
diff --git a/x11-toolkits/gtk20/files/patch-gtk_updateiconcache.c b/x11-toolkits/gtk20/files/patch-gtk_updateiconcache.c
new file mode 100644
index 000000000000..354837da5a4f
--- /dev/null
+++ b/x11-toolkits/gtk20/files/patch-gtk_updateiconcache.c
@@ -0,0 +1,11 @@
+--- gtk/updateiconcache.c.orig 2008-02-16 11:33:25.000000000 -0500
++++ gtk/updateiconcache.c 2008-02-16 11:33:33.000000000 -0500
+@@ -1477,7 +1477,7 @@ build_cache (const gchar *path)
+ if (!validate_file (tmp_cache_path))
+ {
+ g_printerr (_("The generated cache was invalid.\n"));
+- //g_unlink (tmp_cache_path);
++ g_unlink (tmp_cache_path);
+ exit (1);
+ }
+