aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtk20
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
committermarcus <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
commit194069571a0e4c7bad7bce0f33a042d707e9e171 (patch)
treec3c8a6312bab5325147ea9ea2ad87f0cc44a5fec /x11-toolkits/gtk20
parent232533f87b435da7ed2bac7daeae3e90680d9e1d (diff)
downloadfreebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.tar.gz
freebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.tar.zst
freebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.zip
Presenting GNOME 2.12 for FreeBSD. The release is chock full of bug fixes
and new features. Don't believe me? Then see for yourself at http://www.gnome.org/start/2.12/notes/en/. DO NOT USE portupgrade by itself to upgrade to GNOME 2.12. Instead, use the gnome_upgrade.sh script from http://www.marcuscom.com/downloads/gnome_upgrade212.sh. This script will circumvent some potential pitfalls users can see if they use portupgrade by itself. In keeping with tradition, GNOME 2.12 for FreeBSD comes with a special splash screen. The winner of this release's contest is Dominique Goncalves <dominique.goncalves@gmail.com>. His splash screen was inspired by http://art.gnome.org/contests/2.12-splash/83. The FreeBSD GNOME Team would lank to thank the following users for their contributions to this release: Matthew Luckie <mjl@luckie.org.nz> ade sajd on #freebsd-gnome Caelian on #freebsd-gnome mnag Yasuda Keisuke <kysd@po.harenet.ne.jp> Mark Hobden <markhobden@gmail.com> Sergey Akifyev <asa@agava.com> Andreas Kohn For more information on GNOME on FreeBSD, checkout http://www.FreeBSD.org/gnome/. The 2.12 documentation will be posted shortly.
Diffstat (limited to 'x11-toolkits/gtk20')
-rw-r--r--x11-toolkits/gtk20/Makefile33
-rw-r--r--x11-toolkits/gtk20/distinfo6
-rw-r--r--x11-toolkits/gtk20/files/patch-Makefile.in12
-rw-r--r--x11-toolkits/gtk20/files/patch-ak1
-rw-r--r--x11-toolkits/gtk20/files/patch-gtk_gtkcalendar.c10
-rw-r--r--x11-toolkits/gtk20/files/patch-gtk_gtkentry.c13
-rw-r--r--x11-toolkits/gtk20/files/patch-gtk_gtkiconcache.c20
-rw-r--r--x11-toolkits/gtk20/pkg-plist80
8 files changed, 76 insertions, 99 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index 3001ebcaaaad..014cf40de698 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -3,14 +3,14 @@
# Whom: Vanilla I. Shu <vanilla@MinJe.com.TW>
#
# $FreeBSD$
+# $MCom: ports/x11-toolkits/gtk20/Makefile,v 1.80 2005/10/29 22:42:26 mezz Exp $
#
PORTNAME= gtk
-PORTVERSION= 2.6.10
-PORTREVISION= 1
+PORTVERSION= 2.8.6
CATEGORIES= x11-toolkits
-MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.6,} \
- ftp://ftp.gtk.org/pub/gtk/v2.6/ \
+MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.8,} \
+ ftp://ftp.gtk.org/pub/gtk/v2.8/ \
ftp://ftp.gimp.org/pub/%SUBDIR%/ \
ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
http://www.ameth.org/gimp/%SUBDIR%/ \
@@ -20,13 +20,6 @@ MASTER_SITE_SUBDIR= gtk/v${PORTVERSION:R}
DISTNAME= gtk+-${PORTVERSION}
DIST_SUBDIR= gnome2
-.if defined(WITH_DROPSHADOW)
-PATCH_SITES= ${MASTER_SITE_SOURCEFORGE}
-PATCH_SITE_SUBDIR= xfce
-PATCHFILES= gtk+-2.4.0-menushadow.patch
-PATCH_DIST_STRIP= -p1
-.endif
-
MAINTAINER= gnome@FreeBSD.org
COMMENT= Gimp Toolkit for X11 GUI (current stable version)
@@ -43,8 +36,8 @@ USE_XPM= yes
USE_REINPLACE= yes
USE_PERL5= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=15
-USE_GNOME= gnomehack atk pango
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= gnomehack atk pango ltverhack
CONFIGURE_ARGS= --enable-static --with-xinput=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
-I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -64,9 +57,10 @@ CONFIGURE_ARGS+= --enable-debug=no
.else
.if ${WITH_DEBUG:L} == "yes"
CONFIGURE_ARGS+= --enable-debug=yes
+STRIP=
.else
CONFIGURE_ARGS+= --enable-debug=minimum
-CFLAGS+= -g
+CFLAGS+= -g
.endif
STRIP=
.endif
@@ -84,15 +78,6 @@ CFLAGS+= -mno-sse2
.endif
pre-everything::
-.if !defined(WITH_DROPSHADOW)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with experimental menu dropshadow patch,"
- @${ECHO_MSG} "hit Ctrl-C right now and use make \"WITH_DROPSHADOW=yes\""
- @${ECHO_MSG} "NOTE: This option is not supported by the FreeBSD GNOME Team."
- @${ECHO_MSG} "If the patch does not work or causes the build to fail, just"
- @${ECHO_MSG} "stop using the patch; we will not further debug it."
- @${ECHO_MSG}
-.endif
.if !defined(WITH_DEBUG)
@${ECHO_MSG}
@${ECHO_MSG} "Enable or disable debugging with the following knob"
@@ -115,6 +100,8 @@ pre-build:
@${RM} -rf ${WRKSRC}/docs/gtk.info*
post-install:
+ -@${FIND} ${PREFIX}/share/icons -type d -depth 1 -exec \
+ ${PREFIX}/bin/gtk-update-icon-cache -q -f {} \; 2>/dev/null
@${MKDIR} ${PREFIX}/lib/gtk-2.0/modules
@${MKDIR} ${PREFIX}/lib/gtk-2.0/${GTK_VERSION}/engines
diff --git a/x11-toolkits/gtk20/distinfo b/x11-toolkits/gtk20/distinfo
index b725466f4aba..5766a84bc39b 100644
--- a/x11-toolkits/gtk20/distinfo
+++ b/x11-toolkits/gtk20/distinfo
@@ -1,4 +1,2 @@
-MD5 (gnome2/gtk+-2.6.10.tar.bz2) = 520090ef291e35ba93397060e20f5025
-SIZE (gnome2/gtk+-2.6.10.tar.bz2) = 11521380
-MD5 (gnome2/gtk+-2.4.0-menushadow.patch) = 5dde5c5af8f25d282c365663a7256b5c
-SIZE (gnome2/gtk+-2.4.0-menushadow.patch) = 15603
+MD5 (gnome2/gtk+-2.8.6.tar.bz2) = 2bcb9e3feb62ac895101cb8ee87ca49a
+SIZE (gnome2/gtk+-2.8.6.tar.bz2) = 11818976
diff --git a/x11-toolkits/gtk20/files/patch-Makefile.in b/x11-toolkits/gtk20/files/patch-Makefile.in
index c47baaab5ef5..307fd6fc2f77 100644
--- a/x11-toolkits/gtk20/files/patch-Makefile.in
+++ b/x11-toolkits/gtk20/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig Thu Jan 22 19:40:10 2004
-+++ Makefile.in Thu Jan 22 19:40:52 2004
-@@ -286,7 +286,7 @@
+--- Makefile.in.orig Wed Aug 3 18:09:32 2005
++++ Makefile.in Wed Aug 3 18:10:01 2005
+@@ -288,7 +288,7 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
--SRC_SUBDIRS = gdk-pixbuf gdk gtk modules demos tests contrib
-+SRC_SUBDIRS = gdk-pixbuf gdk gtk modules demos contrib
- SUBDIRS = po po-properties $(SRC_SUBDIRS) docs build m4macros
+-SRC_SUBDIRS = gdk-pixbuf gdk gtk modules demos tests perf contrib
++SRC_SUBDIRS = gdk-pixbuf gdk gtk modules demos perf contrib
+ SUBDIRS = po po-properties $(SRC_SUBDIRS) docs m4macros
# require automake 1.4
diff --git a/x11-toolkits/gtk20/files/patch-ak b/x11-toolkits/gtk20/files/patch-ak
index cc94fa96593c..41bffeab1b08 100644
--- a/x11-toolkits/gtk20/files/patch-ak
+++ b/x11-toolkits/gtk20/files/patch-ak
@@ -1,5 +1,6 @@
$FreeBSD$
+ $MCom: ports/x11-toolkits/gtk20/files/patch-ak,v 1.16 2005/06/28 05:40:15 adamw Exp $
--- gdk/Makefile.in.orig Thu Feb 14 12:38:26 2002
+++ gdk/Makefile.in Thu Feb 14 12:45:37 2002
diff --git a/x11-toolkits/gtk20/files/patch-gtk_gtkcalendar.c b/x11-toolkits/gtk20/files/patch-gtk_gtkcalendar.c
new file mode 100644
index 000000000000..4dcf1fd052a5
--- /dev/null
+++ b/x11-toolkits/gtk20/files/patch-gtk_gtkcalendar.c
@@ -0,0 +1,10 @@
+--- gtk/gtkcalendar.c.orig Mon Oct 3 22:01:14 2005
++++ gtk/gtkcalendar.c Mon Oct 3 22:02:36 2005
+@@ -566,6 +566,7 @@ gtk_calendar_init (GtkCalendar *calendar
+ GtkCalendarPrivate *priv;
+ gchar *year_before;
+ gchar *langinfo;
++ gchar *week_start;
+ gint week_1stday = 0;
+ gint first_weekday = 1;
+ guint week_origin;
diff --git a/x11-toolkits/gtk20/files/patch-gtk_gtkentry.c b/x11-toolkits/gtk20/files/patch-gtk_gtkentry.c
deleted file mode 100644
index e725de399cff..000000000000
--- a/x11-toolkits/gtk20/files/patch-gtk_gtkentry.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- gtk/gtkentry.c.orig Wed Aug 25 12:44:23 2004
-+++ gtk/gtkentry.c Wed Aug 25 12:44:52 2004
-@@ -1670,8 +1670,9 @@
- event->x + entry->scroll_offset, event->y))
- {
- GdkDragContext *context;
-+ guint actions;
- GtkTargetList *target_list = gtk_target_list_new (NULL, 0);
-- guint actions = entry->editable ? GDK_ACTION_COPY | GDK_ACTION_MOVE : GDK_ACTION_COPY;
-+ actions = entry->editable ? GDK_ACTION_COPY | GDK_ACTION_MOVE : GDK_ACTION_COPY;
-
- gtk_target_list_add_text_targets (target_list);
-
diff --git a/x11-toolkits/gtk20/files/patch-gtk_gtkiconcache.c b/x11-toolkits/gtk20/files/patch-gtk_gtkiconcache.c
deleted file mode 100644
index d393bd3dfa8d..000000000000
--- a/x11-toolkits/gtk20/files/patch-gtk_gtkiconcache.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- gtk/gtkiconcache.c.orig Sun Dec 12 16:09:13 2004
-+++ gtk/gtkiconcache.c Thu Dec 16 17:09:23 2004
-@@ -21,6 +21,8 @@
- #include "gtkdebug.h"
- #include "gtkiconcache.h"
- #include <glib/gstdio.h>
-+#include <sys/types.h>
-+#include <sys/stat.h>
-
- #ifdef HAVE_MMAP
- #include <sys/mman.h>
-@@ -29,8 +31,6 @@
- #include <windows.h>
- #include <io.h>
- #endif
--#include <sys/types.h>
--#include <sys/stat.h>
- #ifdef HAVE_UNISTD_H
- #include <unistd.h>
- #endif
diff --git a/x11-toolkits/gtk20/pkg-plist b/x11-toolkits/gtk20/pkg-plist
index ec10564dc771..a7a06be2c7d3 100644
--- a/x11-toolkits/gtk20/pkg-plist
+++ b/x11-toolkits/gtk20/pkg-plist
@@ -14,11 +14,13 @@ include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-features.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-io.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-loader.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-marshal.h
+include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-simple-anim.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-transform.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf.h
include/gtk-2.0/gdk-pixbuf/gdk-pixdata.h
include/gtk-2.0/gdk/gdk.h
include/gtk-2.0/gdk/gdkalias.h
+include/gtk-2.0/gdk/gdkcairo.h
include/gtk-2.0/gdk/gdkcolor.h
include/gtk-2.0/gdk/gdkcursor.h
include/gtk-2.0/gdk/gdkdisplay.h
@@ -253,16 +255,16 @@ lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-xbm.so
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-xpm.so
lib/libgdk-x11-2.0.a
lib/libgdk-x11-2.0.so
-lib/libgdk-x11-2.0.so.600
+lib/libgdk-x11-2.0.so.0
lib/libgdk_pixbuf-2.0.a
lib/libgdk_pixbuf-2.0.so
-lib/libgdk_pixbuf-2.0.so.600
+lib/libgdk_pixbuf-2.0.so.0
lib/libgdk_pixbuf_xlib-2.0.a
lib/libgdk_pixbuf_xlib-2.0.so
-lib/libgdk_pixbuf_xlib-2.0.so.600
+lib/libgdk_pixbuf_xlib-2.0.so.0
lib/libgtk-x11-2.0.a
lib/libgtk-x11-2.0.so
-lib/libgtk-x11-2.0.so.600
+lib/libgtk-x11-2.0.so.0
libdata/pkgconfig/gdk-2.0.pc
libdata/pkgconfig/gdk-pixbuf-2.0.pc
libdata/pkgconfig/gdk-pixbuf-xlib-2.0.pc
@@ -297,6 +299,7 @@ share/gtk-2.0/demo/gnu-keys.png
share/gtk-2.0/demo/gtk-logo-rgb.gif
share/gtk-2.0/demo/hypertext.c
share/gtk-2.0/demo/iconview.c
+share/gtk-2.0/demo/iconview_edit.c
share/gtk-2.0/demo/images.c
share/gtk-2.0/demo/list_store.c
share/gtk-2.0/demo/menus.c
@@ -385,6 +388,8 @@ share/locale/ja/LC_MESSAGES/gtk20-properties.mo
share/locale/ja/LC_MESSAGES/gtk20.mo
share/locale/ko/LC_MESSAGES/gtk20-properties.mo
share/locale/ko/LC_MESSAGES/gtk20.mo
+share/locale/ku/LC_MESSAGES/gtk20-properties.mo
+share/locale/ku/LC_MESSAGES/gtk20.mo
share/locale/li/LC_MESSAGES/gtk20-properties.mo
share/locale/li/LC_MESSAGES/gtk20.mo
share/locale/lt/LC_MESSAGES/gtk20-properties.mo
@@ -445,6 +450,8 @@ share/locale/sv/LC_MESSAGES/gtk20-properties.mo
share/locale/sv/LC_MESSAGES/gtk20.mo
share/locale/ta/LC_MESSAGES/gtk20-properties.mo
share/locale/ta/LC_MESSAGES/gtk20.mo
+share/locale/te/LC_MESSAGES/gtk20-properties.mo
+share/locale/te/LC_MESSAGES/gtk20.mo
share/locale/th/LC_MESSAGES/gtk20-properties.mo
share/locale/th/LC_MESSAGES/gtk20.mo
share/locale/tk/LC_MESSAGES/gtk20-properties.mo
@@ -470,20 +477,17 @@ share/locale/zh_CN/LC_MESSAGES/gtk20.mo
share/locale/zh_TW/LC_MESSAGES/gtk20-properties.mo
share/locale/zh_TW/LC_MESSAGES/gtk20.mo
share/themes/Default/gtk-2.0-key/gtkrc
-share/themes/Default/gtk-2.0/gtkrc
share/themes/Emacs/gtk-2.0-key/gtkrc
+share/themes/Raleigh/gtk-2.0/gtkrc
+@exec /usr/bin/find %D/share/icons -type d -depth 1 -exec %D/bin/gtk-update-icon-cache -q -f {} \; 2>/dev/null || /usr/bin/true
+@unexec /usr/bin/find %D/share/icons -type f -depth 2 -name icon-theme.cache -delete 2>/dev/null || /usr/bin/true
+@dirrm share/themes/Raleigh/gtk-2.0
+@dirrm share/themes/Raleigh
@dirrm share/themes/Emacs/gtk-2.0-key
@dirrm share/themes/Emacs
@dirrm share/themes/Default/gtk-2.0-key
-@dirrm share/themes/Default/gtk-2.0
@dirrm share/gtk-2.0/demo
@dirrm share/gtk-2.0
-@unexec /bin/rmdir %D/lib/gtk-2.0/modules 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/lib/gtk-2.0/%%GTK_VERSION%%/loaders 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/lib/gtk-2.0/%%GTK_VERSION%%/immodules 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/lib/gtk-2.0/%%GTK_VERSION%%/engines 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/lib/gtk-2.0/%%GTK_VERSION%% 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/lib/gtk-2.0 2>/dev/null || /usr/bin/true
@dirrm include/gtk-2.0/gtk
@dirrm include/gtk-2.0/gdk-pixbuf-xlib
@dirrm include/gtk-2.0/gdk-pixbuf
@@ -494,27 +498,37 @@ share/themes/Emacs/gtk-2.0-key/gtkrc
@exec /bin/mkdir -p %D/lib/gtk-2.0/%%GTK_VERSION%%/engines
@unexec /bin/rmdir %D/share/themes/Default 2>/dev/null || /usr/bin/true
@unexec /bin/rmdir %D/share/themes 2>/dev/null || /usr/bin/true
-@unexec rmdir %D/share/locale/az_IR/LC_MESSAGES 2> /dev/null || true
-@unexec rmdir %D/share/locale/az_IR 2> /dev/null || true
-@unexec rmdir %D/share/locale/br/LC_MESSAGES 2> /dev/null || true
-@unexec rmdir %D/share/locale/br 2> /dev/null || true
-@unexec rmdir %D/share/locale/hy/LC_MESSAGES 2> /dev/null || true
-@unexec rmdir %D/share/locale/hy 2> /dev/null || true
-@unexec rmdir %D/share/locale/ia/LC_MESSAGES 2> /dev/null || true
-@unexec rmdir %D/share/locale/ia 2> /dev/null || true
-@unexec rmdir %D/share/locale/mi/LC_MESSAGES 2> /dev/null || true
-@unexec rmdir %D/share/locale/mi 2> /dev/null || true
-@unexec rmdir %D/share/locale/mr/LC_MESSAGES 2> /dev/null || true
-@unexec rmdir %D/share/locale/mr 2> /dev/null || true
-@unexec rmdir %D/share/locale/nso/LC_MESSAGES 2> /dev/null || true
-@unexec rmdir %D/share/locale/nso 2> /dev/null || true
-@unexec rmdir %D/share/locale/rw/LC_MESSAGES 2> /dev/null || true
-@unexec rmdir %D/share/locale/rw 2> /dev/null || true
-@unexec rmdir %D/share/locale/sr@ije/LC_MESSAGES 2> /dev/null || true
-@unexec rmdir %D/share/locale/sr@ije 2> /dev/null || true
-@unexec rmdir %D/share/locale/uz@Latn/LC_MESSAGES 2> /dev/null || true
-@unexec rmdir %D/share/locale/uz@Latn 2> /dev/null || true
@unexec rmdir %D/share/locale/yi/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/yi 2> /dev/null || true
-@unexec rmdir %D/share/locale/xh/LC_MESSAGES/ 2> /dev/null || true
+@unexec rmdir %D/share/locale/xh/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/xh 2> /dev/null || true
+@unexec rmdir %D/share/locale/te/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/te 2> /dev/null || true
+@unexec rmdir %D/share/locale/uz@Latn/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/uz@Latn 2> /dev/null || true
+@unexec rmdir %D/share/locale/sr@ije/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/sr@ije 2> /dev/null || true
+@unexec rmdir %D/share/locale/rw/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/rw 2> /dev/null || true
+@unexec rmdir %D/share/locale/nso/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/nso 2> /dev/null || true
+@unexec rmdir %D/share/locale/mr/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/mr 2> /dev/null || true
+@unexec rmdir %D/share/locale/mi/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/mi 2> /dev/null || true
+@unexec rmdir %D/share/locale/ku/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/ku 2> /dev/null || true
+@unexec rmdir %D/share/locale/ia/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/ia 2> /dev/null || true
+@unexec rmdir %D/share/locale/hy/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/hy 2> /dev/null || true
+@unexec rmdir %D/share/locale/br/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/br 2> /dev/null || true
+@unexec rmdir %D/share/locale/az_IR/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/az_IR 2> /dev/null || true
+@unexec /bin/rmdir %D/lib/gtk-2.0/modules 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/lib/gtk-2.0/%%GTK_VERSION%%/loaders 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/lib/gtk-2.0/%%GTK_VERSION%%/immodules 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/lib/gtk-2.0/%%GTK_VERSION%%/engines 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/lib/gtk-2.0/%%GTK_VERSION%% 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/lib/gtk-2.0 2>/dev/null || /usr/bin/true