aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtk20
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-05-03 15:07:01 +0800
committermarcus <marcus@FreeBSD.org>2003-05-03 15:07:01 +0800
commit0060d38bd82d37a0f5645957430313f8b7946f34 (patch)
tree1fc88fd7326e78b563a0742c8e5e530fed6b067b /x11-toolkits/gtk20
parent9ddc7f1308662f6048cc522ffaed58287929510a (diff)
downloadfreebsd-ports-gnome-0060d38bd82d37a0f5645957430313f8b7946f34.tar.gz
freebsd-ports-gnome-0060d38bd82d37a0f5645957430313f8b7946f34.tar.zst
freebsd-ports-gnome-0060d38bd82d37a0f5645957430313f8b7946f34.zip
Link executables with -pthread so that they can work with threaded libraries
like libgthread.
Diffstat (limited to 'x11-toolkits/gtk20')
-rw-r--r--x11-toolkits/gtk20/Makefile1
-rw-r--r--x11-toolkits/gtk20/files/patch-ag14
-rw-r--r--x11-toolkits/gtk20/files/patch-gdk-pixbuf_Makefile.in13
3 files changed, 25 insertions, 3 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index 8385d8441535..68019d86dfc8 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtk
PORTVERSION= 2.2.1
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.2,} \
ftp://ftp.gtk.org/pub/gtk/v2.0/ \
diff --git a/x11-toolkits/gtk20/files/patch-ag b/x11-toolkits/gtk20/files/patch-ag
index b0be157797ed..c4879a292522 100644
--- a/x11-toolkits/gtk20/files/patch-ag
+++ b/x11-toolkits/gtk20/files/patch-ag
@@ -1,6 +1,6 @@
---- gtk/Makefile.in.orig Thu Dec 12 12:07:53 2002
-+++ gtk/Makefile.in Thu Dec 12 12:08:43 2002
-@@ -183,7 +183,7 @@
+--- gtk/Makefile.in.orig Sat May 3 02:43:20 2003
++++ gtk/Makefile.in Sat May 3 02:46:30 2003
+@@ -175,7 +175,7 @@
-DG_LOG_DOMAIN=\"Gtk\" \
-DGTK_LIBDIR=\"$(libdir)\" \
-DGTK_DATA_PREFIX=\"$(prefix)\" \
@@ -9,3 +9,11 @@
-DGTK_VERSION=\"@GTK_VERSION@\" \
-DGTK_BINARY_VERSION=\"@GTK_BINARY_VERSION@\" \
-DGTK_HOST=\"@host@\" \
+@@ -651,6 +651,7 @@
+ TEST_DEPS = $(DEPS) gtk.immodules
+
+ LDADDS = @STRIP_BEGIN@ \
++ $(GLIB_LIBS) \
+ $(gtktargetlib) \
+ $(top_builddir)/gdk-pixbuf/libgdk_pixbuf-$(GTK_API_VERSION).la \
+ $(top_builddir)/gdk/$(gdktargetlib) \
diff --git a/x11-toolkits/gtk20/files/patch-gdk-pixbuf_Makefile.in b/x11-toolkits/gtk20/files/patch-gdk-pixbuf_Makefile.in
new file mode 100644
index 000000000000..fa3e1270f1b2
--- /dev/null
+++ b/x11-toolkits/gtk20/files/patch-gdk-pixbuf_Makefile.in
@@ -0,0 +1,13 @@
+--- gdk-pixbuf/Makefile.in.orig Sat May 3 02:51:31 2003
++++ gdk-pixbuf/Makefile.in Sat May 3 02:51:59 2003
+@@ -384,7 +384,9 @@
+
+
+ AM_CPPFLAGS = "-DPIXBUF_LIBDIR=\"$(loaderdir)\"" "-DBUILT_MODULES_DIR=\"$(srcdir)/.libs\""
+-LDADDS = libgdk_pixbuf-$(GTK_API_VERSION).la
++LDADDS = \
++ $(GLIB_LIBS) \
++ libgdk_pixbuf-$(GTK_API_VERSION).la
+
+ noinst_PROGRAMS = test-gdk-pixbuf
+ test_gdk_pixbuf_LDADD = $(LDADDS)