aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtkmm30/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-06-09 07:54:27 +0800
committersteve <steve@FreeBSD.org>1999-06-09 07:54:27 +0800
commitcd67bb9978e117dbacdffcd1da011f7d19ee5fac (patch)
tree3b718f9910252789e56ae60c7b6c7933bbc5b7d0 /x11-toolkits/gtkmm30/Makefile
parente9918fa09064206e845ec4286ddd90bc07c4c738 (diff)
downloadfreebsd-ports-gnome-cd67bb9978e117dbacdffcd1da011f7d19ee5fac.tar.gz
freebsd-ports-gnome-cd67bb9978e117dbacdffcd1da011f7d19ee5fac.tar.zst
freebsd-ports-gnome-cd67bb9978e117dbacdffcd1da011f7d19ee5fac.zip
Make sure we pass CC and CXX in configure's environment so that
boxes that require egcs from the ports collection will use it instaed of the system compiler. PR: 1176 Submitted by: Yukihiro Nakai <nacai@iname.com>
Diffstat (limited to 'x11-toolkits/gtkmm30/Makefile')
-rw-r--r--x11-toolkits/gtkmm30/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11-toolkits/gtkmm30/Makefile b/x11-toolkits/gtkmm30/Makefile
index fbf3723ec1d3..a01dfab836a4 100644
--- a/x11-toolkits/gtkmm30/Makefile
+++ b/x11-toolkits/gtkmm30/Makefile
@@ -3,7 +3,7 @@
# Date created: 11 May 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
-# $Id: Makefile,v 1.8 1999/05/12 11:37:22 asami Exp $
+# $Id: Makefile,v 1.9 1999/05/29 03:55:36 steve Exp $
#
DISTNAME= Gtk---1.0.0
@@ -31,9 +31,9 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static=yes \
--without-gnome
-CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}"
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" CC="${CC}" CXX="${CXX}"
-MAN3= G_IntList.3 G_IntList_Iterator.3 G_List.3 G_List_Cpp_Iterator.3 \
+MAN3= G_IntList.3 G_IntList_Iterator.3 G_List.3 G_List_Cpp_Iterator.3 \
G_List_Iterator.3 G_SList_Iterator.3 GtkBase.3 GtkBaseClass.3 \
Gtk_AccelEntry.3 Gtk_AccelGroup.3 Gtk_AccelLabel.3 Gtk_Adjustment.3 \
Gtk_Alignment.3 Gtk_ArgBase.3 Gtk_ArgObject.3 Gtk_ArgSimple.3 \
@@ -68,4 +68,7 @@ MAN3= G_IntList.3 G_IntList_Iterator.3 G_List.3 G_List_Cpp_Iterator.3 \
ToolbarConnector.3 ToolbarConnectorBase.3 Toolbar_Child.3 \
_gtk_string.3 gtkmm_add_signal_class.3
+post-install:
+ @${CAT} ${PKGDIR}/MESSAGE
+
.include <bsd.port.post.mk>