aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/guile-gnome
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-10-05 14:42:57 +0800
committerreg <reg@FreeBSD.org>2000-10-05 14:42:57 +0800
commit72ce7050d03c812e37966786e11996a90713afea (patch)
tree9ec01d647da1c4e80223e31fc766740c2a43ebff /x11-toolkits/guile-gnome
parent97830337b8c0333a12d15a49ea1f9c9cdc3dfddf (diff)
downloadfreebsd-ports-gnome-72ce7050d03c812e37966786e11996a90713afea.tar.gz
freebsd-ports-gnome-72ce7050d03c812e37966786e11996a90713afea.tar.zst
freebsd-ports-gnome-72ce7050d03c812e37966786e11996a90713afea.zip
Implement USE_GTK, part 2.
Diffstat (limited to 'x11-toolkits/guile-gnome')
-rw-r--r--x11-toolkits/guile-gnome/Makefile9
-rw-r--r--x11-toolkits/guile-gnome/files/patch-ad11
2 files changed, 13 insertions, 7 deletions
diff --git a/x11-toolkits/guile-gnome/Makefile b/x11-toolkits/guile-gnome/Makefile
index c079948c1266..574d50add2cf 100644
--- a/x11-toolkits/guile-gnome/Makefile
+++ b/x11-toolkits/guile-gnome/Makefile
@@ -14,20 +14,15 @@ DISTNAME= gnome-guile-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- guile.9:${PORTSDIR}/lang/guile \
+LIB_DEPENDS= guile.9:${PORTSDIR}/lang/guile \
guilegtk-1.2.0:${PORTSDIR}/x11-toolkits/guile-gtk \
glade.4:${PORTSDIR}/devel/libglade
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
-
USE_LIBTOOL= yes
+USE_GTK= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --without-bonobo --without-gtkhtml --with-libglade
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- GTK_CONFIG="${GTK_CONFIG}" \
- GLIB_CONFIG="${GLIB_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
diff --git a/x11-toolkits/guile-gnome/files/patch-ad b/x11-toolkits/guile-gnome/files/patch-ad
new file mode 100644
index 000000000000..7b9b2527dd24
--- /dev/null
+++ b/x11-toolkits/guile-gnome/files/patch-ad
@@ -0,0 +1,11 @@
+--- guile-gnome/libglade/Makefile.in.orig Mon Oct 2 01:09:47 2000
++++ guile-gnome/libglade/Makefile.in Mon Oct 2 01:11:08 2000
+@@ -97,7 +97,7 @@
+ INCLUDES = -I.. -I$(srcdir)/.. -I../../guile-gtk -I$(srcdir)/../../guile-gtk -I$(includedir) $(GUILE_INCS) $(GNOME_INCLUDEDIR)
+
+
+-GLADE_LIBS = -lglade -lglade-gnome -lglade-bonobo
++GLADE_LIBS = `libglade-config --libs gnome`
+
+ lib_LTLIBRARIES = libguileglade.la
+ libguileglade_la_SOURCES = libglade-glue.c