aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/hs-GLUT
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2009-09-02 23:38:45 +0800
committerpgj <pgj@FreeBSD.org>2009-09-02 23:38:45 +0800
commit287f50302a59b3a75af8cd8263480951b70ad176 (patch)
tree14860ef0ad1ca08c47d77a5ed1d140cbef657d2a /x11-toolkits/hs-GLUT
parentf095667176485d73e004654a71204b209d48fb1f (diff)
downloadfreebsd-ports-gnome-287f50302a59b3a75af8cd8263480951b70ad176.tar.gz
freebsd-ports-gnome-287f50302a59b3a75af8cd8263480951b70ad176.tar.zst
freebsd-ports-gnome-287f50302a59b3a75af8cd8263480951b70ad176.zip
- Update GHC and Haskell ports to 6.10.4 (for both i386 and amd64), bump
port revision where appropriate - Add devel/hs-ghc-paths - Add devel/hs-QuickCheck - Add devel/hs-readline - Add devel/hs-haskeline - Add devel/hs-mmap - Remove lang/ghc-doc - Mark devel/lhs2TeX broken as it does not compile with GHC 6.10.4 - Set NHC98 as default compiler for devel/hs-hat as it does not compile with GHC 6.10.4 PR: ports/137055, ports/137058, ports/137059, ports/137060, ports/137061, ports/137062, ports/137063, ports/137063, ports/137064, ports/137065, ports/137066, ports/137067, ports/137068, ports/137069, ports/137070, ports/137071, ports/137072, ports/137074, ports/137075, ports/137076, ports/137077, ports/137078, ports/137079, ports/137080, ports/137081, ports/137082, ports/137083, ports/137084, ports/137085, ports/137086, ports/137087, ports/137088, ports/137090, ports/137091, ports/137092, ports/137093, ports/137094, ports/137095, ports/137096, ports/137097, ports/137098, ports/137099, ports/137102, ports/137103, ports/137104, ports/137107, ports/137108, ports/137109, ports/137110, ports/137111 Submitted by: Jacula Modyun (jacula (at) gmail (dot) com), Ashish Shukla (wahjava (at) gmail (dot) com) (amd64 support) Supported by: wxs (review, amd64 testing), tabthorpe (8.x testing) Approved by: tabthorpe (mentor), respective maintainers
Diffstat (limited to 'x11-toolkits/hs-GLUT')
-rw-r--r--x11-toolkits/hs-GLUT/Makefile80
-rw-r--r--x11-toolkits/hs-GLUT/distinfo6
-rw-r--r--x11-toolkits/hs-GLUT/pkg-plist69
3 files changed, 90 insertions, 65 deletions
diff --git a/x11-toolkits/hs-GLUT/Makefile b/x11-toolkits/hs-GLUT/Makefile
index 8541f604e130..525c49cc94ea 100644
--- a/x11-toolkits/hs-GLUT/Makefile
+++ b/x11-toolkits/hs-GLUT/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= glut
-PORTVERSION= 2.1.1.2
-PORTREVISION= 1
+PORTVERSION= 2.1.2.1
CATEGORIES= x11-toolkits haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/GLUT/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -18,46 +17,69 @@ COMMENT= A Haskell binding for the OpenGL Utility Toolkit
USE_GL= glut
-GHC_VERSION= 6.8.3
-PLIST_SUB+= GHC_VERSION=${GHC_VERSION} \
- PORTVERSION=${PORTVERSION} \
- PORTNAME=${PORTNAME} \
- SUBDIR=lib/ghc-${GHC_VERSION}/cabal
-DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
-PORTDOCS= LICENSE html
-
-.include <bsd.port.pre.mk>
-
BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
- ${LOCALBASE}/lib/ghc-${GHC_VERSION}/cabal/opengl-register.sh:${PORTSDIR}/x11-toolkits/hs-opengl-ghc
+ hs-opengl-ghc>=2.2:${PORTSDIR}/x11-toolkits/hs-opengl-ghc
+RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+ hs-opengl-ghc>=2.2:${PORTSDIR}/x11-toolkits/hs-opengl-ghc
LIB_DEPENDS+= gmp.8:${PORTSDIR}/math/libgmp4
-RUN_DEPENDS+= ${LOCALBASE}/lib/ghc-${GHC_VERSION}/cabal/opengl-register.sh:${PORTSDIR}/x11-toolkits/hs-opengl-ghc
-# 'owned' by lang/ghc:
-CABALDIR= ${PREFIX}/lib/ghc-${GHC_VERSION}/cabal
-CABALCMD= ${LOCALBASE}/bin/runghc Setup.hs
-SUBDIR= ${PORTNAME}${PKGNAMESUFFIX}
+GHC_VERSION= 6.10.4
+HSGLUT_VERSION= ${PORTVERSION}
+
+GHC_CMD= ${LOCALBASE}/bin/ghc
+SETUP_CMD= ./setup
+
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+HSGLUT_LIBDIR_REL= lib/${DISTNAME}
+
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ HSGLUT_VERSION=${HSGLUT_VERSION} \
+ HSGLUT_LIBDIR_REL=${HSGLUT_LIBDIR_REL}
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= NOPORTDOCS=""
+.else
+PLIST_SUB+= NOPORTDOCS="@comment "
+.endif
.if !defined(NOPORTDOCS)
+
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if !empty(PORT_HADDOCK:M?0)
BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
-PLIST_SUB+= RMLIC="@comment "
-.else
-PLIST_SUB+= RMLIC=""
+.endif
+BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
+
+HSCOLOUR_VERSION= 1.13
+HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
+
+PORTDOCS= *
.endif
+.SILENT:
+
+post-patch:
+ @${REINPLACE_CMD} 's|/usr/local/include|${LOCALBASE}/include|g' \
+ ${WRKSRC}/configure
+
do-configure:
- cd ${WRKSRC} && ${CABALCMD} configure --ghc --prefix=${PREFIX} --libdir=${CABALDIR} \
- --libsubdir='' --datasubdir=''
+ cd ${WRKSRC} && ${GHC_CMD} --make Setup.hs -o setup -package Cabal \
+ && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
do-build:
- cd ${WRKSRC} && ${CABALCMD} build \
- && ${CABALCMD} --gen-script register
+ cd ${WRKSRC} && ${SETUP_CMD} build \
+ && ${SETUP_CMD} register --gen-script
+
.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${CABALCMD} haddock
+ cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
+ --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
.endif
do-install:
- cd ${WRKSRC} && ${CABALCMD} install \
- && ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${CABALDIR}/${PORTNAME}-register.sh
+ cd ${WRKSRC} && ${SETUP_CMD} install \
+ && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${HSGLUT_LIBDIR_REL}/register.sh
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/hs-GLUT/distinfo b/x11-toolkits/hs-GLUT/distinfo
index d23ac8ebe73a..06900d54f25c 100644
--- a/x11-toolkits/hs-GLUT/distinfo
+++ b/x11-toolkits/hs-GLUT/distinfo
@@ -1,3 +1,3 @@
-MD5 (GLUT-2.1.1.2.tar.gz) = 67e5996a7fe56af764393f1cf80b9a43
-SHA256 (GLUT-2.1.1.2.tar.gz) = d5ecf4b6bacc5e68ade00710df04fa158c6ed322c74362954716a0baba6bd3fb
-SIZE (GLUT-2.1.1.2.tar.gz) = 121228
+MD5 (GLUT-2.1.2.1.tar.gz) = b97f476a04098701e330e86c1f89ed52
+SHA256 (GLUT-2.1.2.1.tar.gz) = 0230bfacbfb85c126f1fba45fcd8d02f20da9ee19180b5ada698224362d17264
+SIZE (GLUT-2.1.2.1.tar.gz) = 720222
diff --git a/x11-toolkits/hs-GLUT/pkg-plist b/x11-toolkits/hs-GLUT/pkg-plist
index 69e9196a268f..b2f9337ffce5 100644
--- a/x11-toolkits/hs-GLUT/pkg-plist
+++ b/x11-toolkits/hs-GLUT/pkg-plist
@@ -1,36 +1,39 @@
-%%SUBDIR%%/Graphics/UI/GLUT/Callbacks/Global.hi
-%%SUBDIR%%/Graphics/UI/GLUT/Callbacks/Window.hi
-%%SUBDIR%%/Graphics/UI/GLUT/Callbacks/Registration.hi
-%%SUBDIR%%/Graphics/UI/GLUT/Begin.hi
-%%SUBDIR%%/Graphics/UI/GLUT/Callbacks.hi
-%%SUBDIR%%/Graphics/UI/GLUT/Colormap.hi
-%%SUBDIR%%/Graphics/UI/GLUT/Debugging.hi
-%%SUBDIR%%/Graphics/UI/GLUT/DeviceControl.hi
-%%SUBDIR%%/Graphics/UI/GLUT/Fonts.hi
-%%SUBDIR%%/Graphics/UI/GLUT/GameMode.hi
-%%SUBDIR%%/Graphics/UI/GLUT/Initialization.hi
-%%SUBDIR%%/Graphics/UI/GLUT/Menu.hi
-%%SUBDIR%%/Graphics/UI/GLUT/Objects.hi
-%%SUBDIR%%/Graphics/UI/GLUT/Overlay.hi
-%%SUBDIR%%/Graphics/UI/GLUT/State.hi
-%%SUBDIR%%/Graphics/UI/GLUT/Window.hi
-%%SUBDIR%%/Graphics/UI/GLUT/Constants.hi
-%%SUBDIR%%/Graphics/UI/GLUT/Extensions.hi
-%%SUBDIR%%/Graphics/UI/GLUT/QueryUtils.hi
-%%SUBDIR%%/Graphics/UI/GLUT/Types.hi
-%%SUBDIR%%/Graphics/UI/GLUT.hi
-%%SUBDIR%%/libHSGLUT-%%PORTVERSION%%.a
-%%SUBDIR%%/HSGLUT-%%PORTVERSION%%.o
-%%SUBDIR%%/include/HsGLUT.h
-%%SUBDIR%%/%%PORTNAME%%-register.sh
-%%RMLIC%%%%DOCSDIR%%/LICENSE
-%%RMLIC%%@dirrm %%DOCSDIR%%
-@dirrm %%SUBDIR%%/Graphics/UI/GLUT/Callbacks
-@dirrm %%SUBDIR%%/Graphics/UI/GLUT
-@dirrmtry %%SUBDIR%%/Graphics/UI
-@dirrmtry %%SUBDIR%%/Graphics
-@dirrmtry %%SUBDIR%%/include
-@exec /bin/sh %D/%%SUBDIR%%/%%PORTNAME%%-register.sh
+@comment $FreeBSD$
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Begin.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Callbacks.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Callbacks/Global.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Callbacks/Registration.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Callbacks/Window.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Colormap.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Constants.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Debugging.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/DeviceControl.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Extensions.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Fonts.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/GameMode.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Initialization.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Menu.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Objects.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Overlay.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/QueryUtils.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/State.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Types.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Window.hi
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HSGLUT-%%HSGLUT_VERSION%%.o
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/include/HsGLUT.h
+%%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHSGLUT-%%HSGLUT_VERSION%%.a
+%%HSGLUT_LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/include
+@dirrm %%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT/Callbacks
+@dirrm %%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI/GLUT
+@dirrm %%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/UI
+@dirrm %%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics
+@dirrm %%HSGLUT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%HSGLUT_LIBDIR_REL%%
+@exec /bin/sh %D/%%HSGLUT_LIBDIR_REL%%/register.sh
@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
@unexec %D/bin/ghc-pkg unregister GLUT
@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old