aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/iv/files/patch-ba
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-01-26 10:40:32 +0800
committersteve <steve@FreeBSD.org>1999-01-26 10:40:32 +0800
commit61d2df90e36f3fe27c59de27d00040e8ce99f13d (patch)
treea26988da91e305ae5118443c4869f9818384544e /x11-toolkits/iv/files/patch-ba
parent2531d31d7a62bc0b963af22d537d554707e5844a (diff)
downloadfreebsd-ports-gnome-61d2df90e36f3fe27c59de27d00040e8ce99f13d.tar.gz
freebsd-ports-gnome-61d2df90e36f3fe27c59de27d00040e8ce99f13d.tar.zst
freebsd-ports-gnome-61d2df90e36f3fe27c59de27d00040e8ce99f13d.zip
Correct build on ELF and add maintainer.
PR: 9594 Submitted by: Seigou Tanimura <tanimura@naklab.dnj.ynu.ac.jp>
Diffstat (limited to 'x11-toolkits/iv/files/patch-ba')
-rw-r--r--x11-toolkits/iv/files/patch-ba24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-toolkits/iv/files/patch-ba b/x11-toolkits/iv/files/patch-ba
new file mode 100644
index 000000000000..1df5bedc0793
--- /dev/null
+++ b/x11-toolkits/iv/files/patch-ba
@@ -0,0 +1,24 @@
+--- makefile.orig Sun Jan 17 20:56:19 1999
++++ makefile Sun Jan 17 20:48:39 1999
+@@ -0,0 +1,21 @@
++CPU=FREEBSD
++
++all: src/Makefile
++ @$(MAKE) $(.MAKEFLAGS) -f Makefile 'CPU=$(CPU)'
++
++# simple but brutal. Will not install to multiple destinations simultaneously.
++install: Makefile
++ @rm -rf installed ${DESTDIR}/usr/local/interviews
++ @mkdir -p ${DESTDIR}/usr/local/interviews
++ @ln -s ${DESTDIR}/usr/local/interviews installed
++ @$(MAKE) $(.MAKEFLAGS) -f Makefile 'CPU=$(CPU)' $@
++
++src/Makefile: Makefile
++ @$(MAKE) Makefiles
++
++Makefile:
++ imake -T "InterViews/template" -I./src/config \
++ -I/usr/X11R6/lib/X11/config -DTOPDIR=. -DCURDIR=.
++
++.DEFAULT: src/Makefile
++ @$(MAKE) $(.MAKEFLAGS) -f Makefile 'CPU=$(CPU)' $@