diff options
author | trevor <trevor@FreeBSD.org> | 2004-03-13 01:05:45 +0800 |
---|---|---|
committer | trevor <trevor@FreeBSD.org> | 2004-03-13 01:05:45 +0800 |
commit | 2ad226e31330ed99eade11510fa59a854f650fbf (patch) | |
tree | 9273d2ef32ed4460f8517c60a12609d684938125 /x11-toolkits/jx | |
parent | cf6e77e277f92a7d86bf7f7352905351ffb2465f (diff) | |
download | freebsd-ports-gnome-2ad226e31330ed99eade11510fa59a854f650fbf.tar.gz freebsd-ports-gnome-2ad226e31330ed99eade11510fa59a854f650fbf.tar.zst freebsd-ports-gnome-2ad226e31330ed99eade11510fa59a854f650fbf.zip |
Only one of the Linuxberg sites (as it happens, the Brazilian one)
has the original distfile. A slightly different distfile is available
from Sunsite:
diff -burN linuxberg/include/make/jx_config_common sunsite/include/make/jx_config_common
--- linuxberg/include/make/jx_config_common Sat Sep 25 19:25:40 1999
+++ sunsite/include/make/jx_config_common Wed Sep 1 02:18:53 1999
@@ -7,14 +7,14 @@
ifeq ($(findstring g++,$(CXX)),g++)
ifeq ($(CXX),g++)
- JX_HAS_GNUG_PRE_2_8 := $(shell \
- if { $(CXX) --version | egrep '^(cygnus-)?2\.[0-7]' > /dev/null; } \
- then { echo 1; } \
- else { echo 0; } fi)
- JX_HAS_GNUG_2_95 := $(shell \
- if { $(CXX) --version | egrep '^(cygnus-)?2\.95' > /dev/null; } \
- then { echo 1; } \
- else { echo 0; } fi)
+ JX_HAS_GNUG_PRE_2_8 := \
+ $(shell \
+ if $(CXX) --version | egrep '^(cygnus-)?2\.[0-7]' > /dev/null; then \
+ echo 1; else echo 0; fi)
+ JX_HAS_GNUG_2_95 := \
+ $(shell \
+ if $(CXX) --version | egrep '^(cygnus-)?2\.95' > /dev/null; then \
+ echo 1; else echo 0; fi)
else # ! g++
ifeq (eg++,$(findstring eg++,$(CXX)))
# Assume that eg++ is egcs.
diff -burN linuxberg/include/make/jx_constants sunsite/include/make/jx_constants
--- linuxberg/include/make/jx_constants Sat Sep 25 19:25:30 1999
+++ sunsite/include/make/jx_constants Tue Sep 21 20:31:57 1999
@@ -23,9 +23,9 @@
ifdef JX_INSTALL_ROOT
override JX_INSTALL_ROOT := \
- ${shell if { test -d ${JX_INSTALL_ROOT} -a -w ${JX_INSTALL_ROOT}; } \
- then { echo ${JX_INSTALL_ROOT}; } \
- else { echo; } fi }
+ ${shell if { test -d ${JX_INSTALL_ROOT} -a -w ${JX_INSTALL_ROOT} } \
+ then { echo ${JX_INSTALL_ROOT} } \
+ else { echo } fi; }
endif
ifndef JX_INSTALL_ROOT
@@ -33,10 +33,10 @@
override JX_INSTALL_ROOT := ${JX_ROOT_BIN_DIRECTORY}
else
override JX_INSTALL_ROOT := \
- ${shell if { test -d ${HOME}/bin -a -w ${HOME}/bin; } \
- then { echo ${HOME}/bin; } \
+ ${shell if { test -d ${HOME}/bin -a -w ${HOME}/bin } \
+ then { echo ${HOME}/bin } \
else { test -d ${JX_ROOT}/bin || mkdir ${JX_ROOT}/bin; \
- echo ${JX_ROOT}/bin; } fi }
+ echo ${JX_ROOT}/bin } fi; }
endif
endif
diff -burN linuxberg/libjx/code/jXUtil.cc sunsite/libjx/code/jXUtil.cc
--- linuxberg/libjx/code/jXUtil.cc Mon Sep 27 20:59:37 1999
+++ sunsite/libjx/code/jXUtil.cc Thu Aug 26 20:22:57 1999
@@ -392,7 +392,7 @@
for (JIndex i=newCount; i>origCount; i--)
{
const JString* url = fileNameList->NthElement(i);
- if (url->IsEmpty() || url->GetFirstCharacter() == kURICommentMarker)
+ if (url->GetFirstCharacter() == kURICommentMarker)
{
fileNameList->DeleteElement(i);
}
Diffstat (limited to 'x11-toolkits/jx')
-rw-r--r-- | x11-toolkits/jx/Makefile | 8 | ||||
-rw-r--r-- | x11-toolkits/jx/distinfo | 2 |
2 files changed, 4 insertions, 6 deletions
diff --git a/x11-toolkits/jx/Makefile b/x11-toolkits/jx/Makefile index 1cb5bc883e3b..1b8eea43aaa6 100644 --- a/x11-toolkits/jx/Makefile +++ b/x11-toolkits/jx/Makefile @@ -9,11 +9,9 @@ PORTNAME= JX PORTVERSION= 1.5.3 PORTREVISION= 2 CATEGORIES= x11-toolkits -MASTER_SITES= ftp://ftp.fct.unl.pt/.2/linuxberg/files/x11/dev/ \ - ftp://ftp.cadvision.com/pub/linuxberg/files/x11/dev/ \ - ftp://ftp.matrix.com.br/pub/linuxberg/files/x11/dev/ \ - ftp://ftp.duth.gr/pub/linuxberg/files/x11/dev/ \ - ftp://ftp.rz.uni-karlsruhe.de/pub/mirror/ftp.uni-tuebingen.de/pub/linux/mirrors/ftp.metalab.unc.edu/pub/Linux/libs/X/c++libs/ +MASTER_SITES= ftp://ftp.matrix.com.br/pub/linuxberg/files/x11/dev/ \ + ${MASTER_SITE_SUNSITE} +MASTER_SITE_SUBDIR= libs/X/c++libs DISTNAME= ${PORTNAME}_source-${PORTVERSION} MAINTAINER= ports@FreeBSD.org diff --git a/x11-toolkits/jx/distinfo b/x11-toolkits/jx/distinfo index 50166e69eef5..b9b4b0491191 100644 --- a/x11-toolkits/jx/distinfo +++ b/x11-toolkits/jx/distinfo @@ -1,2 +1,2 @@ MD5 (JX_source-1.5.3.tar.gz) = e35ea2a77c777d96c3d9b566254d2562 -SIZE (JX_source-1.5.3.tar.gz) = 4099620 +MD5 (JX_source-1.5.3.tar.gz) = 311c4267ffd114a3b3ec76af09db5ecb |