aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/libjtree
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-09-18 05:29:14 +0800
committersteve <steve@FreeBSD.org>2000-09-18 05:29:14 +0800
commit69a32c70981fb6e624d90f66f79cd51455de62b8 (patch)
treef9c5214314c400b8eb748ea34b7b9d89a42e7225 /x11-toolkits/libjtree
parent991e5673af7c6446577cfeddec2e113c934e62c6 (diff)
downloadfreebsd-ports-gnome-69a32c70981fb6e624d90f66f79cd51455de62b8.tar.gz
freebsd-ports-gnome-69a32c70981fb6e624d90f66f79cd51455de62b8.tar.zst
freebsd-ports-gnome-69a32c70981fb6e624d90f66f79cd51455de62b8.zip
Fix these ports so that among other things they look for the jx header
files in the correct place. Submitted by: maintainer
Diffstat (limited to 'x11-toolkits/libjtree')
-rw-r--r--x11-toolkits/libjtree/Makefile33
-rw-r--r--x11-toolkits/libjtree/files/patch-aa18
-rw-r--r--x11-toolkits/libjtree/pkg-plist4
3 files changed, 29 insertions, 26 deletions
diff --git a/x11-toolkits/libjtree/Makefile b/x11-toolkits/libjtree/Makefile
index 0fa988b6379e..cbbeaee75325 100644
--- a/x11-toolkits/libjtree/Makefile
+++ b/x11-toolkits/libjtree/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libjtree
PORTVERSION= 1.1.7
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.newplanetsoftware.com/pub/jx/source-1.5.3/ \
ftp://ftp.newplanetsoftware.com/pub/jcc/source/ \
@@ -16,32 +17,27 @@ DISTNAME= JTree_source-${PORTVERSION}
MAINTAINER= lioux@linf.unb.br
-BUILD_DEPENDS= /nonexistent:${JXPORT}:patch
+BUILD_DEPENDS= nonexistent:${JXPORT}:configure \
+ makemake:${JXPORT}
LIB_DEPENDS= jx-1_5_3.1:${JXPORT}
WRKSRC= ${WRKDIR}/JX-1.5.3
-USE_XLIB= yes
-INSTALLS_SHLIB= yes
+USE_X_PREFIX= yes
USE_GMAKE= yes
+MAKE_ARGS= CC="${CC}" CXX="${CXX}" \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
MAKE_ENV= JX_INSTALL_ROOT="${PREFIX}/bin" \
- JX_LIB_ROOT="${PREFIX}/lib" \
- X11PREFIX="${X11PREFIX}" \
- PORTCFLAGS="${CFLAGS}" \
- PORTCXXFLAGS="${CXXFLAGS}" \
- PORTINCLUDES="${PORTINCLUDES}"
+ JX_LIB_ROOT="${PREFIX}/lib"
PLIST_SUB= PORTNAME="${PORTNAME}" \
LIBNUMBER="${LIBNUMBER}" \
LIBVERSION="${LIBVERSION}" \
EXTRALIBFILES_MAKE_FILES="${EXTRALIBFILES_MAKE_FILES}" \
INCLUDEDIR="${INCLUDEDIR}"
-
-# Proper X11R6 Prefix
-# Change it, if you need it
-X11PREFIX?= ${X11BASE}
+INSTALLS_SHLIB= yes
# Make environment
-PORTINCLUDES= -I${LOCALBASE}/include/jx
+PORTINCLUDES= -I${X11BASE}/include/jx -I${X11BASE}/include/jcore
# Installs dir with proper permissions
INSTALL_DATA_DIR= ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755
@@ -52,7 +48,7 @@ LIBFILES= ${PORTNAME}-${LIBVERSION}.a ${PORTNAME}-${LIBVERSION}.so
# header files
INCLUDEDIR= jtree
# documentation
-DOCDIR_PREFIX= ${PREFIX}/share/doc/JX
+DOCDIR_PREFIX= ${PREFIX}/share/doc/jx
DOCDIRS= ${PORTNAME}
DOCDIRFILES= LICENSE
# additional configuration and header files
@@ -64,7 +60,7 @@ EXTRALIBFILES_MAKE_FILES= jtree_constants
JXPORT= ${PORTSDIR}/x11-toolkits/jx
JXPORT_WRKSRC= ${JXPORT}/work/JX-1.5.3
# main jx distribution files needed for building
-COPY_JXDIRS= include lib libjcore
+COPY_JXDIRS= include
COPY_JXFILES= Makefile
.include <bsd.port.pre.mk>
@@ -91,9 +87,14 @@ post-extract:
@${CP} -p ${JXPORT_WRKSRC}/${i} ${WRKSRC}
.endfor
+post-patch:
+ @${ECHO} "SEARCHDIRS += ${PORTINCLUDES}" >> \
+ ${WRKSRC}/${EXTRALIBFILES_MAKE_WRKSRC}/jx_constants
+
post-build:
@cd ${WRKSRC}/${PORTNAME}; ${SETENV} ${MAKE_ENV} makemake; \
- ${SETENV} ${MAKE_ENV} ${GMAKE}
+ ${SETENV} ${MAKE_ENV} ${GMAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS}
do-install:
.if !defined(NOPORTDOCS)
diff --git a/x11-toolkits/libjtree/files/patch-aa b/x11-toolkits/libjtree/files/patch-aa
index 2ea5a415eb43..18be5d2d2db3 100644
--- a/x11-toolkits/libjtree/files/patch-aa
+++ b/x11-toolkits/libjtree/files/patch-aa
@@ -1,9 +1,11 @@
---- Makefile.orig Tue May 30 13:04:38 2000
-+++ Makefile Tue May 30 13:09:41 2000
-@@ -264,11 +264,6 @@
+--- Makefile.orig Sat Sep 11 17:44:38 1999
++++ Makefile Wed Jun 14 01:07:15 2000
+@@ -262,25 +262,11 @@
+ freebsd2.x: prep
+ @ln -s sys/FreeBSD-2.x_g++ \
include/make/jx_config
- @ln -s ../../include/missing_proto/jMissingProto_empty.h \
- include/jcore/jMissingProto.h
+- @ln -s ../../include/missing_proto/jMissingProto_empty.h \
+- include/jcore/jMissingProto.h
- @ln -s config-freebsd.h \
- ACE/ACE_wrappers/ace/config.h
- @ln -s platform_freebsd.GNU \
@@ -12,10 +14,10 @@
.PHONY : freebsd3.x
freebsd3.x: prep
-@@ -276,11 +271,6 @@
+ @ln -s sys/FreeBSD-3.x_g++ \
include/make/jx_config
- @ln -s ../../include/missing_proto/jMissingProto_empty.h \
- include/jcore/jMissingProto.h
+- @ln -s ../../include/missing_proto/jMissingProto_empty.h \
+- include/jcore/jMissingProto.h
- @ln -s config-freebsd-pthread.h \
- ACE/ACE_wrappers/ace/config.h
- @ln -s platform_freebsd_pthread.GNU \
diff --git a/x11-toolkits/libjtree/pkg-plist b/x11-toolkits/libjtree/pkg-plist
index 2e3c3e444b8b..ea0b0c7bacd4 100644
--- a/x11-toolkits/libjtree/pkg-plist
+++ b/x11-toolkits/libjtree/pkg-plist
@@ -13,6 +13,6 @@ lib/jx/make/%%EXTRALIBFILES_MAKE_FILES%%
lib/%%PORTNAME%%-%%LIBVERSION%%.a
lib/%%PORTNAME%%-%%LIBVERSION%%.so
lib/%%PORTNAME%%-%%LIBVERSION%%.so.%%LIBNUMBER%%
-%%PORTDOCS:%%share/doc/JX/LICENSE_%%PORTNAME%%
-%%PORTDOCS:%%@unexec rmdir %D/share/doc/JX 2>/dev/null || true
+%%PORTDOCS:%%share/doc/jx/LICENSE_%%PORTNAME%%
+%%PORTDOCS:%%@unexec rmdir %D/share/doc/jx 2>/dev/null || true
@dirrm include/%%INCLUDEDIR%%