aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/linux-c6-openmotif
diff options
context:
space:
mode:
authorxmj <xmj@FreeBSD.org>2014-09-22 18:40:00 +0800
committerxmj <xmj@FreeBSD.org>2014-09-22 18:40:00 +0800
commitd39787ca07e42b7a91488f45cc6c58333ae10780 (patch)
treef0614b64c20d137667eadfbdc5663150937dc6c3 /x11-toolkits/linux-c6-openmotif
parent143e62b0f3ebf9f9c709e4c068013418325fc64c (diff)
downloadfreebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.tar.gz
freebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.tar.zst
freebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.zip
Update CentOS base to 6.5, add userland ports
The Fedora 10 infrastructure ports have been in use since June 2009 and, while having served a great deed, have become unsupported upstream and hence affected by unfixed security vulnerabilities. In addition to that, many recent Linux binaries need newer libc / stdlibc++ versions. This commit adds the linux-c6- userland as drop-in replacement for the -f10 infrastructure, as well as upgrading the linux_base-c6 port to CentOS 6.5. If you want to switch to linux-c6 ports, please define at /etc/make.conf: OVERRIDE_LINUX_BASE_PORT=c6 OVERRIDE_LINUX_NONBASE_PORTS=c6 Additionally, please add the following line to /etc/sysctl.conf: compat.linux.osrelease=2.6.18 Upgrading procedures are shown in /usr/ports/UPDATING. This work has been inspired by Artyom Mirgorodskiy's post to emulation@ in November 2013, using and extending mav@'s work. It has been tested extensively and most reported issues were already fixed. Please report any additional bug or "features" to the emulation mailing list. Many thanks to: mav@, rene@, allanjude@, netchild@, antoine@, everyone who's filed Issues and Pull requests on GitHub, PR: 186820 Differential Revision: https://reviews.freebsd.org/D793 Reviewed by: allanjude, antoine, bapt, rene Approved by: portmgr (antoine, bapt) Approved by: koobs (mentor) Sponsored by: Perceivon Hosting Inc.
Diffstat (limited to 'x11-toolkits/linux-c6-openmotif')
-rw-r--r--x11-toolkits/linux-c6-openmotif/Makefile25
-rw-r--r--x11-toolkits/linux-c6-openmotif/distinfo.i6864
-rw-r--r--x11-toolkits/linux-c6-openmotif/pkg-descr1
-rw-r--r--x11-toolkits/linux-c6-openmotif/pkg-plist6
4 files changed, 36 insertions, 0 deletions
diff --git a/x11-toolkits/linux-c6-openmotif/Makefile b/x11-toolkits/linux-c6-openmotif/Makefile
new file mode 100644
index 000000000000..cbae8ceee0f9
--- /dev/null
+++ b/x11-toolkits/linux-c6-openmotif/Makefile
@@ -0,0 +1,25 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= openmotif
+PORTVERSION= 2.3.3
+CATEGORIES= x11-toolkits linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Motif toolkit libraries (Linux CentOS ${LINUX_DIST_VER})
+
+CONFLICTS= linux-openmotif-[0-9]* linux-f8-openmotif-[0-9]*
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= c6
+RPMVERSION= 6.1.el6_4
+USE_LINUX_RPM= yes
+USE_LINUX_APPS= xorglibs
+USE_LDCONFIG= yes
+DESCR= ${.CURDIR}/../open-motif/pkg-descr
+
+post-extract:
+ @${RM} -r ${WRKSRC}/etc ${WRKSRC}/usr/bin ${WRKSRC}/usr/include \
+ ${WRKSRC}/usr/share
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/linux-c6-openmotif/distinfo.i686 b/x11-toolkits/linux-c6-openmotif/distinfo.i686
new file mode 100644
index 000000000000..c4685612f74e
--- /dev/null
+++ b/x11-toolkits/linux-c6-openmotif/distinfo.i686
@@ -0,0 +1,4 @@
+SHA256 (rpm/i686/centos/6.5/openmotif-2.3.3-6.1.el6_4.i686.rpm) = 8c0f4bb22a9dc324c512c8e3f9e32addb83e4a63a033e88c120fd1ff78e6ff32
+SIZE (rpm/i686/centos/6.5/openmotif-2.3.3-6.1.el6_4.i686.rpm) = 1416552
+SHA256 (rpm/i686/centos/6.5/openmotif-2.3.3-6.1.el6_4.src.rpm) = 4137bc1dd0ce8a0c6c3365b02e27c6531d76f8e21b38fa60523943d15d39c749
+SIZE (rpm/i686/centos/6.5/openmotif-2.3.3-6.1.el6_4.src.rpm) = 6056057
diff --git a/x11-toolkits/linux-c6-openmotif/pkg-descr b/x11-toolkits/linux-c6-openmotif/pkg-descr
new file mode 100644
index 000000000000..e669752e68f9
--- /dev/null
+++ b/x11-toolkits/linux-c6-openmotif/pkg-descr
@@ -0,0 +1 @@
+Open Motif runtime libraries for the Linux emulation environment.
diff --git a/x11-toolkits/linux-c6-openmotif/pkg-plist b/x11-toolkits/linux-c6-openmotif/pkg-plist
new file mode 100644
index 000000000000..a52643cacb02
--- /dev/null
+++ b/x11-toolkits/linux-c6-openmotif/pkg-plist
@@ -0,0 +1,6 @@
+usr/lib/libMrm.so.4
+usr/lib/libMrm.so.4.0.3
+usr/lib/libUil.so.4
+usr/lib/libUil.so.4.0.3
+usr/lib/libXm.so.4
+usr/lib/libXm.so.4.0.3