aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/p5-Gtk3
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-04-18 09:12:27 +0800
committerpi <pi@FreeBSD.org>2016-04-18 09:12:27 +0800
commit97324d5957e3c84eb91593ac46b0a435d2011847 (patch)
tree47b2ee88c73b018504ca7f28c9b14057e65a37a2 /x11-toolkits/p5-Gtk3
parent9aabf959d40c7937254a809f42b3f8ffcb83d202 (diff)
downloadfreebsd-ports-gnome-97324d5957e3c84eb91593ac46b0a435d2011847.tar.gz
freebsd-ports-gnome-97324d5957e3c84eb91593ac46b0a435d2011847.tar.zst
freebsd-ports-gnome-97324d5957e3c84eb91593ac46b0a435d2011847.zip
New port: x11-toolkits/p5-Gtk3
Perl bindings to the 3.x series of the gtk+ toolkit. This module allows you to write graphical user interfaces in a Perlish and object-oriented way, freeing you from the casting and memory management in C, yet remaining very close in spirit to original API. Find out more about gtk+ at http://www.gtk.org. The gtk+ reference manual is also a handy companion when writing Gtk3 programs in Perl: http://developer.gnome.org/gtk3/stable/. The Perl bindings follow the C API very closely, and the C reference documentation should be considered the canonical source. WWW: https://metacpan.org/pod/Gtk3 PR: 208372 Submitted by: hiroto.kagotani@gmail.com
Diffstat (limited to 'x11-toolkits/p5-Gtk3')
-rw-r--r--x11-toolkits/p5-Gtk3/Makefile21
-rw-r--r--x11-toolkits/p5-Gtk3/distinfo2
-rw-r--r--x11-toolkits/p5-Gtk3/pkg-descr12
-rw-r--r--x11-toolkits/p5-Gtk3/pkg-plist2
4 files changed, 37 insertions, 0 deletions
diff --git a/x11-toolkits/p5-Gtk3/Makefile b/x11-toolkits/p5-Gtk3/Makefile
new file mode 100644
index 000000000000..7cd6b99dd526
--- /dev/null
+++ b/x11-toolkits/p5-Gtk3/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= Gtk3
+PORTVERSION= 0.026
+CATEGORIES= x11-toolkits lang perl5
+MASTER_SITES= CPAN SF/${PORTNAME:tl}-perl/${PORTNAME}/${PORTVERSION}
+MASTER_SITE_SUBDIR= CPAN:XAOC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hiroto.kagotani@gmail.com
+COMMENT= Perl module for Gtk+ 3.x graphical user interface library
+
+LICENSE= LGPL21
+
+RUN_DEPENDS= p5-Glib-Object-Introspection>=0.002:devel/p5-Glib-Object-Introspection
+
+USES= perl5
+USE_PERL5= configure
+USE_GNOME= gtk30
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/p5-Gtk3/distinfo b/x11-toolkits/p5-Gtk3/distinfo
new file mode 100644
index 000000000000..577c869c1077
--- /dev/null
+++ b/x11-toolkits/p5-Gtk3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Gtk3-0.026.tar.gz) = 083a857c45b9178603176f56402472633851c7e42f6a8c47fd7f6a18e9181319
+SIZE (Gtk3-0.026.tar.gz) = 53408
diff --git a/x11-toolkits/p5-Gtk3/pkg-descr b/x11-toolkits/p5-Gtk3/pkg-descr
new file mode 100644
index 000000000000..8739ce998e2d
--- /dev/null
+++ b/x11-toolkits/p5-Gtk3/pkg-descr
@@ -0,0 +1,12 @@
+Perl bindings to the 3.x series of the gtk+ toolkit. This module
+allows you to write graphical user interfaces in a Perlish and
+object-oriented way, freeing you from the casting and memory
+management in C, yet remaining very close in spirit to original
+API. Find out more about gtk+ at http://www.gtk.org.
+
+The gtk+ reference manual is also a handy companion when writing
+Gtk3 programs in Perl: http://developer.gnome.org/gtk3/stable/. The
+Perl bindings follow the C API very closely, and the C reference
+documentation should be considered the canonical source.
+
+WWW: https://metacpan.org/pod/Gtk3
diff --git a/x11-toolkits/p5-Gtk3/pkg-plist b/x11-toolkits/p5-Gtk3/pkg-plist
new file mode 100644
index 000000000000..926b4046c1e9
--- /dev/null
+++ b/x11-toolkits/p5-Gtk3/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Gtk3.pm
+%%PERL5_MAN3%%/Gtk3.3.gz