aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/p5-qt/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-03-17 11:25:28 +0800
committerijliao <ijliao@FreeBSD.org>2004-03-17 11:25:28 +0800
commit45eb914801bd891c45d7db8c3311573490d007b7 (patch)
tree5b3f97f4cdcfa76cf482365c39c430ff9d9fcd8b /x11-toolkits/p5-qt/Makefile
parentb594e540c100cf52a4af6d8b5b18759ee90b5742 (diff)
downloadfreebsd-ports-gnome-45eb914801bd891c45d7db8c3311573490d007b7.tar.gz
freebsd-ports-gnome-45eb914801bd891c45d7db8c3311573490d007b7.tar.zst
freebsd-ports-gnome-45eb914801bd891c45d7db8c3311573490d007b7.zip
add p5-qt 3.008
A set of Perl bindings for the Qt toolkit
Diffstat (limited to 'x11-toolkits/p5-qt/Makefile')
-rw-r--r--x11-toolkits/p5-qt/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/x11-toolkits/p5-qt/Makefile b/x11-toolkits/p5-qt/Makefile
new file mode 100644
index 000000000000..5f2ae3164375
--- /dev/null
+++ b/x11-toolkits/p5-qt/Makefile
@@ -0,0 +1,56 @@
+# ex:ts=8
+# Ports collection makefile for: p5-qt
+# Date created: Mar 17, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= qt
+PORTVERSION= 3.008
+CATEGORIES= x11-toolkits perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN:S/$/:cpan/} \
+ ${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
+MASTER_SITE_SUBDIR= Qt/:cpan \
+ perlqt/:sf
+PKGNAMEPREFIX= p5-
+DISTNAME= PerlQt-${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:cpan \
+ ${DISTNAME}${EXTRACT_SUFX}:sf
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A set of Perl bindings for the Qt toolkit
+
+USE_GL= yes
+USE_QT_VER= 3
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+PLIST_FILES= bin/pqtapi bin/pqtsh bin/puic include/smoke.h \
+ lib/libsmokeqt.so lib/libsmokeqt.so.3
+
+MAN1= puic.1
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Qt.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "This port needs Perl 5.6.0 or greater, please upgrade your Perl!"
+.endif
+
+post-install:
+ @${FIND} ${PREFIX}/share/PerlQt-3 -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/share/PerlQt-3 -type d | ${SORT} -r | \
+ ${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+ @${FIND} ${SITE_PERL}/${PERL_ARCH}/Qt* -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${SITE_PERL}/${PERL_ARCH}/Qt* -type d | ${SORT} -r | \
+ ${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+ @${FIND} ${SITE_PERL}/${PERL_ARCH}/auto/Qt -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${SITE_PERL}/${PERL_ARCH}/auto/Qt -type d | ${SORT} -r | \
+ ${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+
+.include <bsd.port.post.mk>