aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/pango
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-08-03 08:37:44 +0800
committermarcus <marcus@FreeBSD.org>2004-08-03 08:37:44 +0800
commitba78f9983e50f9d352d117098f6b6d7c5d9199ff (patch)
tree0a0e9cc79144a274b8e7c106f36690741c4c6032 /x11-toolkits/pango
parent2b3d400d379444ae3c33f382e6cec3c071f68d45 (diff)
downloadfreebsd-ports-gnome-ba78f9983e50f9d352d117098f6b6d7c5d9199ff.tar.gz
freebsd-ports-gnome-ba78f9983e50f9d352d117098f6b6d7c5d9199ff.tar.zst
freebsd-ports-gnome-ba78f9983e50f9d352d117098f6b6d7c5d9199ff.zip
Update to 1.4.1.
Diffstat (limited to 'x11-toolkits/pango')
-rw-r--r--x11-toolkits/pango/Makefile5
-rw-r--r--x11-toolkits/pango/distinfo4
-rw-r--r--x11-toolkits/pango/files/patch-configure21
-rw-r--r--x11-toolkits/pango/files/patch-hangul85
-rw-r--r--x11-toolkits/pango/files/patch-ltmain.sh51
5 files changed, 19 insertions, 147 deletions
diff --git a/x11-toolkits/pango/Makefile b/x11-toolkits/pango/Makefile
index ad7303313522..063c58f48073 100644
--- a/x11-toolkits/pango/Makefile
+++ b/x11-toolkits/pango/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pango
-PORTVERSION= 1.4.0
-PORTREVISION= 1
+PORTVERSION= 1.4.1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/${PORTNAME}/1.4,} \
ftp://ftp.gtk.org/pub/gtk/v2.3/
@@ -27,7 +26,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=15
USE_GNOME= gnomehack glib20
CONFIGURE_ARGS= --with-qt=no \
--with-html-dir=${PREFIX}/share/doc \
diff --git a/x11-toolkits/pango/distinfo b/x11-toolkits/pango/distinfo
index 91ee4b4a4267..0088581f7c15 100644
--- a/x11-toolkits/pango/distinfo
+++ b/x11-toolkits/pango/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/pango-1.4.0.tar.bz2) = 9b5d9a5dcce5b3899d401f9c2cd6873f
-SIZE (gnome2/pango-1.4.0.tar.bz2) = 921472
+MD5 (gnome2/pango-1.4.1.tar.bz2) = 39868e0da250fd4c00b2970e4eb84389
+SIZE (gnome2/pango-1.4.1.tar.bz2) = 914710
diff --git a/x11-toolkits/pango/files/patch-configure b/x11-toolkits/pango/files/patch-configure
index 611bcc5764e5..071893b4cbda 100644
--- a/x11-toolkits/pango/files/patch-configure
+++ b/x11-toolkits/pango/files/patch-configure
@@ -1,7 +1,16 @@
---- configure.orig Thu Jun 13 17:04:03 2002
-+++ configure Wed Jul 3 12:46:50 2002
-@@ -12084,10 +12085,10 @@
- s,@INSTALL_DATA@,$INSTALL_DATA,;t t
+--- configure.orig Mon Aug 2 20:29:37 2004
++++ configure Mon Aug 2 20:32:46 2004
+@@ -1958,7 +1958,7 @@
+
+
+
+-LT_VERSION_INFO="400:1:400"
++LT_VERSION_INFO="399:1:399"
+ LT_CURRENT_MINUS_AGE=0
+
+
+@@ -23945,10 +23945,10 @@
+ s,@CYGPATH_W@,$CYGPATH_W,;t t
s,@PACKAGE@,$PACKAGE,;t t
s,@VERSION@,$VERSION,;t t
-s,@ACLOCAL@,$ACLOCAL,;t t
@@ -13,5 +22,5 @@
+s,@AUTOMAKE@,/usr/bin/true,;t t
+s,@AUTOHEADER@,/usr/bin/true,;t t
s,@MAKEINFO@,$MAKEINFO,;t t
- s,@SET_MAKE@,$SET_MAKE,;t t
- s,@CC@,$CC,;t t
+ s,@AMTAR@,$AMTAR,;t t
+ s,@install_sh@,$install_sh,;t t
diff --git a/x11-toolkits/pango/files/patch-hangul b/x11-toolkits/pango/files/patch-hangul
deleted file mode 100644
index 36e55c8ad068..000000000000
--- a/x11-toolkits/pango/files/patch-hangul
+++ /dev/null
@@ -1,85 +0,0 @@
-===================================================================
-RCS file: /cvs/gnome/pango/modules/hangul/hangul-fc.c,v
-retrieving revision 1.13
-retrieving revision 1.14
-diff -u -r1.13 -r1.14
---- modules/hangul/hangul-fc.c 2003/09/23 23:11:51 1.13
-+++ modules/hangul/hangul-fc.c 2004/04/17 16:17:57 1.14
-@@ -1,7 +1,7 @@
- /* Pango
- * hangul-fc.c: Hangul shaper for FreeType based backends
- *
-- * Copyright (C) 2002 Changwoo Ryu
-+ * Copyright (C) 2002-2004 Changwoo Ryu
- * Author: Changwoo Ryu <cwryu@debian.org>
- *
- * This library is free software; you can redistribute it and/or
-@@ -275,6 +275,21 @@
- render_tone(font, tone, glyphs, n_glyphs, cluster_offset);
- }
-
-+static void
-+render_basic (PangoFont *font, gunichar wc,
-+ PangoGlyphString *glyphs, int *n_glyphs, int cluster_offset)
-+{
-+ int index;
-+ index = find_char (font, wc);
-+ pango_glyph_string_set_size (glyphs, *n_glyphs + 1);
-+ if (index)
-+ set_glyph (font, glyphs, *n_glyphs, cluster_offset, index);
-+ else
-+ set_glyph (font, glyphs, *n_glyphs, cluster_offset,
-+ get_unknown_glyph (font, wc));
-+ (*n_glyphs)++;
-+}
-+
- static void
- hangul_engine_shape (PangoEngineShape *engine,
- PangoFont *font,
-@@ -307,13 +322,14 @@
- if (n_jamos)
- {
- gunichar prev = jamos[n_jamos - 1];
-- if ((!IS_L (prev) && IS_S (wc)) ||
-+ if ((!IS_JAMO (wc) && !IS_S (wc) && !IS_M (wc)) ||
-+ (!IS_L (prev) && IS_S (wc)) ||
- (IS_T (prev) && IS_L (wc)) ||
- (IS_V (prev) && IS_L (wc)) ||
- (IS_T (prev) && IS_V (wc)) ||
-- IS_M(prev))
-+ IS_M (prev))
- {
-- /* Draw a syllable. */
-+ /* Draw a syllable with these jamos. */
- render_syllable (font, jamos, n_jamos, glyphs,
- &n_glyphs, start - text);
- n_jamos = 0;
-@@ -333,7 +349,12 @@
- jamos = g_renew (gunichar, jamos, max_jamos);
- }
-
-- if (IS_S (wc))
-+ if (!IS_JAMO (wc) && !IS_S (wc) && !IS_M (wc))
-+ {
-+ render_basic (font, wc, glyphs, &n_glyphs, start - text);
-+ start = g_utf8_next_char (p);
-+ }
-+ else if (IS_S (wc))
- {
- jamos[n_jamos++] = L_FROM_S (wc);
- jamos[n_jamos++] = V_FROM_S (wc);
-===================================================================
-RCS file: /cvs/gnome/pango/modules/hangul/hangul-defs.h,v
-retrieving revision 1.4
-retrieving revision 1.5
-diff -u -r1.4 -r1.5
---- modules/hangul/hangul-defs.h 2002/11/03 19:56:24 1.4
-+++ modules/hangul/hangul-defs.h 2004/04/17 16:17:57 1.5
-@@ -48,6 +48,7 @@
- #define HTONE1 0x302E
- #define HTONE2 0x302F
-
-+#define IS_JAMO(wc) (wc >= LBASE && wc <= TEND)
- #define IS_L(wc) (wc >= LBASE && wc <= LEND)
- #define IS_V(wc) (wc >= VFILL && wc <= VEND)
- #define IS_T(wc) (wc > TBASE && wc <= TEND)
diff --git a/x11-toolkits/pango/files/patch-ltmain.sh b/x11-toolkits/pango/files/patch-ltmain.sh
deleted file mode 100644
index 1d56986675d0..000000000000
--- a/x11-toolkits/pango/files/patch-ltmain.sh
+++ /dev/null
@@ -1,51 +0,0 @@
---- ltmain.sh.orig Thu Apr 24 19:44:23 2003
-+++ ltmain.sh Sat May 31 01:34:34 2003
-@@ -1280,7 +1280,7 @@
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd* | *-*-freebsd4*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -1290,8 +1290,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -3000,6 +3008,9 @@
- # problems, so we reset it completely
- verstring=
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- verstring="0.0"
- ;;
-@@ -5428,10 +5439,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"