aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/pangomm
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-01-10 13:22:13 +0800
committermarcus <marcus@FreeBSD.org>2009-01-10 13:22:13 +0800
commit6d8ed8f7c7511223163de715a97ffc04bf6fada9 (patch)
tree40dc015efe383243b0880df377f73ee250da7de7 /x11-toolkits/pangomm
parentc7f342a8d7b82e85b9625c4403600fc20ce41da6 (diff)
downloadfreebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.tar.gz
freebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.tar.zst
freebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.zip
Presenting GNOME 2.24 for FreeBSD.
See http://library.gnome.org/misc/release-notes/2.24/ for the general release notes. On the FreeBSD front, this release introduces Fuse support in HAL, adds multi-CPU support to libgtop, WebKit updates, and fixes some long-standing seahorse and gnome-keyring bugs. The documentation updates to the website are forthcoming. This release features commits by adamw, ahze, kwm, mezz, and myself. It would not have been possible without are contributors and testers: Alexander Loginov Craig Butler [1] Dmitry Marakasov [6] Eric L. Chen Joseph S. Atkinson Kris Moore Lapo Luchini [7] Nikos Ntarmos Pawel Worach Romain Tartiere TAOKA Fumiyoshi [3] Yasuda Keisuke Zyl aZ [4] bf [2] [5] Florent Thoumie Peter Wemm pluknet PR: 125857 [1] 126993 [2] 130031 [3] 127399 [4] 127661 [5] 124302 [6] 129570 [7] 129936 123790
Diffstat (limited to 'x11-toolkits/pangomm')
-rw-r--r--x11-toolkits/pangomm/Makefile48
-rw-r--r--x11-toolkits/pangomm/distinfo3
-rw-r--r--x11-toolkits/pangomm/pkg-descr3
-rw-r--r--x11-toolkits/pangomm/pkg-plist67
4 files changed, 121 insertions, 0 deletions
diff --git a/x11-toolkits/pangomm/Makefile b/x11-toolkits/pangomm/Makefile
new file mode 100644
index 000000000000..d1ddb461a5e6
--- /dev/null
+++ b/x11-toolkits/pangomm/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: pangomm
+# Date created: 23 July 2008
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/x11-toolkits/pangomm/Makefile,v 1.7 2008/11/10 19:57:21 kwm Exp $
+#
+
+PORTNAME= pangomm
+PORTVERSION= 2.14.1
+PORTREVISION?= 0
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= C++ wrapper for Pango
+
+USE_BZIP2= yes
+
+.if !defined(REFERENCE_PORT)
+
+LIB_DEPENDS= glibmm-2.4.1:${PORTSDIR}/devel/glibmm \
+ cairomm-1.0.1:${PORTSDIR}/graphics/cairomm
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_GNOME= gnomehack pango
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-demos \
+ --disable-docs \
+ --disable-examples \
+ --enable-static=yes \
+ --with-sigc-prefix=${LOCALBASE}
+
+PLIST_SUB= VERSION="2.4" API_VERSION="1.4"
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s/tests//' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
+
+.endif
diff --git a/x11-toolkits/pangomm/distinfo b/x11-toolkits/pangomm/distinfo
new file mode 100644
index 000000000000..650cc75a9861
--- /dev/null
+++ b/x11-toolkits/pangomm/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnome2/pangomm-2.14.1.tar.bz2) = c67228ea93dd977394d2872b61754b53
+SHA256 (gnome2/pangomm-2.14.1.tar.bz2) = d7724d878242f7313086e23f774f5ae021f6ff8d0bd393d6c704ad89362c3557
+SIZE (gnome2/pangomm-2.14.1.tar.bz2) = 984848
diff --git a/x11-toolkits/pangomm/pkg-descr b/x11-toolkits/pangomm/pkg-descr
new file mode 100644
index 000000000000..1fec3f2b76be
--- /dev/null
+++ b/x11-toolkits/pangomm/pkg-descr
@@ -0,0 +1,3 @@
+C++ wrapper for Pango.
+
+WWW: http://gtkmm.sourceforge.net/
diff --git a/x11-toolkits/pangomm/pkg-plist b/x11-toolkits/pangomm/pkg-plist
new file mode 100644
index 000000000000..08c681f69138
--- /dev/null
+++ b/x11-toolkits/pangomm/pkg-plist
@@ -0,0 +1,67 @@
+include/pangomm-%%API_VERSION%%/pangomm.h
+include/pangomm-%%API_VERSION%%/pangomm/attributes.h
+include/pangomm-%%API_VERSION%%/pangomm/attriter.h
+include/pangomm-%%API_VERSION%%/pangomm/attrlist.h
+include/pangomm-%%API_VERSION%%/pangomm/cairofontmap.h
+include/pangomm-%%API_VERSION%%/pangomm/color.h
+include/pangomm-%%API_VERSION%%/pangomm/context.h
+include/pangomm-%%API_VERSION%%/pangomm/coverage.h
+include/pangomm-%%API_VERSION%%/pangomm/font.h
+include/pangomm-%%API_VERSION%%/pangomm/fontdescription.h
+include/pangomm-%%API_VERSION%%/pangomm/fontface.h
+include/pangomm-%%API_VERSION%%/pangomm/fontfamily.h
+include/pangomm-%%API_VERSION%%/pangomm/fontmap.h
+include/pangomm-%%API_VERSION%%/pangomm/fontmetrics.h
+include/pangomm-%%API_VERSION%%/pangomm/fontset.h
+include/pangomm-%%API_VERSION%%/pangomm/glyph.h
+include/pangomm-%%API_VERSION%%/pangomm/glyphstring.h
+include/pangomm-%%API_VERSION%%/pangomm/init.h
+include/pangomm-%%API_VERSION%%/pangomm/item.h
+include/pangomm-%%API_VERSION%%/pangomm/language.h
+include/pangomm-%%API_VERSION%%/pangomm/layout.h
+include/pangomm-%%API_VERSION%%/pangomm/layoutiter.h
+include/pangomm-%%API_VERSION%%/pangomm/layoutline.h
+include/pangomm-%%API_VERSION%%/pangomm/layoutrun.h
+include/pangomm-%%API_VERSION%%/pangomm/private/attributes_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/attriter_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/attrlist_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/cairofontmap_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/color_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/context_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/coverage_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/font_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/fontdescription_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/fontface_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/fontfamily_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/fontmap_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/fontmetrics_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/fontset_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/glyph_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/glyphstring_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/item_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/language_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/layout_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/layoutiter_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/layoutline_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/layoutrun_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/rectangle_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/renderer_p.h
+include/pangomm-%%API_VERSION%%/pangomm/private/tabarray_p.h
+include/pangomm-%%API_VERSION%%/pangomm/rectangle.h
+include/pangomm-%%API_VERSION%%/pangomm/renderer.h
+include/pangomm-%%API_VERSION%%/pangomm/tabarray.h
+include/pangomm-%%API_VERSION%%/pangomm/types.h
+include/pangomm-%%API_VERSION%%/pangomm/wrap_init.h
+lib/libpangomm-%%API_VERSION%%.a
+lib/libpangomm-%%API_VERSION%%.la
+lib/libpangomm-%%API_VERSION%%.so
+lib/libpangomm-%%API_VERSION%%.so.1
+lib/pangomm-%%API_VERSION%%/proc/m4/convert.m4
+lib/pangomm-%%API_VERSION%%/proc/m4/convert_pango.m4
+libdata/pkgconfig/pangomm-%%API_VERSION%%.pc
+@dirrm lib/pangomm-%%API_VERSION%%/proc/m4
+@dirrm lib/pangomm-%%API_VERSION%%/proc
+@dirrm lib/pangomm-%%API_VERSION%%
+@dirrm include/pangomm-%%API_VERSION%%/pangomm/private
+@dirrm include/pangomm-%%API_VERSION%%/pangomm
+@dirrm include/pangomm-%%API_VERSION%%