aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/php-gtk2
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-03-02 23:36:09 +0800
committerrafan <rafan@FreeBSD.org>2007-03-02 23:36:09 +0800
commita81ff1f1fac0a00025faf00d1bee31ef435d5f36 (patch)
tree5cf44c8f97c6ad8f787102dee017499c48dceaf7 /x11-toolkits/php-gtk2
parentaefd1b6948e3084094be6c3c3022532ef612fdbb (diff)
downloadfreebsd-ports-gnome-a81ff1f1fac0a00025faf00d1bee31ef435d5f36.tar.gz
freebsd-ports-gnome-a81ff1f1fac0a00025faf00d1bee31ef435d5f36.tar.zst
freebsd-ports-gnome-a81ff1f1fac0a00025faf00d1bee31ef435d5f36.zip
- Fix build with scintilla and gtkhtml which are moved to LOCALBASE
PR: ports/109738 Submitted by: Alexander Zhuravlev <zaa at zaa.pp.ru> (maintainer)
Diffstat (limited to 'x11-toolkits/php-gtk2')
-rw-r--r--x11-toolkits/php-gtk2/Makefile6
-rw-r--r--x11-toolkits/php-gtk2/files/patch-ext_scintilla-config.m42
2 files changed, 4 insertions, 4 deletions
diff --git a/x11-toolkits/php-gtk2/Makefile b/x11-toolkits/php-gtk2/Makefile
index 9bad3741ccd7..9c58a59a5679 100644
--- a/x11-toolkits/php-gtk2/Makefile
+++ b/x11-toolkits/php-gtk2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= php-gtk
PORTVERSION= 1.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits
MASTER_SITES= http://gtk.php.net/distributions/ \
http://document-root.de/mirror/php-gtk/
@@ -50,7 +50,7 @@ CONFIGURE_ARGS+= --disable-libglade
.endif
.if !defined(WITHOUT_SCINTILLA)
-BUILD_DEPENDS+= ${X11BASE}/include/scintilla/gtkscintilla.h:${PORTSDIR}/x11-toolkits/gtkscintilla
+BUILD_DEPENDS+= ${LOCALBASE}/include/scintilla/gtkscintilla.h:${PORTSDIR}/x11-toolkits/gtkscintilla
LIB_DEPENDS+= gtkscintilla.0:${PORTSDIR}/x11-toolkits/gtkscintilla
ENVSCE+= -DHAVE_SCINTILLA=1 # -DPHP_GTK_COMPILE_DL_SCINTILLA=1
CONFIGURE_ARGS+= --enable-scintilla
@@ -68,7 +68,7 @@ PLIST_SUB+= GDKPIXBUF="@comment "
.if !defined(WITHOUT_GTKHTML)
USE_GNOME+= gtkhtml
CONFIGURE_ARGS+= --enable-gtkhtml
-ENVSCE+= -DHAVE_HTML=1 -I${X11BASE}/include/gal-1.0 # -DPHP_GTK_COMPILE_DL_GTKHTML=1 -DGTKHTML_HAVE_GCONF=1 -I${X11BASE}/include/gal-1.0
+ENVSCE+= -DHAVE_HTML=1 -I${LOCALBASE}/include/gal-1.0 # -DPHP_GTK_COMPILE_DL_GTKHTML=1 -DGTKHTML_HAVE_GCONF=1 -I${X11BASE}/include/gal-1.0
PLIST_SUB+= GTKHTML=""
.else
PLIST_SUB+= GTKHTML="@comment "
diff --git a/x11-toolkits/php-gtk2/files/patch-ext_scintilla-config.m4 b/x11-toolkits/php-gtk2/files/patch-ext_scintilla-config.m4
index 48fcbb8e4951..4d2f78def30c 100644
--- a/x11-toolkits/php-gtk2/files/patch-ext_scintilla-config.m4
+++ b/x11-toolkits/php-gtk2/files/patch-ext_scintilla-config.m4
@@ -6,7 +6,7 @@
if test "$PHP_GTK_SCINTILLA" != "no"; then
- for x in /usr /usr/local; do
- if test -f $x/include/gtkscintilla.h; then
-+ for x in /usr/include /usr/local/include /usr/X11R6/include/scintilla; do
++ for x in /usr/include /usr/local/include /usr/local/include/scintilla /usr/X11R6/include/scintilla; do
+ if test -f $x/gtkscintilla.h; then
SCINTILLA_DIR=$x
- SCINTILLA_INCDIR=$x/include