aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/py-fox
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /x11-toolkits/py-fox
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'x11-toolkits/py-fox')
-rw-r--r--x11-toolkits/py-fox/Makefile4
-rw-r--r--x11-toolkits/py-fox/files/patch-setup4
2 files changed, 4 insertions, 4 deletions
diff --git a/x11-toolkits/py-fox/Makefile b/x11-toolkits/py-fox/Makefile
index 9469499ca404..ce7532f11318 100644
--- a/x11-toolkits/py-fox/Makefile
+++ b/x11-toolkits/py-fox/Makefile
@@ -9,7 +9,7 @@ PORTNAME= fox
PORTVERSION= 1.0.5
PORTREVISION= 2
CATEGORIES= x11-toolkits
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= fxpy
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= FXPy-${PORTVERSION}
@@ -30,7 +30,7 @@ DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
post-patch:
- ${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/setup.py
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/setup.py
do-install:
@(cd ${INSTALL_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} install ${PYDISTUTILS_INSTALLARGS})
diff --git a/x11-toolkits/py-fox/files/patch-setup b/x11-toolkits/py-fox/files/patch-setup
index fb2d40fe3576..0ebeea955eca 100644
--- a/x11-toolkits/py-fox/files/patch-setup
+++ b/x11-toolkits/py-fox/files/patch-setup
@@ -7,8 +7,8 @@
+ XLIBINC = []
else:
- XLIBDIR = ['/usr/X11R6/lib']
-+ XLIBDIR = ['%%X11BASE%%/lib']
-+ XLIBINC = ['%%X11BASE%%/include']
++ XLIBDIR = ['%%LOCALBASE%%/lib']
++ XLIBINC = ['%%LOCALBASE%%/include']
# Other libraries
OLIBDIRS = ['c:\cygwin\usr\local\lib']