aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/py-gnome-desktop
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-04-30 08:47:21 +0800
committermarcus <marcus@FreeBSD.org>2006-04-30 08:47:21 +0800
commit7315b1c16ae631c60d787b73475db448b86b7e0b (patch)
tree0a7edc722d829b9a98914843c0c09d978324e75f /x11-toolkits/py-gnome-desktop
parente43bffa408ddb90519bcbf271791632a33f25217 (diff)
downloadfreebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.tar.gz
freebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.tar.zst
freebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.zip
Presenting GNOME 2.14.1 for FreeBSD! Checkout
http://www.gnome.org/start/2.14/ for the official release notes, and a list of all the gooides in this new release. In particular, GNOME 2.14 focused on performance, and they did not miss the mark. There's some new eye candy, but most of the big things are waiting until GNOME 2.16. On the FreeBSD side, we tried to clean up all the crashers we could. In particular, we really improved GNOME's 64-bit support. The good news is that this release does not bring any big shared library version bumps, so you can almost do a simple portupgrade to get to 2.14. There are a few minor gotchas that will be documented in UPDATING shortly. The FreeBSD GNOME Team would like th thank the following users for their patches, feedback, and sometimes incessant complaing about crashes (you know who you are). Yasuda Keisuke <kysd@po.harenet.ne.jp> Pascal Hofstee <caelian@gmail.com> rmgls@wanadoo.fr tmclaugh Yuri Pankov <yuri.pankov@gmail.com> sajd on #freebsd-gnome ade ankon on #FreeBSD-Gnome mux Pascal Hofstee <caelian@gmail.com> QuiRK on #freebsd-gnome Vladimir Timofeev <vovkasm@gmail.com>
Diffstat (limited to 'x11-toolkits/py-gnome-desktop')
-rw-r--r--x11-toolkits/py-gnome-desktop/Makefile56
-rw-r--r--x11-toolkits/py-gnome-desktop/distinfo3
-rw-r--r--x11-toolkits/py-gnome-desktop/files/patch-gtop_gtop.c20
-rw-r--r--x11-toolkits/py-gnome-desktop/pkg-descr2
-rw-r--r--x11-toolkits/py-gnome-desktop/pkg-plist108
5 files changed, 189 insertions, 0 deletions
diff --git a/x11-toolkits/py-gnome-desktop/Makefile b/x11-toolkits/py-gnome-desktop/Makefile
new file mode 100644
index 000000000000..9aeb67dc21a7
--- /dev/null
+++ b/x11-toolkits/py-gnome-desktop/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: py-gnome-desktop
+# Date created: 20 January 2006
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/x11-toolkits/py-gnome-desktop/Makefile,v 1.39 2006/03/12 23:43:07 marcus Exp $
+#
+
+PORTNAME= gnome
+PORTVERSION= 2.14.0
+CATEGORIES= x11-toolkits python gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/gnome-python-desktop/${PORTVERSION:C/..$//}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= -desktop
+DISTNAME= gnome-python-desktop-${PORTVERSION}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A set of Python bindings used by modules in the GNOME Desktop
+
+LIB_DEPENDS= gtop-2.0.7:${PORTSDIR}/devel/libgtop2 \
+ totem-plparser.2:${PORTSDIR}/multimedia/totem-gstreamer \
+ gnome-media-profiles.0:${PORTSDIR}/audio/gnomemedia2
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PYTHON= yes
+USE_GNOME= gnomehack libgnomeprintui gnomepanel \
+ gtksourceview libwnck nautiluscdburner pygnome2 metacity
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+EG_SRC_DIR= ${WRKSRC}/examples
+EG_DST_DIR= ${PREFIX}/share/examples/py-gnome
+.if !defined(NOPORTDOCS)
+DOCSDIR= ${PREFIX}/share/doc/py-gnome-desktop
+.else
+DOCSDIR= ${WRKSRC}/share/doc/py-gnome-desktop
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${FIND} ${WRKSRC}/docs -name Makefile.in | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|^HTML_DIR =.*|HTML_DIR = ${DOCSDIR}|g'
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${EG_DST_DIR}
+ ${TAR} -C ${EG_SRC_DIR} -cf - . | ${TAR} -C ${EG_DST_DIR} -xf -
+ ${CHOWN} -R ${BINOWN}:${BINGRP} ${EG_DST_DIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/py-gnome-desktop/distinfo b/x11-toolkits/py-gnome-desktop/distinfo
new file mode 100644
index 000000000000..85e7ee9263a1
--- /dev/null
+++ b/x11-toolkits/py-gnome-desktop/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnome2/gnome-python-desktop-2.14.0.tar.bz2) = d3f9c2d213b7d486ca7bd87dd106ca69
+SHA256 (gnome2/gnome-python-desktop-2.14.0.tar.bz2) = 1e617686fc7b84a4b2779cdfe3987a592f40bd24f3f5e252fd559ca41452dde1
+SIZE (gnome2/gnome-python-desktop-2.14.0.tar.bz2) = 403302
diff --git a/x11-toolkits/py-gnome-desktop/files/patch-gtop_gtop.c b/x11-toolkits/py-gnome-desktop/files/patch-gtop_gtop.c
new file mode 100644
index 000000000000..05db58a4c083
--- /dev/null
+++ b/x11-toolkits/py-gnome-desktop/files/patch-gtop_gtop.c
@@ -0,0 +1,20 @@
+--- gtop/gtop.c.orig Wed May 18 00:54:59 2005
++++ gtop/gtop.c Wed May 18 00:54:12 2005
+@@ -44,6 +44,7 @@
+
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <netinet/in.h>
+ #include <arpa/inet.h>
+
+
+@@ -1316,8 +1317,8 @@ build_siglist(void)
+
+ for(i = 0; i < len; ++i)
+ {
+- p = &glibtop_sys_siglist[i];
+ PyObject* d;
++ p = &glibtop_sys_siglist[i];
+
+ d = PyDict_New();
+ my_dict_add_and_decref(d, "number", PyI_L(p->number));
diff --git a/x11-toolkits/py-gnome-desktop/pkg-descr b/x11-toolkits/py-gnome-desktop/pkg-descr
new file mode 100644
index 000000000000..cbc8cc5d8dd1
--- /dev/null
+++ b/x11-toolkits/py-gnome-desktop/pkg-descr
@@ -0,0 +1,2 @@
+GnomePythonDesktop provides python interfacing modules for some GNOME
+libraries part of the GNOME Desktop.
diff --git a/x11-toolkits/py-gnome-desktop/pkg-plist b/x11-toolkits/py-gnome-desktop/pkg-plist
new file mode 100644
index 000000000000..7f7cd743a321
--- /dev/null
+++ b/x11-toolkits/py-gnome-desktop/pkg-plist
@@ -0,0 +1,108 @@
+%%PYTHON_SITELIBDIR%%/gtk-2.0/gnome/applet.py
+%%PYTHON_SITELIBDIR%%/gtk-2.0/gnome/applet.pyc
+%%PYTHON_SITELIBDIR%%/gtk-2.0/gnome/applet.pyo
+%%PYTHON_SITELIBDIR%%/gtk-2.0/gnomeapplet.la
+%%PYTHON_SITELIBDIR%%/gtk-2.0/gnomeapplet.so
+%%PYTHON_SITELIBDIR%%/gtk-2.0/gnomeprint/__init__.py
+%%PYTHON_SITELIBDIR%%/gtk-2.0/gnomeprint/__init__.pyc
+%%PYTHON_SITELIBDIR%%/gtk-2.0/gnomeprint/__init__.pyo
+%%PYTHON_SITELIBDIR%%/gtk-2.0/gnomeprint/_print.la
+%%PYTHON_SITELIBDIR%%/gtk-2.0/gnomeprint/_print.so
+%%PYTHON_SITELIBDIR%%/gtk-2.0/gnomeprint/ui.la
+%%PYTHON_SITELIBDIR%%/gtk-2.0/gnomeprint/ui.so
+%%PYTHON_SITELIBDIR%%/gtk-2.0/gtksourceview.la
+%%PYTHON_SITELIBDIR%%/gtk-2.0/gtksourceview.so
+%%PYTHON_SITELIBDIR%%/gtk-2.0/gtop.la
+%%PYTHON_SITELIBDIR%%/gtk-2.0/gtop.so
+%%PYTHON_SITELIBDIR%%/gtk-2.0/mediaprofiles.la
+%%PYTHON_SITELIBDIR%%/gtk-2.0/mediaprofiles.so
+%%PYTHON_SITELIBDIR%%/gtk-2.0/metacity.la
+%%PYTHON_SITELIBDIR%%/gtk-2.0/metacity.so
+%%PYTHON_SITELIBDIR%%/gtk-2.0/nautilusburn.la
+%%PYTHON_SITELIBDIR%%/gtk-2.0/nautilusburn.so
+%%PYTHON_SITELIBDIR%%/gtk-2.0/totem/__init__.py
+%%PYTHON_SITELIBDIR%%/gtk-2.0/totem/__init__.pyc
+%%PYTHON_SITELIBDIR%%/gtk-2.0/totem/__init__.pyo
+%%PYTHON_SITELIBDIR%%/gtk-2.0/totem/plparser.la
+%%PYTHON_SITELIBDIR%%/gtk-2.0/totem/plparser.so
+%%PYTHON_SITELIBDIR%%/gtk-2.0/wnck.la
+%%PYTHON_SITELIBDIR%%/gtk-2.0/wnck.so
+libdata/pkgconfig/gnome-python-desktop-2.0.pc
+%%DOCSDIR%%/pygnomeprint/class-gnomeprintconfig.html
+%%DOCSDIR%%/pygnomeprint/class-gnomeprintcontext.html
+%%DOCSDIR%%/pygnomeprint/class-gnomeprintfont.html
+%%DOCSDIR%%/pygnomeprint/class-gnomeprintfontface.html
+%%DOCSDIR%%/pygnomeprint/class-gnomeprintglyphlist.html
+%%DOCSDIR%%/pygnomeprint/class-gnomeprintjob.html
+%%DOCSDIR%%/pygnomeprint/gnomeprint-class-reference.html
+%%DOCSDIR%%/pygnomeprint/index.html
+%%DOCSDIR%%/pygnomeprint/index.sgml
+%%DOCSDIR%%/pygnomeprint/pygnomeprint.devhelp
+%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuidialog.html
+%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuifontdialog.html
+%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuifontpreview.html
+%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuifontselection.html
+%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuijobpreview.html
+%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuipaperselector.html
+%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuipreview.html
+%%DOCSDIR%%/pygnomeprintui/gnomeprintui-class-reference.html
+%%DOCSDIR%%/pygnomeprintui/index.html
+%%DOCSDIR%%/pygnomeprintui/index.sgml
+%%DOCSDIR%%/pygnomeprintui/pygnomeprintui.devhelp
+%%DOCSDIR%%/pygtksourceview/class-gtksourcebuffer.html
+%%DOCSDIR%%/pygtksourceview/class-gtksourcelanguage.html
+%%DOCSDIR%%/pygtksourceview/class-gtksourcelanguagesmanager.html
+%%DOCSDIR%%/pygtksourceview/class-gtksourcemarker.html
+%%DOCSDIR%%/pygtksourceview/class-gtksourceprintjob.html
+%%DOCSDIR%%/pygtksourceview/class-gtksourcestylescheme.html
+%%DOCSDIR%%/pygtksourceview/class-gtksourcetag.html
+%%DOCSDIR%%/pygtksourceview/class-gtksourcetagstyle.html
+%%DOCSDIR%%/pygtksourceview/class-gtksourcetagtable.html
+%%DOCSDIR%%/pygtksourceview/class-gtksourceview.html
+%%DOCSDIR%%/pygtksourceview/gtksourcesview-class-reference.html
+%%DOCSDIR%%/pygtksourceview/index.html
+%%DOCSDIR%%/pygtksourceview/index.sgml
+%%DOCSDIR%%/pygtksourceview/pygtksourceview.devhelp
+share/examples/py-gnome/applet/GNOME_PythonAppletSample.server
+share/examples/py-gnome/applet/README
+share/examples/py-gnome/applet/applet.py
+share/examples/py-gnome/gnomeprint/README
+share/examples/py-gnome/gnomeprint/example_01.py
+share/examples/py-gnome/gnomeprint/example_02.py
+share/examples/py-gnome/gnomeprint/example_03.py
+share/examples/py-gnome/gnomeprint/example_04.py
+share/examples/py-gnome/gnomeprint/example_05.py
+share/examples/py-gnome/gnomeprint/example_06.py
+share/examples/py-gnome/gnomeprint/example_08.py
+share/examples/py-gnome/gnomeprint/example_09.py
+share/examples/py-gnome/gnomeprint/example_10.glade
+share/examples/py-gnome/gnomeprint/example_10.py
+share/examples/py-gnome/gnomeprint/example_11.py
+share/examples/py-gnome/gnomeprint/sample-image.png
+share/examples/py-gnome/gnomeprint/test-print.py
+share/examples/py-gnome/gtksourceview/test-widget.py
+share/examples/py-gnome/mediaprofiles/profiles.py
+share/examples/py-gnome/nautilusburn/blank_disc.py
+share/examples/py-gnome/nautilusburn/drive_selection.py
+share/examples/py-gnome/nautilusburn/write_iso.py
+share/pygtk/2.0/defs/applet.defs
+share/pygtk/2.0/defs/art.defs
+share/pygtk/2.0/defs/gtksourceview.defs
+share/pygtk/2.0/defs/mediaprofiles.defs
+share/pygtk/2.0/defs/metacity.defs
+share/pygtk/2.0/defs/nautilus_burn.defs
+share/pygtk/2.0/defs/nb_drive_selection.defs
+share/pygtk/2.0/defs/print.defs
+share/pygtk/2.0/defs/printui.defs
+share/pygtk/2.0/defs/wnck.defs
+%%PORTDOCS%%@dirrm share/examples/py-gnome/nautilusburn
+%%PORTDOCS%%@dirrm share/examples/py-gnome/mediaprofiles
+%%PORTDOCS%%@dirrm share/examples/py-gnome/gtksourceview
+%%PORTDOCS%%@dirrm share/examples/py-gnome/gnomeprint
+%%PORTDOCS%%@dirrm share/examples/py-gnome/applet
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/pygtksourceview
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/pygnomeprintui
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/pygnomeprint
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%PYTHON_SITELIBDIR%%/gtk-2.0/totem
+@dirrm %%PYTHON_SITELIBDIR%%/gtk-2.0/gnomeprint