aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/py-gtkscintilla/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-12-14 20:24:39 +0800
committersobomax <sobomax@FreeBSD.org>2000-12-14 20:24:39 +0800
commitb20f355787e3aff9fa41c7d71287dd2c43c06a3f (patch)
treec98544e52edbe7371cb3d917d23aef00e2d0cf56 /x11-toolkits/py-gtkscintilla/Makefile
parentf544f3f8c48d1b66d4c1e7d3f17e8b8e65c0bd2e (diff)
downloadfreebsd-ports-gnome-b20f355787e3aff9fa41c7d71287dd2c43c06a3f.tar.gz
freebsd-ports-gnome-b20f355787e3aff9fa41c7d71287dd2c43c06a3f.tar.zst
freebsd-ports-gnome-b20f355787e3aff9fa41c7d71287dd2c43c06a3f.zip
Add py-gtkscintilla - a Python bindings for GtkScintilla library.
Diffstat (limited to 'x11-toolkits/py-gtkscintilla/Makefile')
-rw-r--r--x11-toolkits/py-gtkscintilla/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-toolkits/py-gtkscintilla/Makefile b/x11-toolkits/py-gtkscintilla/Makefile
new file mode 100644
index 000000000000..e09439825b44
--- /dev/null
+++ b/x11-toolkits/py-gtkscintilla/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: py-gtkscintilla
+# Date created: 14 December 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= py-gtkscintilla
+PORTVERSION= 0.1
+CATEGORIES= x11-toolkits python
+MASTER_SITES= http://www.moleskine.f2s.com/
+DISTNAME= PyGtkScintilla-${PORTVERSION}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= gtkscintilla.0:${PORTSDIR}/x11-toolkits/gtkscintilla
+
+USE_PYTHON= yes
+USE_GTK= yes
+USE_GMAKE= yes
+MAKE_ENV= PYTHON_INCLUDEDIR="${PYTHON_INCLUDEDIR}"
+
+INST_DIR= ${PREFIX}/lib/${PYTHON_VERSION}/site-packages
+
+post-build:
+ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${WRKSRC}
+
+do-install:
+ ${MKDIR} ${INST_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/_gtkscintillamodule.so ${INST_DIR}
+.for file in gtkscintilla.py GTKSCINTILLA.py
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${WRKSRC}/${file}c ${INST_DIR}
+.endfor
+
+.include <bsd.port.mk>